Bug 787781 - Lorax Templates are deleting required binaries post usrmove
Lorax Templates are deleting required binaries post usrmove
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Alpha/F17AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-02-06 12:48 EST by Tim Flink
Modified: 2012-02-15 23:04 EST (History)
5 users (show)

See Also:
Fixed In Version: lorax-17.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-15 23:04:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Fix-removefrom-lines-in-templates-to-work-with-usr-m.patch (8.65 KB, patch)
2012-02-07 17:43 EST, Will Woods
no flags Details | Diff

  None (edit)
Description Tim Flink 2012-02-06 12:48:28 EST
With usrmove for F17, a lot of required binaries have moved and the lorax templates aren't working as they should be.

A patch has been submitted to anaconda-devel:
https://www.redhat.com/archives/anaconda-devel-list/2012-February/msg00021.html

The patch is available at:
http://tflink.fedorapeople.org/packages/lorax/0001-patching-lorax-to-work-with-F17-usrmove.patch

I built a new x86_64 RPM locally using that patch:
http://tflink.fedorapeople.org/packages/lorax/lorax-17.3-usrmove1.fc17.x86_64.rpm
Comment 1 Tim Flink 2012-02-06 12:51:53 EST
Since the images composed with the older version of Lorax don't boot into X or allow for any installation, submitting as a blocker for F17 alpha under the following F17 alpha release criterion [1]:

The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media

[1] https://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria
Comment 2 Will Woods 2012-02-07 17:43:44 EST
Created attachment 560077 [details]
0001-Fix-removefrom-lines-in-templates-to-work-with-usr-m.patch

I think most of the stuff in the patch is unnecessary because symlinks should make it all work - it's really just the removefrom stuff that's having trouble (because the filelists of the RPMs have changed and filelists don't care about symlinks).

Could you try with this patch and let me know if that works?
Comment 3 Tim Flink 2012-02-08 13:41:31 EST
I built a test installer with the patch from comment #2 and it is able to create a working minimal install inside a VM (as long as you aren't using virtio disks).

Since the virtio problem (#788662) goes away post-install as soon as I change the VM configuration, I can't see how it would be lorax related.
Comment 4 Will Woods 2012-02-08 14:13:28 EST
Okay! Pushed to lorax master as commit e9d34e3.

Since there's a different bug for the virtio thing, let's close this once we can confirm that the binaries that should be present are present.
Comment 5 Adam Williamson 2012-02-10 12:26:32 EST
Discussed at 2012-02-10 blocker review meeting. Accepted as a blocker per criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media". A fixed lorax has been built and TC2 was composed with it, so this can likely be closed, but Tim will re-test with TC2 and confirm before we close it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-02-15 23:04:33 EST
the Alpha TC and RC composes have clearly been okay, so let's mark this as fixed. lorax 17.4 is in stable.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.