Bug 787787 - mkefiboot crashes with --apple option by using old mkfs command
mkefiboot crashes with --apple option by using old mkfs command
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Alpha/F17AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-02-06 13:10 EST by Tim Flink
Modified: 2012-02-10 12:39 EST (History)
6 users (show)

See Also:
Fixed In Version: lorax-17.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 12:39:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2012-02-06 13:10:02 EST
While creating the EFI boot image for apple machines, lorax calls mkfs.hfs and crashes with a 'no such file or directory' error from the subprocess call.

[root@f17rawhide fedora_images]# mkefiboot --label=ANACONDA --apple --icon=/home/tflink/fedora_images/work/Fedora/x86_64/installroot/usr/share/pixmaps/bootloader/fedora.icns /home/tflink/fedora_images/f17usrmove-test1/Fedora/x86_64/os/EFI/BOOT /home/tflink/fedora_images/f17usrmove-test1/Fedora/x86_64/os/images/macboot.img
Traceback (most recent call last):
  File "/sbin/mkefiboot", line 105, in <module>
    mkmacboot(opt.bootdir, opt.outfile, opt.label, opt.icon)
  File "/sbin/mkefiboot", line 35, in mkmacboot
    mkhfsimg(None, outfile, label=label, graft=graft)
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 294, in mkhfsimg
    mkfsargs=["-v", label], graft=graft)
  File "/usr/lib/python2.7/site-packages/pylorax/imgutils.py", line 273, in mkfsimage
    stdout=PIPE, stderr=PIPE)
  File "/usr/lib64/python2.7/subprocess.py", line 506, in check_call
    retcode = call(*popenargs, **kwargs)
  File "/usr/lib64/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1228, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Comment 1 Tim Flink 2012-02-06 13:11:28 EST
Submitting as F17 alpha blocker because it blocks image composition.
Comment 2 Tim Flink 2012-02-06 13:15:33 EST
I patched lorax locally such that it doesn't crash during image compose and I suspect that everything will work but I don't have a mac to test with.

I'm planning to submit the lorax patch shortly (it's a small one-liner).

The test iso is available at:
http://tflink.fedorapeople.org/iso/20120206_hfspatchtest.boot.iso
http://tflink.fedorapeople.org/iso/20120206_hfspatchtest.boot.iso.sha256
Comment 3 Tim Flink 2012-02-06 13:27:57 EST
Patch has been submitted to anaconda-devel-list:
https://www.redhat.com/archives/anaconda-devel-list/2012-February/msg00034.html

Patch is available at:
http://tflink.fedorapeople.org/packages/lorax/0001-changing-hfs-to-hfsplus-so-that-the-correct-mkfs-bin.patch

Locally built rpm with this patch and the patch to fix #787781 is available at:
http://tflink.fedorapeople.org/packages/lorax/lorax-17.3-usrmove2.fc17.x86_64.rpm
Comment 4 satellitgo 2012-02-06 14:59:05 EST
20120206_hfspatchtest.boot.iso burned to CD:

Macbook Pro i7 shows 3 additional icons on boot with "options "Key held down:
Macintosh HD

Windows   (CD) 
 Boots to start screen
  Install or upgrade fedora
  Troubleshooting

EFI Boot  (CD)
EFI Boot (Fedora Branding)
Both Boot to Grub 0.97-85.f17 prompt:
Comment 5 Will Woods 2012-02-07 17:27:58 EST
Patch from comment #3 has been applied and is in upstream git.
Comment 6 Adam Williamson 2012-02-10 12:39:19 EST
Discussed at 2012-02-10 blocker review meeting. Fix for this issue was included in the lorax used for TC2 and the issue is resolved, so closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.