Bug 787855 - "Cannot open ConsoleKit session" when logging in
Summary: "Cannot open ConsoleKit session" when logging in
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-workspace
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 786157
TreeView+ depends on / blocked
 
Reported: 2012-02-06 22:36 UTC by nucleo
Modified: 2012-04-19 00:45 UTC (History)
8 users (show)

Fixed In Version: kde-workspace-4.8.0-11.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-28 10:51:46 UTC


Attachments (Terms of Use)

Description nucleo 2012-02-06 22:36:59 UTC
Description of problem:
There is warning message when logging in from kdm "Cannot open ConsoleKit session".

Version-Release number of selected component (if applicable):


Steps to Reproduce:
1. Try to login in kdm on livecd
2.
3.
  
Actual results:
Window with warning displayed:
http://img692.imageshack.us/img692/1171/errorzg.png
KDE starting after pressing OK.

Comment 1 Kevin Kofler 2012-02-06 22:48:01 UTC

*** This bug has been marked as a duplicate of bug 786157 ***

Comment 2 Kevin Kofler 2012-02-07 16:05:04 UTC
Actually, let's keep #786157 as a tracker, since there are at least 2 separate issues.

Comment 3 nucleo 2012-02-14 00:25:11 UTC
ConsoleKit is installed on las nightly CD but there is other error now:
http://img706.imageshack.us/img706/2475/consolekit.png
Cannot open ConsoleKit session: Unable yo open session: Unable to get information about calling process.
But after OK logged in as it should.

Comment 4 Kevin Kofler 2012-02-15 02:18:53 UTC
So, do we have any idea what's up with this one yet?

Comment 5 Rex Dieter 2012-02-15 11:31:15 UTC
Seems xorg-x11-xinit no longer includes ck bits, maybe that's relevant.

/etc/X11/xinit/Xsession includes:
. /etc/X11/xinit/xinitrc-common

and xinitrc-common contained:

CK_XINIT_SESSION=
if [ -z "$XDG_SESSION_COOKIE" ] && [ -x /usr/bin/ck-xinit-session ]; then
    CK_XINIT_SESSION="/usr/bin/ck-xinit-session"
fi

which isn't there anymore.

Comment 6 Kevin Kofler 2012-02-15 16:18:19 UTC
That shouldn't be needed with KDM because KDM integrates ConsoleKit natively. It wasn't there in F7 either. It got added later to make DMs without native ConsoleKit integration work (at least for local sessions).

Comment 7 Orion Poplawski 2012-02-21 23:44:42 UTC
kdm in debug mode outputs:

arguments to ck_connector_get_cookie() were incorrect, assertion "connector != NULL" failed in file ck-connector.c line 583.

Comment 8 Rex Dieter 2012-02-22 15:16:04 UTC
%changelog
* Wed Feb 22 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.0-10
- kdm: Requires: ConsoleKit-x11 (#787855)

this fixes it for me.

Comment 9 Fedora Update System 2012-02-22 16:36:16 UTC
kde-workspace-4.8.0-10.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-workspace-4.8.0-10.fc17

Comment 10 Fedora Update System 2012-02-22 17:45:55 UTC
Package kde-workspace-4.8.0-10.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.8.0-10.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2201/kde-workspace-4.8.0-10.fc17
then log in and leave karma (feedback).

Comment 11 Rex Dieter 2012-02-22 17:47:58 UTC
OK, alternative approach, removing CK support altogether, functionality is essentially handled by systemd-logind these days.

%changelog
* Wed Feb 22 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.0-11
- drop ConsoleKit support f17+

Comment 12 Kevin Kofler 2012-02-22 22:07:27 UTC
Well, shutdown/restart without KDM isn't going to work without ConsoleKit as long as the systemd shutdown support is not implemented, see bug #788171.

Comment 13 Fedora Update System 2012-02-23 22:30:34 UTC
Package kde-workspace-4.8.0-11.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.8.0-11.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2201/kde-workspace-4.8.0-11.fc17
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2012-02-28 10:51:46 UTC
kde-workspace-4.8.0-11.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Adam Williamson 2012-04-19 00:45:12 UTC
Dropping Commonbugs nomination, as this was fixed well ahead of Beta.


Note You need to log in before you can comment on or make changes to this bug.