Bug 78802 - 1400x1050 will not work using generated XFree86
1400x1050 will not work using generated XFree86
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2002-11-30 15:03 EST by John MacLean
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 03:16:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John MacLean 2002-11-30 15:03:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
Selecting 1400x1050 will result in an "Sync out of Range" error message from the
monitor

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select 1400x1050 resolution
2. Restart X
3. 
	

Actual Results:  Monitor blanks and display "Sync out of range - 52.4 KHz 17Hz
NN" message. Numbers vary.

Expected Results:  A working 1400x1050 X.

Additional info:

Monitor: Samsung SyncMaster 900NF
Video: (built-by) ATI Radeon 7500

Cross-reference bugzilla bug 63593.

1400x1050 will work with the following modelines added to XFree86.

# 1400x1050 @ 60Hz
Modeline "1400x1050" 129 1400 1464 1656 1960 1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 70Hz
Modeline "1400x1050" 151 1400 1464 1656 1960 1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 75Hz
Modeline "1400x1050" 162 1400 1464 1656 1960 1050 1051 1054 1100 +HSync +VSync

# 1400x1050 @ 85Hz
# Gives 'Sync out of range error', do not use
#       Modeline "1400x1050" 184 1400 1464 1656 1960 1050 1051 1054 1100 +HSync
+VSync
Comment 1 Brent Fox 2002-12-23 02:12:48 EST
What does '/usr/sbin/ddcprobe' say?
Comment 2 John MacLean 2002-12-31 10:22:19 EST
# /usr/sbin/ddcprobe

Videocard DDC probe results
Description:  ATI Technologies Inc. V200
Memory (MB):  64

Monitor DDC probe results
ID: SAM38d9
Name: Samsung SyncMaster 900NF
Horizontal Sync (kHZ): 30-110
Vertical Sync (HZ)  : 50-160
Width (mm): 360
Height(mm): 270


Comment 3 Brent Fox 2003-01-06 01:46:18 EST
Hmm, I'm not really sure what's going on here.  I don't think that
redhat-config-xfree86 wrote that 1400x1050 ModeLine in the file...perhaps
anaconda did.  If the invalid modeline was already in the XF86Config file,
redhat-config-xfree86 will not override those manual additions.

In the Poebe beta, we've finally gotten redhat-config-xfree86 and anaconda using
the same backend, so maybe this problem won't happen in the future.

Try this:  make a backup of the /etc/X11/XF86Config file and then delete the
original.  Then try running redhat-config-xfree86 and generate an XF86Config
file from scratch.  If that still doesn't work, try upgrading to
redhat-config-xfree86-0.7.1-2 out of Rawhide and try again.  A lot of code in
redhat-config-xfree86 has changed since 8.0, so I'm anxious to know if the
latest versions are solving some of the problems people have been seeing.
Comment 4 John MacLean 2003-01-06 21:10:47 EST
Sorry, I may have confused you. Anaconda and redhat-config-xfree86 do not add
any Modelines. Both do allow me to select 1400x1050 configuration and the
resulting XF86Config gives a working XFree86 (unlike on RHL 7.x which gives an
FPE, see bug 63593) but the monitor shows a "Sync. Out of Range" message. If I
manually insert the indicated modelines then 1400x1050 does work.


I just updated to xfree86-redhat-xfree86-0.7.1-3 (also, due to dependencies,
rhpl-0.74-1 and pyxf86config-0.3.3-1). Started with a clean XF86Config. Selected
1400x1050 resolution. Still get a "Sync. Out of Range" message from the monitor.

As you expect, no Modelines inserted by redhat-config-xfree86. 'Section
"Monitor"' now has a new line, 
	DisplaySize  360	270

Otherwise it looks pretty much like the one created when I installed Psyche. 
Manually inserted the modelines and 1400x1050 works
Comment 5 Brent Fox 2003-01-14 00:32:20 EST
When you go to the "Advanced" tab, is the right monitor selected in the list? 
Also, what if you try a resolution other than 1400x1050?  Do any of them work
out of the box or do all of them fail?
Comment 6 John MacLean 2003-01-14 16:59:55 EST
Advanced tab looks correct. Samsung SyncMaster 900NF, 30.0-110.0 Horiz, &
50.0-160.0 Vert. 
DPI is 99x99. Don't know what this should be.
Video card looks ok too, Radeon 7500, 64MB, radeon driver. I have hw 3D
disabled. And before you ask it is a real, built-by-ATI 7500.
Haven't tried 1920x1440 but all others work OOTB.
Comment 7 Brent Fox 2003-01-17 15:59:00 EST
mharris: Do you have any ideas about what would cause this?  It seems to me like
the original file that redhat-config-xfree86 writes out should be capable of
doing 1400x1050 without needing the modelines added by hand.  Any ideas as to
why this is not the case?
Comment 8 Mike A. Harris 2003-01-18 06:09:40 EST
Modelines should be built into the X server, not into the config tool.

I will investigate this issue in the customized modelines we include
in the server.  If they do not work, then there is a bug in the
X server code.
Comment 9 Mike A. Harris 2004-09-24 14:54:38 EDT
1400x1050 video modes work for me on local systems.

Please upgrade to Fedora Core 2 or later, and if this issue turns
out to still be reproduceable, please file a bug report in the
X.Org bugzilla located at http://bugs.freedesktop.org in the
"xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes
that become available for consideration in future updates.
Comment 10 Ville Skyttä 2004-09-26 10:36:57 EDT
FYI: I have been witnessing this bug as well for a long time,
identical symptoms both with identical H/W (Radeon 7500, Syncmaster
900NF), and this week after changing the 7500 to a Radeon 9200SE
(manufactured by Club3D).  The issue still exists in FC2.

I don't know if it makes sense to report this to freedesktop.org
Bugzilla, because the 6.7.0 shipped with FC2 is no longer the latest
one.  I cannot upgrade to FC3test* at the moment, but will revisit later.

If I have no 1400x1050 entries in xorg.conf, I get the "sync out of
range" message.  Ditto for the 85Hz modeline in the initial comment. 
Adding this modeline to it gives me a working 1400x1050@83Hz:

Modeline "1400x1050" 178 1400 1464 1656 1960 1050 1051 1054 1100
+HSync +VSync
Comment 12 Mike A. Harris 2004-09-27 15:48:39 EDT
http://products.consumerguide.com/cp/electronics/review/index.cfm/id/23496

"The display's maximum resolution is 1,600x1,200, with a refresh rate
of 75Hz."

85Hz at 1400x1050 might be just outside of the reach of this
monitor's range.
Comment 13 Mike A. Harris 2004-09-27 15:50:05 EDT
Can everyone who can reproduce this please attach your X server
config file and log file?  The X server startup messages will
be very useful in diagnosing the problem.

Thanks in advance.
Comment 14 Ville Skyttä 2004-09-27 17:43:51 EDT
I'm speechless.  I did:
- checked the monitor's manual (available from
http://www.samsung.com/Support/ProductSupport/download/Model_Select.aspx?type=Monitor&typecode=102050&subtypecode=370018&model=900NF&filetype=UM)
- it says 1600x1200 @ 87Hz should work (IIRC)
- booted to Windows (ugh) to check 1400x1050 there
- found that there's no such option, tested 1600x1200 @ 85Hz while at it
- booted back to FC2 runlevel 3
- commented out my modeline in comment 11 from xorg.conf (result: no
Modelines defined in xorg.conf)
- did a init 5... and it suddenly works at 1400x1050 @ 85Hz ?!?

I have zero clue what happened, but I can no longer reproduce the
problem.  Sorry about the noise; as far as I'm concerned, this can be
re-closed.

OT: I still get the "sync out of range" message if I enable
AGPFastWrite in xorg.conf (I have AGPMode 4 and EnablePageFlip on
there already, they work).  AGPFastWrite did work with my old Radeon
7500, but it doesn't now with the 9200SE (otherwise identical hardware
and settings).  And EnablePageFlip didn't work with the 7500, but
works now with the 9200SE.  WDYT, should this be reported somewhere
(radeon(4) talks about potential problems with EnablePageFlip, but not
AGPFastWrite)?
Comment 15 Mike A. Harris 2004-09-27 18:47:33 EDT
Ok, thanks for the update Ville.

John, can you confirm wether this problem still exists for you?

Thanks.
Comment 16 Mike A. Harris 2004-09-30 03:16:29 EDT
Closing bug as "CURRENTRELEASE".  If the problem occurs again
for anyone, please reopen the bug report and attach the information
requested in comment #13 above, and we'll re-investigate the
issue.

Thanks.
Comment 17 John MacLean 2004-10-01 01:25:21 EDT
This bug is dead. 
"#mv xorg.cong xorg.conf~" then used system-config-display to
regenerate the config. Reloaded and 1400x1050 working (and xvidtune
reports Vsync at 85Hz). FC2 xorg-X11-6.7.0-5.

Also working on FC3T2, same monitor and but a Mobile Radeon 7500
inside an IBM T42.

I can't add anything further re Ville's comments when setting various
AGP options. They weren't present in my old config either.

Thanks Mike.
Comment 18 Mike A. Harris 2004-10-01 01:41:30 EDT
John,

Thanks for the additional confirmation update.  Much appreciated.

Note You need to log in before you can comment on or make changes to this bug.