Bug 788246 - GraphicsMagick 1.3.13 update breaks some PNGs
GraphicsMagick 1.3.13 update breaks some PNGs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: Regression
: 803578 812645 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 15:49 EST by Ville Skyttä
Modified: 2012-12-20 11:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Reproducer PNG broken by 1.3.13 update (594 bytes, image/png)
2012-02-07 15:50 EST, Ville Skyttä
no flags Details
Reproducer PNG as shown by "gm display" from 1.3.13 (354 bytes, image/png)
2012-02-07 15:52 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2012-02-07 15:49:53 EST
The GraphicsMagick 1.3.13-3 F-16 update breaks some, but not all PNGs.  The broken ones appear as if some vertical empty space/interlacing was added to them.  No such problems with earlier GraphicsMagick versions.

Some reproducer files attached.
Comment 1 Ville Skyttä 2012-02-07 15:50:36 EST
Created attachment 560057 [details]
Reproducer PNG broken by 1.3.13 update
Comment 2 Ville Skyttä 2012-02-07 15:52:10 EST
Created attachment 560058 [details]
Reproducer PNG as shown by "gm display" from 1.3.13
Comment 3 Rex Dieter 2012-02-07 15:54:40 EST
So, the png in comment #1 was created by gm or is the source used in comment #2?
Comment 4 Ville Skyttä 2012-02-07 16:01:29 EST
The PNG in comment 1 is just a random PNG that GM 1.3.13 has problems with, no idea what it was created with.

The PNG in comment 2 is a screenshot of how the PNG from comment 1 looks with GM 1.3.13's "gm display" (I should probably have attached this one as a BMP or something else than PNG to reduce confusion).
Comment 5 Rex Dieter 2012-02-07 16:24:25 EST
ok, thanks.

I'll see if the impact is limited to or goes beyond the use of 'gm display'
Comment 6 Rex Dieter 2012-02-07 16:53:58 EST
OK, GM-1.1.13 does not like this image alright, pretty much any operation botches it.

Bug opened upstream,
https://sourceforge.net/tracker/?func=detail&aid=3485509&group_id=73485&atid=537937
Comment 7 Rex Dieter 2012-02-07 16:55:54 EST
I'll see about diff'ing gm-1.1.12 -> 1.1.13 coders/png.c for anything obviously wrong.  it was updated to support libpng-1.5 (as in rawhide, but apparently there's some regression going on here with f16/libpng-1.2.x)
Comment 8 Bob Friesenhahn 2012-02-07 22:18:47 EST
I am able to reproduce the problem here as well.  I see the same problem with libpng 1.5.6 and libpng 1.2.46.  While there were a number of known problems with the PNG writer, this is the first issue I am aware of with the reader.
Comment 9 Rex Dieter 2012-03-01 14:59:48 EST
confirmed still an issue with 1.3.14
Comment 10 Ville Skyttä 2012-03-17 15:57:55 EDT
*** Bug 803578 has been marked as a duplicate of this bug. ***
Comment 11 Ville Skyttä 2012-03-17 15:58:52 EDT
Any progress on this or thoughts when it might be fixed?
Comment 12 Rex Dieter 2012-03-18 21:51:59 EDT
Ville, 
this has been reported upstream,
https://sourceforge.net/tracker/?func=detail&aid=3485509&group_id=73485&atid=537937

and it's been acknowledged/confirmed (see Bob's comment #8 as well as that referenced in the upstream report).
Comment 13 Bob Friesenhahn 2012-03-19 10:07:37 EDT
I am hoping that Glenn Randers-Pehrson will be able to complete the fixes to (or rewrite of) GM's png.c.  Progress has been slow since he would like to do the job correctly and has other responsibilities.  It seems likely that the issues were introduced due to the port to libpng 1.4.X and then libpng 1.5.X.
Comment 14 Ville Skyttä 2012-04-15 14:20:38 EDT
*** Bug 812645 has been marked as a duplicate of this bug. ***
Comment 15 Ville Skyttä 2012-07-08 10:24:50 EDT
Confirmed still an issue with 1.3.16.
Comment 16 Fedora Update System 2012-10-16 16:00:50 EDT
GraphicsMagick-1.3.17-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.17-1.fc17
Comment 17 Fedora Update System 2012-10-16 16:02:01 EDT
GraphicsMagick-1.3.17-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.17-1.fc16
Comment 18 Fedora Update System 2012-10-16 16:02:50 EDT
GraphicsMagick-1.3.17-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.17-1.el6
Comment 19 Fedora Update System 2012-10-17 09:05:58 EDT
GraphicsMagick-1.3.17-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.17-1.el5
Comment 20 Fedora Update System 2012-10-17 20:21:04 EDT
Package GraphicsMagick-1.3.17-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GraphicsMagick-1.3.17-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16336/GraphicsMagick-1.3.17-1.fc16
then log in and leave karma (feedback).
Comment 21 Otto J. Makela 2012-10-20 12:16:28 EDT
Quick testing seems to indicate this new testing version 1.3.17-1 does not cause the problems that were associated with 1.3.13-3, will leave feedback.
Comment 22 Fedora Update System 2012-12-20 11:20:41 EST
GraphicsMagick-1.3.17-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.