Bug 812645 - Spumux not muxing png/xml subtitles properly
Spumux not muxing png/xml subtitles properly
Status: CLOSED DUPLICATE of bug 788246
Product: Fedora
Classification: Fedora
Component: dvdauthor (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-15 13:02 EDT by Mohamed AMAZIRH
Modified: 2012-04-15 14:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-15 14:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xml+png and video to test with (6.43 MB, application/x-bzip)
2012-04-15 13:02 EDT, Mohamed AMAZIRH
no flags Details

  None (edit)
Description Mohamed AMAZIRH 2012-04-15 13:02:28 EDT
Created attachment 577567 [details]
xml+png and video to test with

Description of problem:
After an update, spumux no longer muxes xml/png subtitles properly (not .srt).

I used the upstream package and it muxes the subtitles properly. 

Version-Release number of selected component (if applicable):


How reproducible:
I made an XML file and 3 png files each representing a subtitle (Found in the attachment).
Then I used spumux from fedora 16 to mux the pngs into a simple mpeg2 video.

Steps to Reproduce:

using the attached files, try 

spumux -m dvd sub.xml < vid_without_subs.mpg > output.mpg

then compare output.mpg with spumux_original.mpg (using mplayer)
  
Actual results:
2 subtitles don't show up on the screen. (first should show up from 1s -> 5s at the top of the video, second from 9s->12s at the bottom)
The third subtitle is not displayed correctly (13s -> 30s)
Comment 1 Mohamed AMAZIRH 2012-04-15 13:47:43 EDT
I just found out that the root of the problem is GraphicsMagick and not spumux.
The spumux binary I built from the upstream package works because it doesn't include support for GraphicsMagick, while the one from Fedora16 does.

I downgraded the GraphicsMagick package and spumux is working as expected now.


Output of upstream spumux binary:
>>DVDAuthor::spumux, version 0.7.0.
>>Build options: gnugetopt iconv freetype fribidi fontconfig

Output of Fedora16's spumux binary:
>>DVDAuthor::spumux, version 0.7.0.
>>Build options: gnugetopt graphicsmagick iconv freetype fribidi fontconfig
Comment 2 Ville Skyttä 2012-04-15 14:20:38 EDT

*** This bug has been marked as a duplicate of bug 788246 ***

Note You need to log in before you can comment on or make changes to this bug.