Bug 78830 - gnome2-info2html infinite loop when started from redhat-config-network
gnome2-info2html infinite loop when started from redhat-config-network
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: yelp (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
N/A
:
: 80236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-01 15:03 EST by David Masterson
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 07:44:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Masterson 2002-12-01 15:03:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When trying to get help in redhat-config-network, I get the index for "Network
Configuration", but I hang after selecting a topic.  It appears that
gnome2-info2html goes into an infinite loop.

Version-Release number of selected component (if applicable):
libgnome-2.0.2-5

How reproducible:
Always

Steps to Reproduce:
1.Start redhat-config-network in any fashion.
2.Click on "Help"
3.Click on "Introduction" or "Overview".
	

Actual Results:  Yelp puts up a "Loading" window waiting for gnome2-info2html to
finish, but it never does.

Expected Results:  The chosen topic should come back pretty fast as I am running
on a dual CPU Athlon system with lots of memory and disk space.

Additional info:

This may not be related.  When I click on Help in redhat-config-network, I get
the following messages:

(neat:2207): Gnome-CRITICAL **: file gnome-program.c: line 738
(gnome_program_get_app_id): assertion `program != NULL' failed

(neat:2207): GConf-CRITICAL **: file gconf-client.c: line 545
(gconf_client_add_dir): assertion `gconf_valid_key (dirname, NULL)' failed
Comment 1 Michael Lee Yohe 2002-12-01 16:36:23 EST
Confirming - I also see this problem.

$ rpm -q redhat-config-network
redhat-config-network-1.1.20-1
Comment 2 Michael Lee Yohe 2002-12-02 09:50:56 EST
This priority should be upgraded to HIGH.  Its severity rating might also need
to be upgraded since it can render a machine slow without any means of
correcting it (without manually finding and killing the gnome2-info2html
process).  The component may need to be switched to libgnome since the race
condition should also be detected by gnome2-info2html.

Reason?  Since redhat-config-network runs as root, gnome2-info2html also gets
spawned with root privileges and will consume almost all CPU until a super-user
kill ends the process.  Killing redhat-config-network will not perpetuate a
SIGTERM down to gnome2-info2html.
Comment 3 Harald Hoyer 2002-12-02 10:18:45 EST
This is executed:
import gnome
gnome.url_show("ghelp:///usr/share/redhat-config-network/help/index.html")

Assigning to yelp
Comment 4 Alexander Larsson 2002-12-03 05:02:05 EST
It looks like neat has to call gnome_program_init for show_url to work.
Comment 5 jerry asher 2002-12-25 15:09:10 EST
This is not a workaround (except for su'ers), but I think it is interesting to
note that if I kill -9 the gnome2-info2html process, then the Help Browser does
come back, and does show the intended page.

I do think the priority or severity of this bug should be increased.  Imagine my
chagrin this morning to find that our webserver has been spending most of its
cycles navel gazing instead of cycling pages.  It's probably been doing that for
a day or so now.  Yeah, I don't have enough resources for a dedicated sysadmin.
 I suspect that's a good chunk of your market.
Comment 6 Harald Hoyer 2003-01-13 08:13:41 EST
even does not work if gnome_program_init was called before...
why is info2html called?? these pages are already in html???
Comment 7 Alexander Larsson 2003-01-17 07:53:26 EST
harald: I'm not sure what you mean here. In the latest beta, when i click on
help in r-c-network i get a mozilla window, not yelp.
Comment 8 Jef Spaleta 2004-02-11 19:32:33 EST
*** Bug 80236 has been marked as a duplicate of this bug. ***
Comment 9 Marco Pesenti Gritti 2004-11-06 07:44:34 EST
This has been changed to use the web browser instead of yelp and works
fine in current release.

Note You need to log in before you can comment on or make changes to this bug.