Bug 788300 - dracut-014-81.git20120202.fc17 generated initramfs breaks rebooting/shutdown
dracut-014-81.git20120202.fc17 generated initramfs breaks rebooting/shutdown
Status: CLOSED DUPLICATE of bug 788107
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-07 19:46 EST by Michal Jaegermann
Modified: 2012-02-08 03:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 20:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-02-07 19:46:15 EST
Description of problem:

Why initramfs has anything to do with reboot/halt/poweroff/shutdown is really a mystery but this happens when running a kernel with initramfs which was created by dracut-014-81.git20120202.fc17 and it is not the case when dracut-014-77.git20120126.fc17, or possibly earlier, was used.

If you try any of the above actions, by whatever means, then on a screen shows up a series of 'unmounting /oldroot/...' messages followed by something like:

halt: invalid optin -- 'd'
Dropping to debug shell

and a dracut prompt shows up.  Debugging does not work too well as whatever is typed is not echoed back, so is is necessary to do that in blind, and the best one can apparently achieve is "Failed to get D-Bus connection. No connection to service manager" if anything shows up back at all (with an exception of complaints of something mistyped).

Version-Release number of selected component (if applicable):
dracut-014-81.git20120202.fc17

How reproducible:
always

Additional info:
I just recalled that I have on a command line 'rd.info' option left after some older troubles but that should not have such nasty side-effects, shouldn't it?
Comment 1 Michal Jaegermann 2012-02-07 19:57:14 EST
(In reply to comment #0)

> I just recalled that I have on a command line 'rd.info' option left after some
> older troubles but that should not have such nasty side-effects, shouldn't it?

No, dropping 'rd.info' from a boot commmand does not have effect on the above. OTOH there is something which is causing another reaction from this "debugging shell".  Typing there in blind 'exit' is causing an instant panic and a complete machine lockup.
Comment 2 Kay Sievers 2012-02-07 20:18:54 EST
The 'mystery' is that the initramfs is the last part of the shutdown these days,
and it unmounts the rootfs and finally shuts down the box.

The bug is a bug in binutils and a miscompiled shutdown binary.

*** This bug has been marked as a duplicate of bug 788107 ***
Comment 3 Michal Jaegermann 2012-02-07 21:03:35 EST
(In reply to comment #2)
> 
> The bug is a bug in binutils and a miscompiled shutdown binary.
> 
> *** This bug has been marked as a duplicate of bug 788107 ***

Kay, are you really sure that this is a duplicate of bug 788107? 788107 implies that there are troubles when using "shortcuts" like 'reboot' or 'poweroff'.  Here there is the same ailment of landing blind in a debug shell when one tries
'systemctl reboot' or 'systemctl -f poweroff' and similar and these are "long forms".  If this is a really duplicate then what can be used to, say, shutdown the whole machine?  So far I did not find any suitable command.

Bug 788107 would be possibly responsible for a breakage described in bug 788304 (although not for an "Additional info:" part).
Comment 4 Michal Schmidt 2012-02-08 03:15:01 EST
Yes, we are sure it is a duplicate. /run/initramfs/shutdown eventually calls 'reboot', 'poweroff', or 'halt', which in the initramfs too are just symlinks to systemctl.

Note You need to log in before you can comment on or make changes to this bug.