Bug 788304 - systemd-40-1.fc17 breaks reboot/halt/poweroff/shutdown ...
systemd-40-1.fc17 breaks reboot/halt/poweroff/shutdown ...
Status: CLOSED DUPLICATE of bug 788107
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-02-07 20:27 EST by Michal Jaegermann
Modified: 2012-02-08 02:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-02-07 22:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2012-02-07 20:27:35 EST
Description of problem:

After updating to systemd-40-1.fc17 an attempt to execute commands like
'reboot' and/or other related results in dump of systemd units into a pager on a screen and that is it.  That means that effects are the same as if a bare 'systemctl' would be typed.  Reverting to systemd-39-3.fc17 unbreaks that.

'systemctl reboot' does have desired effects but, adding an insult to injury, this runs into a bug 788300 and one is dropped into "debugging shell".  There systemd leaves any pretense of a sanity and every attempt to communicate with it, in blind, ends up with a "Failed to get D-Bus connection. No connection to service manager" response and one is totally stuck.  A nice design of a critical component!

Version-Release number of selected component (if applicable):

How reproducible:
all the time 

Additional info:
It appears that "halt", when it can be coaxed to work, does stop the system but it does not bother to turn off a power.  One needs and explicit "poweroff" for the later.  For a long time "halt" and "poweroff" were really synonymous and this surprised me. AFAICS manpages do not bother to define what is expected from these actions leaving that to be guessed.  If all of sudden these two are supposed to be different then at least a mention in docs would be in order.  I am not sure when they diverged as, by a force of habit, I was usually using 'shutdown -h now'.  It is very far from clear what 'systemctl ...' equivalent of that would be.
Comment 1 Kay Sievers 2012-02-07 22:56:02 EST

*** This bug has been marked as a duplicate of bug 788107 ***
Comment 2 Michal Schmidt 2012-02-08 02:49:00 EST
(In reply to comment #0)
> It appears that "halt", when it can be coaxed to work, does stop the system but
> it does not bother to turn off a power.

The change from upstart's behaviour was documented in F15 release notes:
and in Fedora's systemd wiki page:

It is true that the man page does not define the semantics of the terms, but it does refer to Halt and Power-off as distinct actions.

Note You need to log in before you can comment on or make changes to this bug.