Bug 78845 - GinGin anaconda created boot disk does not boot.
GinGin anaconda created boot disk does not boot.
Status: CLOSED DUPLICATE of bug 80605
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-12-01 19:34 EST by Eugene Kanter
Modified: 2011-04-07 13:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2002-12-01 19:34:58 EST
Description of Problem:

GinGin anaconda created boot disk does not boot. Everything is normal up intil
kernel should start reading RAMDISK where it stops with no errors displayed.

The test system has had linux running from as early as 7.2 time without any
problems with bootdisks.
Comment 1 Leonid Kanter 2002-12-05 11:33:39 EST
Looks like this is not anaconda problem, but kernel/mkinitrd problem. If there is no 
scsi card in system, boot disk creation is OK. With scsi module, initrd and kernel are 
too big for 1.44 floppy! 
[root@leon root]# cat /etc/modules.conf | grep scsi_hostadapter 
alias scsi_hostadapter aic7xxx 
[root@leon root]# mkbootdisk 2.4.19-0.pp.15 
Insert a disk in /dev/fd0. Any information on the disk will be lost. 
Press <Enter> to continue or ^C to abort: 
gzip: stdout: No space left on device 
[root@leon root]# 
If I remove scsi_hostadapter line from /etc/modules.conf, boot disk creation is OK.
Comment 2 Eugene Kanter 2002-12-10 10:53:45 EST
Works in beta2
Comment 3 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 4 Eugene Kanter 2002-12-23 21:02:29 EST
Boot disk (e100 and aic7xxx) does not fit on a floppy again. Anaconda does not tell user that 
there is not enough space. Message is posted on one of the virtual consoles. 
I tried to format disk using fdformat /dev/fd0u1760 and run mkbootdisk but resulting image 
would not boot. 
Comment 5 Jeremy Katz 2003-01-03 00:57:39 EST
Added code to verify that the initrd we create is the same size to avoid problems
Comment 6 Eugene Kanter 2003-01-03 11:24:26 EST
Will the new initrd+kernel fit into regular 1.44 floppy or one needs to format
1.6 floppy? After I formatted /dev/fd0u1660, mkbootdisk created working bootdisk.
Comment 7 Eugene Kanter 2003-02-11 15:31:55 EST
Anaconda now clearly detects out of space conditions. What about attempting to
format /dev/fd0u1660 and try to recreate boot disk if regular 1.44 is not
enough? This works for me.
Comment 8 Mike McLean 2003-02-11 20:02:45 EST

*** This bug has been marked as a duplicate of 80605 ***
Comment 9 Red Hat Bugzilla 2006-02-21 13:50:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.