Bug 80605 - Hangs at RAMDISK: on boot from floppy
Hangs at RAMDISK: on boot from floppy
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 78845 (view as bug list)
Depends On: 81595
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-28 12:26 EST by Ted Kaczmarek
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-24 23:02:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Kaczmarek 2002-12-28 12:26:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20021225

Description of problem:
I just finished an install of Phoebe on my second scsi drive, when trying to
boot using floopy it hangs after it gets to
RAMDISK: compressed image at block 0.

This was an install over an existing Dell oem win2k setup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Phoebe on second scsi drive on Dell Precsion 330
2.Insert boot disk created during install in floppy
3. Try to boot off of floppy
    

Actual Results:  Hangs at 
RAMDISK: compressed image at block 0.

Expected Results:  Boot process completes

Additional info:
Comment 1 Ted Kaczmarek 2002-12-29 09:25:19 EST
I am able to boot using grub and the /boot from /dev/sda1. This is very simillar
to the problem I started having with 7.3 and beyond. I was informed of an issue
with recognizing ide drives and I have 2 cd roms in this machine along with 2
scsi drives. With 7.3 and 8.0 the installer would always hang on some post
installation script, with Phoebe the install will complete, so progress has been
made. With 7.2
I did not have this issue. Hope this helps, this box is available for any testing
so feel free to ask for anything you want.

Comment 2 Jeremy Katz 2003-01-02 18:16:00 EST
If you mount the floppy and compare the size of the initrd to the size of the
initrd in /boot, is it smaller?
Comment 3 Ted Kaczmarek 2003-01-02 18:29:19 EST
291831 Dec 28 02:36 initrd-2.4.20-2.2.img from /boot
253952 Dec 28 11:58 initrd.img frpm floppy
Comment 4 Jeremy Katz 2003-01-03 00:57:05 EST
Added code in CVS to verify the sizes of the initrd + kernel written out to the
floppy
Comment 8 Mike McLean 2003-02-11 20:02:48 EST
*** Bug 78845 has been marked as a duplicate of this bug. ***
Comment 9 Eugene Kanter 2003-02-12 13:47:20 EST
Does anaconda use mkbootdisk or some internal code? mkbootdisk returns an error
if there is not enough space on the target media.
The best solution would be to actually format fd0u1660 device if 1440 is not
enough. There are cases where MBR is not accessible and user would be left with
a non-bootable system with the only option: rescue mode, format fd0u1660 and
mkbootdisk.
Comment 10 Mike McLean 2003-02-24 14:26:34 EST
anaconda does use mkbootdisk.

Currently anaconda detects when the bootdisk size is greater than 1440 and
informs the user that it cannot create one.  Experienced users can always use
mkbootdisk themselves if they want to use unusual workarounds.

The '--iso' option to mkbootdisk will create a bootable iso image that can be
burned to a cd.

Closing bug...
Comment 11 Eugene Kanter 2003-02-24 22:30:22 EST
There have been several (un)releated problems and all got closed. The root cause
I believe is that mkinitrd piles up all scsi modules it finds even though only
one is needed on the image.

I agree that experienced users will find a way to create a bootdisk. But
anaconda is designed for unexperienced users and must desperately try to create
a working bootdisk by a) removing extra scsi modules or b) formatting > 1440 floppy.

This is definitely not a top priority for this release. I believe it should be
documented. If system has two different scsi cards anaconda will most likely NOT
create a boot disk.
Comment 12 Jeremy Katz 2003-02-24 23:02:36 EST
It's too bad that removable media hardware is lagging, but anything that's done
is just going to be a temporary bandaid.  It's definitely not anaconda's place
to do so.  The anaconda side of this at least is fixed

You can't even do boot disks on a lot of platforms these days, so the usefulness
of it as a default is decreasing as time goes on.

Note You need to log in before you can comment on or make changes to this bug.