Bug 789376 - ruby/ruby.h tries to include ruby/config.h which is missing from ruby-devel
ruby/ruby.h tries to include ruby/config.h which is missing from ruby-devel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
: 809186 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-10 10:52 EST by John Ellson
Modified: 2012-04-03 00:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-10 11:22:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2012-02-10 10:52:41 EST
Description of problem:
ruby/ruby.h tries to include ruby/config.h which is missing from ruby-devel

I suspect it shouldn't be attempting to include config.h at all, since that represents the results of ./configure on the build host, not the rpm install host.

Version-Release number of selected component (if applicable):
ruby-devel-1.9.3.0-7.fc17

How reproducible:
100% (breaks graphviz build)

Steps to Reproduce:
1.grep config.h /usr/include/ruby/*
2.ls /usr/include/ruby/config.h
3.
  
Actual results:

defines.h:#include "ruby/config.h"
io.h:#include "ruby/config.h"
missing.h:#include "ruby/config.h"
ruby.h:#include "ruby/config.h"

ls: cannot access /usr/include/ruby/config.h: No such file or directory


Expected results:
Probably should not be #include'd unconditionally by ruby/*.h in the first place.

Expect successful build of graphviz-ruby plugin

Additional info:
Not as simple as hand editing the four .h files listed above to disable the #include.   When I tried that, graphviz's ./configure check for ruby.h, fails with:
/usr/include/ruby/ruby.h:104:36: error: 'SIZEOF_INT' undeclared here (not in a function)
/usr/include/ruby/ruby.h:105:37: error: 'SIZEOF_LONG' undeclared here (not in a function)
/usr/include/ruby/ruby.h:109:38: error: 'SIZEOF_VOIDP' undeclared here (not in a function)
Comment 1 Vít Ondruch 2012-02-10 11:22:54 EST
Hi,


According to the Ruby upstream, this was intentional change [1], although I cannot find better reference now. So the problem is more or less on Graphviz side.

Nevertheless, I have rebuild Graphviz against Ruby 1.9.3 for you already and this [2] was the solution. You don't need to do anything.



[1] http://bugs.ruby-lang.org/issues/show/2317
[2] http://pkgs.fedoraproject.org/gitweb/?p=graphviz.git;a=commitdiff;h=7066554dc5d3a8c8fd509d9334526f6189e59e51
Comment 2 Vít Ondruch 2012-04-03 00:54:48 EDT
*** Bug 809186 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.