This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 789383 - pkcon advice incorrect
pkcon advice incorrect
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
: 835472 (view as bug list)
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2012-02-10 11:22 EST by Neal Becker
Modified: 2012-12-20 10:44 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:44:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2012-02-10 11:22:45 EST
Description of problem:

Abrt found a new update which fix your problem. Please run before submitting bug: pkcon update --repo-enable=fedora --repo-repo=updates-testing imsettings-1.2.8-1.fc16. Do you want to continue with reporting bug?

How nice!  But it doesn't work:

sudo pkcon update --repo-enable=fedora --repo-repo=updates-testing imsettings-1.2.8-1.fc16
[sudo] password for nbecker: 
Failed to parse command line: Unknown option --repo-enable=fedora


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Toby Haynes 2012-05-24 15:25:07 EDT
Also seen in Fedora 17.


Searching for updates
Abrt found a new update which fix your problem. Please run before submitting bug: pkcon update --repo-enable=fedora --repo-repo=updates-testing tracker-0.14.1-1.fc17. Do you want to continue with reporting bug? NO
(exited with 1)


One possible correct command (there may be others)

yum update --enablerepo=fedora --enablerepo=updates-testing tracker-0.14.1-1.fc17


While someone is resolving this, they should fix the grammar for the rest of the statement:

Replace:
Abrt found a new update which fix your problem.
With:
Abrt found a new update which should fix your problem.
Comment 2 Nikola Pajkovsky 2012-05-25 03:22:36 EDT
Working on proper PackageKit integration right now.
Comment 3 Penelope Fudd 2012-08-22 13:36:12 EDT
This bug is still present in abrt-2.0.10-4.fc17.i686
Comment 4 Jiri Moskovcak 2012-09-18 06:56:11 EDT
*** Bug 835472 has been marked as a duplicate of this bug. ***
Comment 5 Denys Vlasenko 2012-09-20 10:06:23 EDT
Changing the suggested command to:

yum update --enablerepo=fedora --enablerepo=updates-testing PKG1 PKG2...
Comment 6 Denys Vlasenko 2012-09-20 10:09:05 EDT
Fixed in git:

commit fafc4d3ac0ae6c2bfef6543a245d0a2ee9df2866
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Thu Sep 20 16:05:35 2012 +0200

    bodhi: fix suggested pkg update command, fix version comparison
Comment 7 Fedora Update System 2012-09-24 10:31:25 EDT
abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
Comment 8 Fedora Update System 2012-09-24 16:03:35 EDT
Package abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.13-1.fc18 libreport-2.0.14-1.fc18 btparser-0.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14679/abrt-2.0.13-1.fc18,libreport-2.0.14-1.fc18,btparser-0.19-1.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-09-25 06:05:57 EDT
abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.13-1.fc17,libreport-2.0.14-1.fc17,btparser-0.19-1.fc17
Comment 10 Fedora Update System 2012-12-20 10:44:19 EST
abrt-2.0.13-1.fc18, libreport-2.0.14-1.fc18, btparser-0.19-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.