Bug 789886 - bind-chroot package has a few bugs
Summary: bind-chroot package has a few bugs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind
Version: 6.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 829823 857347
TreeView+ depends on / blocked
 
Reported: 2012-02-13 07:46 UTC by repomaint-rhbz
Modified: 2012-09-14 07:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 829823 857347 (view as bug list)
Environment:
Last Closed: 2012-06-20 13:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0830 normal SHIPPED_LIVE bind bug fix and enhancement update 2012-06-19 20:49:20 UTC

Description repomaint-rhbz 2012-02-13 07:46:58 UTC
Description of problem:

The bind-chroot package contains a couple of bugs.
1) It doesn't create the /dev/null device due to a spec file copy&paste error
2) When uninstalling it leaves some empty dirs behind as they aren't listed in the files section of the spec-file.

Version-Release number of selected component (if applicable):
bind-chroot-9.7.3-8.P3.el6_2.2

How reproducible:
install package / uninstall it again

Steps to Reproduce:
1. yum install bind-chroot
2. ls -la /var/named/chroot/dev/
3. yum erase bind-chroot
4. ls -la /var/named/chroot/
  

Additional info:

The '%post chroot' section of the bind spec-file contains the following bit:

  [ -e %{chroot_prefix}/dev/zero ] || \
    /bin/mknod %{chroot_prefix}/dev/null c 1 3

the check for /dev/zero is wrong and appears to be a copy&paste error, it should obviously be /dev/null.

The 'files chroot' section is missing the following lines:
%dir %{chroot_prefix}/etc/pki
%dir %{chroot_prefix}/usr
%dir %{chroot_prefix}/%{_libdir}

Comment 7 Orion Poplawski 2012-06-13 20:51:43 UTC
It should also create:

%{chroot_prefix}/var/named/data
%{chroot_prefix}/var/named/dynamic
%{chroot_prefix}/var/named/slaves

Comment 9 errata-xmlrpc 2012-06-20 13:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0830.html


Note You need to log in before you can comment on or make changes to this bug.