Bug 789959 - firefox 10 crashes on java applet
Summary: firefox 10 crashes on java applet
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-13 11:02 UTC by Andrea Pasquinucci
Modified: 2012-05-25 17:35 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-05-25 17:35:56 UTC


Attachments (Terms of Use)
about:plugins from upstream binary version (11.11 KB, text/plain)
2012-02-14 14:49 UTC, Andrea Pasquinucci
no flags Details
about:plugins from fedora version user-1 (12.71 KB, text/plain)
2012-02-14 14:49 UTC, Andrea Pasquinucci
no flags Details
about:plugins from fedora version user-2 (11.11 KB, text/plain)
2012-02-14 14:50 UTC, Andrea Pasquinucci
no flags Details
crash_bt (29.88 KB, text/plain)
2012-02-29 13:48 UTC, Andrea Pasquinucci
no flags Details
crash_bt2 (76.00 KB, text/plain)
2012-02-29 15:29 UTC, Andrea Pasquinucci
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 704249 None None None Never

Description Andrea Pasquinucci 2012-02-13 11:02:55 UTC
Description of problem:

firefox crashes on running a signed (OK) java applet from the home banking web site which implements the login form


Version-Release number of selected component (if applicable):

firefox 10 (both .1 and .2)

How reproducible:

always, just run the applet

Steps to Reproduce:
1. connect to the bank login page 
2. click RUN on the applet (OK) signature verification popup
3.
  
Actual results:
crash

Expected results:
login form

Additional info:
works perfectly fine with firefox 9

Comment 1 Martin Stransky 2012-02-13 15:47:15 UTC
Can you check it with an upstream binary package from mozilla.org?

Comment 2 Andrea Pasquinucci 2012-02-13 16:07:47 UTC
yes, but you should tell me which one and how to download it

Comment 3 Andrea Pasquinucci 2012-02-14 10:08:50 UTC
I downloaded firefox-10.0.1.tar.bz2  (firefox: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.9, stripped) from www.mozilla.org, and it works fine

Comment 4 Martin Stransky 2012-02-14 13:07:58 UTC
I see. Can you check the 10.0.1 from Fedora updates? (https://admin.fedoraproject.org/updates/FEDORA-2012-1650)

Comment 5 Andrea Pasquinucci 2012-02-14 14:08:44 UTC
CRASH

installed: firefox-10.0.1-1.fc16.x86_64.rpm and xulrunner-10.0.1-1.fc16.x86_64.rpm

Comment 6 Martin Stransky 2012-02-14 14:13:22 UTC
Can you please attach content of "about:plugins" from the fedora package and from the upstream binary? Which Java do you use?

Comment 7 Andrea Pasquinucci 2012-02-14 14:49:08 UTC
Created attachment 561928 [details]
about:plugins from upstream binary version

Comment 8 Andrea Pasquinucci 2012-02-14 14:49:59 UTC
Created attachment 561929 [details]
about:plugins from fedora version user-1

Comment 9 Andrea Pasquinucci 2012-02-14 14:50:39 UTC
Created attachment 561931 [details]
about:plugins from fedora version user-2

Comment 10 Andrea Pasquinucci 2012-02-14 15:00:12 UTC
java-1.6.0-openjdk-1.6.0.0-63.1.11.fc16.x86_64

I uploaded the plugin pages. I noticed that one user on the machine appears as having 2 plugin versions of icedtea-web-1.1.4-4.fc16.x86_64; it is not the user who has the crash who instead has only 1 occurence of icedtea, ie user-2

if I run fedora firefox from the command line I get

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11) (fedora-63.1.11.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

Comment 11 Andrea Pasquinucci 2012-02-18 08:46:51 UTC
update: since I was not convinced by my tests, I downloaded the latest upstream binary firefox versions 10.0.2, both i686 and x86_64 (from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/10.0.2-candidates/build1/linux-x86_64/en-US/ )

Now the upstream binary i686 did not find Java (since the installed IcedTea is x86_64) and did not run the applet.

Instead the upstream binary x86_64 10.0.2, after a renaming of the x86_64 plugin directory, found all plugins, run the applet and CRASHED

Comment 12 Juan Antonio Martinez 2012-02-28 08:48:36 UTC
Similar problem for me: 

xulrunner-10.0.1-3.fc16.x86_64
firefox-10.0.1-1.fc16.x86_64
icedtea-web-1.1.4-4.fc16.x86_64
java plugin enabled in ff

- Setting "dom.ipc.plugins.java.enabled;false" to true in about:config has no effect
- Applet does not load
- If requested java console doesn't appear.
- Navigator shows garbage in the applet window
- Wow! libflashplayer.so plugin is started but no flash requested!

Tested on several java-based pages with no flash nor any other <object> element

Comment 13 Martin Stransky 2012-02-28 08:59:56 UTC
Okay, please attach the firefox stractrace:

https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Obtain_crash_stack_trace

Comment 14 Andrea Pasquinucci 2012-02-29 13:48:32 UTC
Created attachment 566549 [details]
crash_bt

Comment 15 Andrea Pasquinucci 2012-02-29 13:50:47 UTC
I did run the crash stack trace (but no debug info table installed) and uploaded the output

versions are firefox-10.0.1-1.fc16.x86_64 and xulrunner-10.0.1-3.fc16.x86_64

Comment 16 Martin Stransky 2012-02-29 14:07:21 UTC
Can you please install the debuginfo packages (https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products) and attach it again? We need the debug symbols.

Comment 17 Andrea Pasquinucci 2012-02-29 15:29:33 UTC
Created attachment 566572 [details]
crash_bt2

added debuginfo symbols

Comment 18 Martin Stransky 2012-03-01 10:36:34 UTC
Can you try to set dom.ipc.plugins.java.enabled to true? in about:config. And do you have any reproducer? (page where it crashes?)

Comment 19 Juan Antonio Martinez 2012-03-01 10:40:35 UTC
Found that google chrome 17.0.963.56 suffers same problem: java applet doesn't load nor starts

So imo the problem is related to icedtea-web plugin, not to FF

Comment 20 Andrea Pasquinucci 2012-03-01 16:01:48 UTC
sorry to disagree, but I am using chromium-17.0.963.46-3.fc16.x86_64 on the same machine and no crash at all

Comment 21 Andrea Pasquinucci 2012-03-01 16:18:08 UTC
After setting dom.ipc.plugins.java.enabled to true it works, no more crash. I will test it more later on. 

For the reproducer, yes I have an URL, but can I send it to you by email ? Thanks

Comment 22 Martin Stransky 2012-03-01 16:33:03 UTC
yes, send the reproducer to stransky@redhat.com please, thanks.

Comment 23 Martin Stransky 2012-03-02 08:10:47 UTC
Upstream bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=704249

The crash is caused when JS_NewContext is called off the main thread from js plugin.

dom.ipc.plugins.java.enabled works here as a workaround.

Comment 24 Martin Stransky 2012-03-02 08:27:52 UTC
Accrding to https://bugzilla.mozilla.org/show_bug.cgi?id=704249 it's fixed in IcedTea-Web 1.2pre.

Comment 25 Andrea Pasquinucci 2012-03-18 14:45:18 UTC
Just tried with firefox-11.0-1.fc16.x86_64, icedtea-web-1.2-1.fc16.x86_64 and 
dom.ipc.plugins.java.enabled=false and seems to work fine

Comment 26 koteshwarv 2012-03-22 16:45:28 UTC
I am using Firefox 10.0 and when I click on Java console nothing is coming up. When I open my website I get the error popup saying - Check if your environment allows to download and run Java applets. Refer to the Java console for more details. I did all the settings including dom.ipc.plugins.java.enabled=true. It did not work out. Do I need to install any patch on top of 10.0 version to get this fixed.

Comment 27 Deepak Bhole 2012-03-22 18:09:50 UTC
(In reply to comment #26)
> I am using Firefox 10.0 and when I click on Java console nothing is coming up.
> When I open my website I get the error popup saying - Check if your environment
> allows to download and run Java applets. Refer to the Java console for more
> details. I did all the settings including dom.ipc.plugins.java.enabled=true. It
> did not work out. Do I need to install any patch on top of 10.0 version to get
> this fixed.

Can you please post the out of about:plugins (enter in Firefox location bar and hit enter)?

Comment 28 koteshwarv 2012-03-22 18:44:45 UTC
Enabled plugins
Find more information about browser plugins at mozilla.org.
Find updates for installed plugins at mozilla.com/plugincheck.
Help for installing plugins is available from plugindoc.mozdev.org.
Java(TM) Platform SE 6 U11

    File: npdeploytk.dll
    Version: 6.0.110.3
    Java(TM) Platform SE binary

MIME Type 	Description 	Suffixes
application/npruntime-scriptable-plugin;DeploymentToolkit 		
Java(TM) Platform SE 6 U11

    File: npjp2.dll
    Version: 6.0.110.3
    Java Plug-in 1.6.0_11 for Netscape Navigator (DLL Helper)

MIME Type 	Description 	Suffixes
application/x-java-applet 	Java Applet 	
application/x-java-bean 	JavaBeans 	
application/x-java-vm 		
application/x-java-applet;version=1.1.1 		
application/x-java-bean;version=1.1.1 		
application/x-java-applet;version=1.1 		
application/x-java-bean;version=1.1 		
application/x-java-applet;version=1.2 		
application/x-java-bean;version=1.2 		
application/x-java-applet;version=1.1.3 		
application/x-java-bean;version=1.1.3 		
application/x-java-applet;version=1.1.2 		
application/x-java-bean;version=1.1.2 		
application/x-java-applet;version=1.3 		
application/x-java-bean;version=1.3 		
application/x-java-applet;version=1.2.2 		
application/x-java-bean;version=1.2.2 		
application/x-java-applet;version=1.2.1 		
application/x-java-bean;version=1.2.1 		
application/x-java-applet;version=1.3.1 		
application/x-java-bean;version=1.3.1 		
application/x-java-applet;version=1.4 		
application/x-java-bean;version=1.4 		
application/x-java-applet;version=1.4.1 		
application/x-java-bean;version=1.4.1 		
application/x-java-applet;version=1.4.2 		
application/x-java-bean;version=1.4.2 		
application/x-java-applet;version=1.5 		
application/x-java-bean;version=1.5 		
application/x-java-applet;version=1.6 		
application/x-java-bean;version=1.6 		
application/x-java-applet;jpi-version=1.6.0_11 		
application/x-java-bean;jpi-version=1.6.0_11 		
Windows Presentation Foundation

    File: NPWPF.dll
    Version: 3.5.30729.1
    Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

MIME Type 	Description 	Suffixes
application/x-ms-xbap 	XAML Browser Application 	xbap
application/xaml+xml 	XAML Document 	xaml

Comment 29 Deepak Bhole 2012-03-22 19:50:38 UTC
Hmm, the list has DLLs. Which OS are you using?

Comment 30 koteshwarv 2012-05-23 18:34:16 UTC
Sorry for the late communication. The OS is Windows Server Standard (Service Pack 1 )

Comment 31 Bill Nottingham 2012-05-23 18:42:34 UTC
Apologies to you, koteshwarv, but then you're in the wrong place. Fedora cannot fix either your Firefox on Windows, nor your Windows Java runtime.

Comment 32 Deepak Bhole 2012-05-23 18:45:19 UTC
Hi koteshwarv, as Bill pointed out, we cannot fix anything for Windows in any way. I am going to close this as NOTABUG as it is not a Fedora/RHEL bug.

Comment 33 Deepak Bhole 2012-05-23 18:46:46 UTC
Oops, the original bug was opened by someone else. Sorry :( 

Re-opening.

Comment 34 Deepak Bhole 2012-05-23 18:47:43 UTC
(In reply to comment #25)
> Just tried with firefox-11.0-1.fc16.x86_64, icedtea-web-1.2-1.fc16.x86_64
> and 
> dom.ipc.plugins.java.enabled=false and seems to work fine

What happens if the above is not specified? Still crashes?

Comment 35 Andrea Pasquinucci 2012-05-25 10:52:42 UTC
For me the bug is fixed, all ok with default value of dom.ipc.plugins.java.enabled, no more crashes
we can close the ticket, as far as I understand it has been solved upstream, see comment #23

Comment 36 Deepak Bhole 2012-05-25 17:35:56 UTC
(In reply to comment #35)
> For me the bug is fixed, all ok with default value of
> dom.ipc.plugins.java.enabled, no more crashes
> we can close the ticket, as far as I understand it has been solved upstream,
> see comment #23

Fair enough. Thanks!


Note You need to log in before you can comment on or make changes to this bug.