Bug 79008 - Update Agent Fails
Update Agent Fails
Status: CLOSED NOTABUG
Product: Stronghold Cross Platform
Classification: Retired
Component: update-agent (Show other bugs)
4.0
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
Stronghold Engineering List
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-04 10:48 EST by Bob Breedlove
Modified: 2007-04-18 12:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-06 05:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Breedlove 2002-12-04 10:48:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
Agent fails when updating:

# bin/agent
Getting list of packages    ########################################### [100%]
Getting package headers     ########################################### [100%]
 
Required packages:
   Name                                    Version        Rel
   ----------------------------------------------------------
   stronghold-apache                       1.3.22         11                  
   stronghold-php4                         4.1.2          2                   
   stronghold-php4-manual                  4.1.2          2                   
   stronghold-configurator                 1.2            8                   
   stronghold-openssl                      0.9.6c         6                   
   stronghold-openssl-devel                0.9.6c         6                   
   stronghold-tomcat                       4.0.5          1                   
   stronghold-shcore                       4.0            7                   
   stronghold-perl                         5.6.1          6                   
   stronghold-apache-devel                 1.3.22         11                  
   stronghold-mm-devel                     1.1.3          6                   
   stronghold-apache-src                   1.3.22         11                  
   stronghold-mod_authz_ldap               0.19           4                   
   stronghold-update-agent                 1.2            1                   
   stronghold-apache-manual                1.3.22         11                  
 
Downloading package files:
   1:apache                 ########################################### [100%]
   2:php4                   ########################################### [100%]
   3:php4-manual            ########################################### [100%]
   4:configurator           ########################################### [100%]
   5:openssl                ########################################### [100%]
   6:openssl-devel          ########################################### [100%]
   7:tomcat                 ########################################### [100%]
   8:shcore                 ########################################### [100%]
   9:perl                   ########################################### [100%]
  10:apache-devel           ########################################### [100%]
  11:mm-devel               ########################################### [100%]
  12:apache-src             ########################################### [100%]
  13:mod_authz_ldap         ########################################### [100%]
  14:update-agent           ########################################### [100%]
  15:apache-manual          ########################################### [100%]
 
Installing packages:
   (preparing...)           ########################################### [100%]
 
The following problems prevented package installation:
  package stronghold-apache-devel-1.3.22-11 is for a different operating system
  package stronghold-php4-manual-4.1.2-2 is for a different operating system
  package stronghold-perl-5.6.1-6 is for a different operating system
  package stronghold-php4-4.1.2-2 is for a different operating system
  package stronghold-apache-1.3.22-11 is for a different operating system
  package stronghold-configurator-1.2-8 is for a different operating system
  package stronghold-apache-src-1.3.22-11 is for a different operating system
  package stronghold-openssl-devel-0.9.6c-6 is for a different operating system
  package stronghold-openssl-0.9.6c-6 is for a different operating system
  package stronghold-tomcat-4.0.5-1 is for a different operating system
  package stronghold-shcore-4.0-7 is for a different operating system
  package stronghold-mm-devel-1.1.3-6 is for a different operating system
  package stronghold-mod_authz_ldap-0.19-4 is for a different operating system
  package stronghold-update-agent-1.2-1 is for a different operating system
  package stronghold-apache-manual-1.3.22-11 is for a different operating system
 
How do I get a complete install package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the agent per your directions.

	

Actual Results:  # bin/agent
Getting list of packages    ########################################### [100%]
Getting package headers     ########################################### [100%]
 
Required packages:
   Name                                    Version        Rel
   ----------------------------------------------------------
   stronghold-apache                       1.3.22         11                  
   stronghold-php4                         4.1.2          2                   
   stronghold-php4-manual                  4.1.2          2                   
   stronghold-configurator                 1.2            8                   
   stronghold-openssl                      0.9.6c         6                   
   stronghold-openssl-devel                0.9.6c         6                   
   stronghold-tomcat                       4.0.5          1                   
   stronghold-shcore                       4.0            7                   
   stronghold-perl                         5.6.1          6                   
   stronghold-apache-devel                 1.3.22         11                  
   stronghold-mm-devel                     1.1.3          6                   
   stronghold-apache-src                   1.3.22         11                  
   stronghold-mod_authz_ldap               0.19           4                   
   stronghold-update-agent                 1.2            1                   
   stronghold-apache-manual                1.3.22         11                  
 
Downloading package files:
   1:apache                 ########################################### [100%]
   2:php4                   ########################################### [100%]
   3:php4-manual            ########################################### [100%]
   4:configurator           ########################################### [100%]
   5:openssl                ########################################### [100%]
   6:openssl-devel          ########################################### [100%]
   7:tomcat                 ########################################### [100%]
   8:shcore                 ########################################### [100%]
   9:perl                   ########################################### [100%]
  10:apache-devel           ########################################### [100%]
  11:mm-devel               ########################################### [100%]
  12:apache-src             ########################################### [100%]
  13:mod_authz_ldap         ########################################### [100%]
  14:update-agent           ########################################### [100%]
  15:apache-manual          ########################################### [100%]
 
Installing packages:
   (preparing...)           ########################################### [100%]
 
The following problems prevented package installation:
  package stronghold-apache-devel-1.3.22-11 is for a different operating system
  package stronghold-php4-manual-4.1.2-2 is for a different operating system
  package stronghold-perl-5.6.1-6 is for a different operating system
  package stronghold-php4-4.1.2-2 is for a different operating system
  package stronghold-apache-1.3.22-11 is for a different operating system
  package stronghold-configurator-1.2-8 is for a different operating system
  package stronghold-apache-src-1.3.22-11 is for a different operating system
  package stronghold-openssl-devel-0.9.6c-6 is for a different operating system
  package stronghold-openssl-0.9.6c-6 is for a different operating system
  package stronghold-tomcat-4.0.5-1 is for a different operating system
  package stronghold-shcore-4.0-7 is for a different operating system
  package stronghold-mm-devel-1.1.3-6 is for a different operating system
  package stronghold-mod_authz_ldap-0.19-4 is for a different operating system
  package stronghold-update-agent-1.2-1 is for a different operating system
  package stronghold-apache-manual-1.3.22-11 is for a different operating system
 
P

Expected Results:  Correct install.

Additional info:
Comment 1 Gary Benson 2002-12-05 06:48:03 EST
A workaround for this issue is attached to #70449.

*** This bug has been marked as a duplicate of 70449 ***
Comment 2 Gary Benson 2002-12-06 05:41:19 EST
My mistake, this is not a duplicate of 70449 at all.
Comment 3 Gary Benson 2002-12-06 05:45:03 EST
Could you please attach:
* the file <ServerRoot>/lib/update-agent/config.py
* the file <ServerRoot>/conf/update-agent.conf if it exists.
* a listing of the contents of the directory <ServerRoot>/var/ua/spool

Note You need to log in before you can comment on or make changes to this bug.