Bug 790530 - yum install fails - No repomd file
Summary: yum install fails - No repomd file
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: rawhide
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F17Alpha, F17AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2012-02-14 18:55 UTC by satellitgo
Modified: 2014-01-21 23:21 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-15 16:49:29 UTC
Type: ---


Attachments (Terms of Use)

Description satellitgo 2012-02-14 18:55:46 UTC
Description of problem:
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-17&arch=i386
Error: Error importing repomd.xml from fedora: unable to open /var/cache/yum/i386/17/fedora/repomd.xml

Version-Release number of selected component (if applicable):
Fedora-17-Nightly-20120214.09-i686-Live-soas.iso (and live-Desktop)


How reproducible:
Try to install from yum


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 satellitgo 2012-02-14 18:58:11 UTC
https://mirrors.fedoraproject.org/metalink?repo=fedora-17&arch=i386
The application you chose ("") could not be found.  Check the file name or choose another application.

Comment 2 Adam Williamson 2012-02-14 19:05:20 UTC
This looks like a releng issue, not yum: # repo=fedora-17, arch=i386 is missing from the metalink stuff, if you look through the error output (click on the link above and open it in gedit). Assigning to releng people. Proposing as Alpha blocker, as this probably prevents updates working on i386 - "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops".

Note this doesn't need a package update, so it's not a blocker that affects spinning.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2012-02-14 19:36:28 UTC
Seems to also have been reported through trac, as https://fedorahosted.org/fedora-infrastructure/ticket/3142 .

Comment 4 Kevin Fenzi 2012-02-15 16:49:29 UTC
this is fixed now. sorry for the trouble. ;( 

There's a mirrormanager bug that was exposed, and will hopefully be fixed now.


Note You need to log in before you can comment on or make changes to this bug.