Bug 790855 - Rebase freerdp to 1.0.x?
Summary: Rebase freerdp to 1.0.x?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: freerdp
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 800207 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-15 14:42 UTC by Trond H. Amundsen
Modified: 2012-04-12 01:52 UTC (History)
4 users (show)

Fixed In Version: freerdp-1.0.1-5.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-11 18:53:01 UTC
Type: ---


Attachments (Terms of Use)

Description Trond H. Amundsen 2012-02-15 14:42:58 UTC
FreeRDP in Fedora (EPEL) is getting old. There are many new exciting features in the 1.0.x releases, as well as bugfixes. In addition, we're hitting a strange problem where freerdp brings down the RDP server infrequently and at random, as described here:

http://permalink.gmane.org/gmane.network.freerdp.devel/1589

While this is really a problem with Windows and should be fixed at the server end, we're hoping that an upgraded freerdp might help as a workaround.

Comment 1 Mads Kiilerich 2012-02-15 14:58:04 UTC
Yes, I will do that RSN. I haven't had time to follow it recently, but it is getting close to the top of my list now.

Comment 2 Mads Kiilerich 2012-02-25 11:57:03 UTC
I have commit the update in Fedora rawhide, but building without repo conflicts requires a remmina update as well - we are waiting for that to happen. The (major) update has thus not seen any real testing yet.

Remmina is however not in EPEL and there is thus no dependency problems for updating there. The only problem is that it would be a major update in a released EL, but I think it is OK considering how unknown and immature freerdp 0.8 was and how much it has improved.

Comment 3 Fedora Update System 2012-02-25 11:59:29 UTC
freerdp-1.0.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/freerdp-1.0.1-2.el6

Comment 4 Fedora Update System 2012-02-25 20:01:30 UTC
Package freerdp-1.0.1-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing freerdp-1.0.1-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0594/freerdp-1.0.1-2.el6
then log in and leave karma (feedback).

Comment 5 Mads Kiilerich 2012-03-06 00:55:32 UTC
*** Bug 800207 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2012-03-10 23:57:09 UTC
freerdp-1.0.1-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freerdp-1.0.1-5.fc17

Comment 7 Fedora Update System 2012-03-11 18:53:01 UTC
freerdp-1.0.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-04-12 01:52:08 UTC
freerdp-1.0.1-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.