Bug 790871 - ant contrib tasks fail
ant contrib tasks fail
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: CLI (Show other bugs)
JON 3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 800068
  Show dependency treegraph
 
Reported: 2012-02-15 10:42 EST by Shaun Appleton
Modified: 2013-09-20 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 800068 (view as bug list)
Environment:
Last Closed: 2013-09-20 10:56:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaun Appleton 2012-02-15 10:42:24 EST
Description of problem:


Version-Release number of selected component (if applicable):
JON-3.0.0.GA-patch-2

How reproducible:
very

Steps to Reproduce:
Try to use some tasks like <assert> and <for>
deploy the deploy.xml trough JON I get the following error message:

[preinstall] /data/opt/jon/rhq-agent/data/tmp/bundle-versions/10041/ant-bundle-recipe5951772158125813392.xml:42: Problem: failed to create task or type for Cause: The name is undefined. Action: Check the spelling. Action: Check that any custom tasks/types have been declared. Action: Check that any / declarations have taken place. at org.apache.tools.ant.UnknownElement.getNotFoundException(UnknownElement.java:487) at org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:419) at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:163) at org.apache.tools.ant.Task.perform(Task.java:347) at org.apache.tools.ant.Target.execute(Target.java:390) at org.apache.tools.ant.Target.performTasks(Target.java:411) at org.rhq.bundle.ant.type.DeploymentUnitType.install(DeploymentUnitType.java:131) at org.rhq.bundle.ant.task.BundleTask.execute(BundleTask.java:148) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:616) at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106) at org.apache.tools.ant.Task.perform(Task.java:348) at org.apache.tools.ant.Target.execute(Target.java:390) at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:179) at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:80) at org.rhq.bundle.ant.AntLauncher.executeBundleDeployFile(AntLauncher.java:111) at org.rhq.plugins.ant.AntBundlePluginComponent.executeDeploymentPhase(AntBundlePluginComponent.java:304) at org.rhq.plugins.ant.AntBundlePluginComponent.deployBundle(AntBundlePluginComponent.java:137) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:616) at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) at java.lang.Thread.run(Thread.java:679) 
  
Actual results:


Expected results:
<assert> and <for> work without throwing an exception

Additional info:

https://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html-single/Deploying_Applications_and_Content/index.htm l#bundle-refs
points to ant contrib
so suggests these tags are valid and will work
Comment 1 Mike Foley 2012-03-05 12:03:05 EST
triage (crouch, loleary, foley). jon 3.1 timeframe.  

add BZ:  document which version of Ant we support.
Comment 2 Mike Foley 2012-03-05 12:04:31 EST
BZ for the new doc issue:  https://bugzilla.redhat.com/show_bug.cgi?id=800068
Comment 3 John Mazzitelli 2012-03-05 13:09:54 EST
need replication code - can someone attach a sample deploy.xml or better an actual sample bundle distribution file that demonstrates the behavior?
Comment 4 John Mazzitelli 2012-03-05 13:22:35 EST
(In reply to comment #1)
> triage (crouch, loleary, foley). jon 3.1 timeframe.  
> 
> add BZ:  document which version of Ant we support.

also need to doc which version of ant-contrib we support (today its 1.0b3, which does appear to be the latest version - http://sourceforge.net/projects/ant-contrib/ )
Comment 6 Charles Crouch 2012-08-02 22:22:55 EDT
(In reply to comment #3)
> need replication code - can someone attach a sample deploy.xml or better an
> actual sample bundle distribution file that demonstrates the behavior?

Shaun can you help?
Comment 7 Shaun Appleton 2012-08-06 05:09:11 EDT
(In reply to comment #6)
> (In reply to comment #3)
> > need replication code - can someone attach a sample deploy.xml or better an
> > actual sample bundle distribution file that demonstrates the behavior?
> 
> Shaun can you help?

I've asked the consultant for an example.
Comment 8 Charles Crouch 2012-08-29 12:13:35 EDT
As per 8/20 triage pushing to JON312
Comment 9 Heiko W. Rupp 2013-08-12 05:38:05 EDT
Any news?
Comment 10 Shaun Appleton 2013-08-12 05:52:31 EDT
Hi Heiko - no. 

I asked the consultant for this in May 2012 and didn't not get anything.
The consultant has since left Red Hat so we probably won't get anything now.

Shaun

Note You need to log in before you can comment on or make changes to this bug.