Bug 800068 - Consider documenting which version of Ant we support
Consider documenting which version of Ant we support
Status: CLOSED UPSTREAM
Product: RHQ Project
Classification: Other
Component: Documentation (Show other bugs)
3.0.1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: JON 3.1.0
Assigned To: Deon Ballard
Mike Foley
:
: 800089 (view as bug list)
Depends On: 790871
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 12:03 EST by Mike Foley
Modified: 2013-09-05 12:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 790871
Environment:
Last Closed: 2013-09-05 12:21:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2012-03-05 12:03:56 EST
+++ This bug was initially created as a clone of Bug #790871 +++

Description of problem:


Version-Release number of selected component (if applicable):
JON-3.0.0.GA-patch-2

How reproducible:
very

Steps to Reproduce:
Try to use some tasks like <assert> and <for>
deploy the deploy.xml trough JON I get the following error message:

[preinstall] /data/opt/jon/rhq-agent/data/tmp/bundle-versions/10041/ant-bundle-recipe5951772158125813392.xml:42: Problem: failed to create task or type for Cause: The name is undefined. Action: Check the spelling. Action: Check that any custom tasks/types have been declared. Action: Check that any / declarations have taken place. at org.apache.tools.ant.UnknownElement.getNotFoundException(UnknownElement.java:487) at org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:419) at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:163) at org.apache.tools.ant.Task.perform(Task.java:347) at org.apache.tools.ant.Target.execute(Target.java:390) at org.apache.tools.ant.Target.performTasks(Target.java:411) at org.rhq.bundle.ant.type.DeploymentUnitType.install(DeploymentUnitType.java:131) at org.rhq.bundle.ant.task.BundleTask.execute(BundleTask.java:148) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:616) at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106) at org.apache.tools.ant.Task.perform(Task.java:348) at org.apache.tools.ant.Target.execute(Target.java:390) at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:179) at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:80) at org.rhq.bundle.ant.AntLauncher.executeBundleDeployFile(AntLauncher.java:111) at org.rhq.plugins.ant.AntBundlePluginComponent.executeDeploymentPhase(AntBundlePluginComponent.java:304) at org.rhq.plugins.ant.AntBundlePluginComponent.deployBundle(AntBundlePluginComponent.java:137) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:616) at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:552) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) at java.util.concurrent.FutureTask.run(FutureTask.java:166) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) at java.lang.Thread.run(Thread.java:679) 
  
Actual results:


Expected results:
<assert> and <for> work without throwing an exception

Additional info:

https://docs.redhat.com/docs/en-US/JBoss_Operations_Network/3.0/html-single/Deploying_Applications_and_Content/index.htm l#bundle-refs
points to ant contrib
so suggests these tags are valid and will work

--- Additional comment from mfoley@redhat.com on 2012-03-05 12:03:05 EST ---

triage (crouch, loleary, foley). jon 3.1 timeframe.  

add BZ:  document which version of Ant we support.
Comment 1 Deon Ballard 2012-03-05 12:59:22 EST
*** Bug 800089 has been marked as a duplicate of this bug. ***
Comment 2 Deon Ballard 2012-03-05 12:59:59 EST
Just to note, this question originally came up because of bug 790871 (although the two are not directly related).
Comment 3 Deon Ballard 2012-04-03 11:23:32 EDT
Targeting 3.1.
Comment 4 Mike Foley 2013-09-05 12:21:52 EDT
old documentation issues

Note You need to log in before you can comment on or make changes to this bug.