Bug 790874 - after default installation and default configuration returns 503
after default installation and default configuration returns 503
Status: CLOSED DUPLICATE of bug 790507
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bryan Kearney
Eric Sammons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-15 10:47 EST by Jakub Dorňák
Modified: 2016-11-30 19:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-16 05:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (41.03 KB, application/x-gzip)
2012-02-15 10:47 EST, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2012-02-15 10:47:09 EST
Created attachment 562250 [details]
logs

Description of problem:
After successfull installation of katello-headpin-all and successfull run of katello-configure (and reboot) the web server returns:

503 Service Temporarily Unavailable

Version-Release number of selected component (if applicable):
2012-02-13.1


How reproducible:
on RHEL 6.2 Server x86_64 provided by beaker


Steps to Reproduce:
1. yum install -y katello-headpin-all
2. katello-configure --deployment=headpin
3. reboot
4. wget --no-check-certificate https://127.0.0.1/headpin/

Actual results:
503 Service Temporarily Unavailable

Expected results:
saved login page

Additional info:

The httpd server says:
Permission denied: proxy: HTTP: attempt to connect to 127.0.0.1:5000 (127.0.0.1) failed
Permission denied: proxy: HTTP: attempt to connect to 127.0.0.1:5001 (127.0.0.1) failed
...

Katello says:
/usr/lib/ruby/gems/1.8/gems/activesupport-3.0.10/lib/active_support/dependencies.rb:239: command not found: git rev-parse --short HEAD

After manual installation of git katello says:
fatal: Not a git repository (or any of the parent directories): .git

All logs attached.
Comment 2 Jakub Dorňák 2012-02-16 05:07:59 EST
The problem is with the enforcing selinux.
It should by solved with katello-selinux package (once it is installable together with katello-headpin;).

*** This bug has been marked as a duplicate of bug 790507 ***

Note You need to log in before you can comment on or make changes to this bug.