Bug 791098 - make boot messages shut up before starting getty (if ply is not used)
Summary: make boot messages shut up before starting getty (if ply is not used)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 801405 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-16 07:56 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 19:25:19 UTC


Attachments (Terms of Use)
system halts (5.44 KB, image/png)
2012-02-16 07:56 UTC, Tao Wu
no flags Details

Description Tao Wu 2012-02-16 07:56:06 UTC
Created attachment 562428 [details]
system halts

Description of problem:
anaconda suspend at first reboot if using the text mode installer 

Version-Release number of selected component (if applicable):
17.8

How reproducible:
100%

Steps to Reproduce:
1. Boot the installation passing the command line argument text.
2. Proceed and complete installation. 
3. Reboot when installation completed.
  
Actual results:
System halts after the "Started OpenSSH server deamon     [OK]".

Expected results:
Reboot successfully into installed system

Additional info:

Comment 1 Chris Lumens 2012-02-16 14:59:28 UTC
If you hit enter, does it redisplay the login prompt?  This is quite obviously not an anaconda problem, as it's got nothing to do with installation.  I don't really know whose problem it is, though, so let's send it to systemd since they handle process startup now.

Comment 2 Michal Schmidt 2012-02-16 17:13:32 UTC
We can do something to shut up the boot messages before starting getty, because they obviously confuse people.

But first I'd like to know the answer to Chris's question. Does hitting Enter make the prompt appear? If not, can you switch to a different VT and login there? If not, does Ctrl+Alt+Del reboot the system?

Comment 3 Adam Williamson 2012-02-17 17:49:44 UTC
Is this the same as #787461?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Jóhann B. Guðmundsson 2012-02-20 14:13:06 UTC
FYI the suspending part is not systemd issue it's either an xorg-x11-drv-intel ( or potentially some other driver ) + kernel 3.+ regression ( there seem to be few of those floating around atleast with i915 ) or plymouth.

So Tao what kind of graphics card do you have?

Comment 5 Tao Wu 2012-02-22 08:58:35 UTC
(In reply to comment #4)
> FYI the suspending part is not systemd issue it's either an xorg-x11-drv-intel
> ( or potentially some other driver ) + kernel 3.+ regression ( there seem to be
> few of those floating around atleast with i915 ) or plymouth.
> 
> So Tao what kind of graphics card do you have?

Mine is nVidia Corporation G96 [Quadro FX 380].

Comment 6 Tao Wu 2012-02-22 09:00:15 UTC
(In reply to comment #3)
> Is this the same as #787461?
> 
> 
> 
> -- 
> Fedora Bugzappers volunteer triage team
> https://fedoraproject.org/wiki/BugZappers

I don't think they are same, this one is about how to avoid the boot messages before starting getty.

Comment 7 Michal Schmidt 2012-02-22 17:25:57 UTC
I don't see a direct answer to my question, but from your latest comment I am deducing that the system is in fact fully alive and the only problem is the boot messages being printed after the login prompt.
[Changing title accordingly.]

Comment 8 Adam Williamson 2012-02-22 18:38:49 UTC
mschmidt: I suspect it's to do with plymouth being missing (even in RC4 it's still missing in a minimal install, unfortunately, because I put it in comps Base not Core, and minimal install doesn't install Base).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Michal Schmidt 2012-02-23 12:41:50 UTC
Yes, plymouth influences what we print. But still, I want to fix this even for the case when plymouth is not used.

Comment 10 Michal Schmidt 2012-03-08 13:29:55 UTC
*** Bug 801405 has been marked as a duplicate of this bug. ***

Comment 11 Felix Miata 2012-06-04 00:11:36 UTC
(In reply to comment #2)
> Does hitting Enter make the prompt appear?

In F17, <ENTER> draws a new release/kernel/prompt below the last boot message.

There is already a release/kernel/prompt beginning on the top line, after which various boot messages (all networking related here) appear.

Comment 12 Michal Schmidt 2012-06-04 10:49:01 UTC
In upstream systemd the getty services use a new feature to workaround the problem. It's "Type=idle", which delays the actual execution of the getty process by up to 5 seconds if the boot has not finished completely yet. I am not a big fan of it, but it does make the cosmetic issue go away in most cases. It will likely be included in a future update.

Comment 13 Fedora Update System 2012-06-13 00:15:13 UTC
systemd-44-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/systemd-44-13.fc17

Comment 14 Fedora Update System 2012-06-15 12:28:08 UTC
Package systemd-44-14.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-44-14.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9471/systemd-44-14.fc17
then log in and leave karma (feedback).

Comment 15 Felix Miata 2012-06-15 16:29:51 UTC
I would have left positive feedback in response to comment 14, but there's no way I can comply with the password requirements. I haven't had the memory of a teenager in over 50 years.

Comment 16 Adam Williamson 2012-06-15 17:08:24 UTC
Considered using a password manager? It's a really good idea.

Comment 17 Felix Miata 2012-06-15 17:30:55 UTC
I suppose that could be useful to someone who doesn't use 100+ logins across 30+ multiboot puters running disparate operating systems and web browsers.

Comment 18 Michal Schmidt 2012-06-15 21:44:03 UTC
(In reply to comment #15)
> I would have left positive feedback in response to comment 14, but [...]

Counting of the karma points is not very useful anyway. I don't enable karma automatism. The critical threshold for update approval is usually reached quite soon for systemd. Then I wait for a few more days to let people notice any regressions. I pay attention to other kinds of feedback besides karma.

Comment 19 Fedora Update System 2012-06-20 19:25:19 UTC
systemd-44-14.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.