Bug 791152 - use systemd to offer to start libvirtd
Summary: use systemd to offer to start libvirtd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 800896 825611 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-16 11:01 UTC by cje
Modified: 2012-08-09 23:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-09 23:02:39 UTC


Attachments (Terms of Use)

Description cje 2012-02-16 11:01:19 UTC
on first run of vmm it installed libvirt for me and then popped up this message:

Libvirt was just installed, so the 'libvirtd' service will
will need to be started. This can be done with one 
of the following:

- From GNOME menus: System->Administration->Services
- From the terminal: su -c 'service libvirtd restart'
- Restart your computer

virt-manager will connect to libvirt on the next application
start up.

the first two options are out of date.  i'm not sure if it's possible to do the first at all with gnome shell.  the second should probably be systemctl restart libvirtd.service

it'd probably be nice to note in the last sentence that double-clicking on 'localhost (QEMU)' in the app window will cause vmm to connect - there's no need to close and reopen the app.

Comment 1 Cole Robinson 2012-02-28 21:19:24 UTC
Hmm, and actually systemd exposes a dbus interface for polling services which we can probably use to get better info here, and even offer to start if it isn't running.

Comment 2 Cole Robinson 2012-06-06 20:08:02 UTC
*** Bug 800896 has been marked as a duplicate of this bug. ***

Comment 3 Cole Robinson 2012-06-06 20:08:56 UTC
*** Bug 825611 has been marked as a duplicate of this bug. ***

Comment 4 Cole Robinson 2012-07-07 17:32:09 UTC
Upstream now:

http://git.fedorahosted.org/git?p=virt-manager.git;a=commit;h=f7eb8f0f96d762f5b3dfd999a3dc9b00eaba3508

Requires system-config-services installed to actually work, so we get nice policykit integration.

Comment 5 Fedora Update System 2012-07-09 22:02:53 UTC
virt-manager-0.9.3-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc16

Comment 6 Fedora Update System 2012-07-09 22:02:55 UTC
virt-manager-0.9.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.3-1.fc17

Comment 7 Fedora Update System 2012-07-10 20:51:13 UTC
Package virt-manager-0.9.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-0.9.3-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10462/virt-manager-0.9.3-1.fc17
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-07-29 21:22:56 UTC
virt-manager-0.9.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc17

Comment 9 Fedora Update System 2012-07-29 21:23:57 UTC
virt-manager-0.9.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/virt-manager-0.9.4-1.fc16

Comment 10 Fedora Update System 2012-08-09 23:02:39 UTC
virt-manager-0.9.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2012-08-09 23:23:44 UTC
virt-manager-0.9.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.