Bug 791242 - Firefox 10.0.1 crashes loading java applet, in process only.
Summary: Firefox 10.0.1 crashes loading java applet, in process only.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 794908 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-16 15:21 UTC by Erik P. Olsen
Modified: 2012-03-17 23:32 UTC (History)
13 users (show)

Fixed In Version: icedtea-web-1.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-08 21:26:57 UTC
Type: ---


Attachments (Terms of Use)

Description Erik P. Olsen 2012-02-16 15:21:12 UTC
Description of problem:As described in Summary.


Version-Release number of selected component (if applicable):Firefox 10.0.1


How reproducible:Happens allways.


Steps to Reproduce:
1. Boot fedora 16 
2. launch Firefox 10.0.1
3. Select url: https://netbank.danskebank.dk/html/index.html?site=DBNB&secsystem=DI
  
Actual results: crash


Expected results: Logon dialog to my bank.


Additional info: When starting firefox from a console, I get:

[erik@epohost ~]$ firefox
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11) (fedora-63.1.11.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
16-02-2012 15:36:38 <WARN> DANID_DIGITAL_SIGNATUR appletdk.pbs.applet.bootstrap.new - Not using whitelisted class classloader: net.sourceforge.jnlp.runtime.JNLPClassLoader
16-02-2012 15:36:38 <INFO> Thread-5 - init
Assertion failure: rt->onOwnerThread(), at /builddir/build/BUILD/xulrunner-10.0.1/mozilla-release/js/src/jsapi.cpp:6316

Comment 1 Martin Stransky 2012-02-16 15:25:58 UTC
Can you attach a backtrace? (https://fedoraproject.org/wiki/StackTraces#Firefox)

Comment 2 Erik P. Olsen 2012-02-16 16:54:38 UTC
(In reply to comment #1)
> Can you attach a backtrace?
> (https://fedoraproject.org/wiki/StackTraces#Firefox)

I wish I could. I've installed the debug packages and run firefox in debug mode as described but I don't see how I can obtain the backtrace. Apparently I should issue the command gbd name-of-program. Since I am in gbd mode I enter "firefox" as this is the program that crashes but gbd doesn't know what to do with it. 

I need more precise information at that point.

Comment 3 Martin Stransky 2012-02-16 17:00:01 UTC
when you're in the gdb (you'll see the "(gdb)" prompt), run firefox by "run" command.

Comment 4 Erik P. Olsen 2012-02-16 22:29:13 UTC
(In reply to comment #3)
> when you're in the gdb (you'll see the "(gdb)" prompt), run firefox by "run"
> command.

OK, I got the following output, hope it's sufficient:

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11) (fedora-63.1.11.fc16-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
16-02-2012 22:16:24 <WARN> DANID_DIGITAL_SIGNATUR appletdk.pbs.applet.bootstrap.new - Not using whitelisted class classloader: net.sourceforge.jnlp.runtime.JNLPClassLoader
16-02-2012 22:16:24 <INFO> Thread-4 - init
Assertion failure: rt->onOwnerThread(), at /builddir/build/BUILD/xulrunner-10.0.1/mozilla-release/js/src/jsapi.cpp:6316

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7fffd31ef700 (LWP 1916)]
0x0000003879a0f3cb in raise (sig=<optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/pt-raise.c:42
42                 sig);
(gdb) thread apply all bt full

Thread 32 (Thread 0x7fffd21ed700 (LWP 1922)):
#0  0x0000003879a0e62d in read () at ../sysdeps/unix/syscall-template.S:82
No locals.
#1  0x0000003e7e240b93 in read (__nbytes=128, __buf=0x7fffd21ecdb0,
    __fd=<optimized out>) at /usr/include/bits/unistd.h:45
No locals.
#2  unix_signal_helper_thread (data=<optimized out>) at gmain.c:4567
        i = <optimized out>
        bytes_read = <optimized out>
        b = '\000' <repeats 127 times>
        sigterm_received = 0
        sigint_received = 0
        sighup_received = 0
#3  0x0000003e7e26a226 in g_thread_create_proxy (data=0x7fffd5d15340)
    at gthread.c:1962
        thread = 0x7fffd5d15340
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#4  0x0000003879a07d90 in start_thread (arg=0x7fffd21ed700)
    at pthread_create.c:309
        __res = <optimized out>
        pd = 0x7fffd21ed700
        now = <optimized out>
---Type <return> to continue, or q <return> to quit---q
Quit
(gdb) q
A debugging session is active.

    Inferior 1 [process 1881] will be killed.

Quit anyway? (y or n) y
Quitting: Couldn't get registers: Ingen sådan proces.

Comment 5 Martin Stransky 2012-02-17 08:01:36 UTC
We need a complete backtrace, don't choose the quit but continue.

Comment 6 Erik P. Olsen 2012-02-17 13:09:03 UTC
(In reply to comment #5)
> We need a complete backtrace, don't choose the quit but continue.

It prompts me to issue continue a zillion times producing more output that I can catch with copy/paste. Please inform what I can do to save the output.

Comment 7 nicofo 2012-02-19 11:52:04 UTC
Same problem for me: Assertion failure: rt->onOwnerThread(), at /builddir/build/BUILD/xulrunner-10.0.1/mozilla-release/js/src/jsapi.cpp:6316

(gdb) run
Starting program: /usr/lib/firefox/firefox 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
Detaching after fork from child process 4658.
[New Thread 0xb7affb40 (LWP 4659)]
[New Thread 0xb6cebb40 (LWP 4660)]
[New Thread 0xb62ffb40 (LWP 4661)]
[New Thread 0xb58ffb40 (LWP 4662)]
Detaching after fork from child process 4663.
Detaching after fork from child process 4664.
[New Thread 0xb4dffb40 (LWP 4665)]
[New Thread 0xb45feb40 (LWP 4666)]
[New Thread 0xb1fffb40 (LWP 4667)]
[New Thread 0xb17feb40 (LWP 4668)]
[New Thread 0xb0ffdb40 (LWP 4669)]
ACR (Component): component init
[New Thread 0xb07fcb40 (LWP 4670)]
[New Thread 0xafdffb40 (LWP 4671)]
[New Thread 0xaf0ffb40 (LWP 4672)]
[New Thread 0xae5ffb40 (LWP 4673)]
[New Thread 0xaddfeb40 (LWP 4674)]
[New Thread 0xad5fdb40 (LWP 4675)]
[New Thread 0xacdfcb40 (LWP 4676)]
[New Thread 0xa9fffb40 (LWP 4677)]
[New Thread 0xa97feb40 (LWP 4678)]
[New Thread 0xa8ffdb40 (LWP 4679)]
[Thread 0xa8ffdb40 (LWP 4679) exited]
[New Thread 0xa8ffdb40 (LWP 4680)]
[New Thread 0x96bffb40 (LWP 4681)]
Detaching after fork from child process 4682.
[New Thread 0x94dffb40 (LWP 4683)]
[New Thread 0x93dffb40 (LWP 4684)]
Detaching after fork from child process 4685.
[New Thread 0x8f8ffb40 (LWP 4687)]
[New Thread 0x8f0feb40 (LWP 4688)]
[New Thread 0x8e8fdb40 (LWP 4690)]
Detaching after fork from child process 4691.
[New Thread 0x8e0fcb40 (LWP 4693)]
java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.1) (fedora-65.1.11.1.fc16-i386)
OpenJDK Client VM (build 20.0-b12, mixed mode)
ExtraFilm Uploader version: 6.5.17.0
Current document URL: http://belgacom.smartphoto.be/fr/upload/
[New Thread 0x8cdffb40 (LWP 4742)]
Reading cookies
Assertion failure: rt->onOwnerThread(), at /builddir/build/BUILD/xulrunner-10.0.1/mozilla-release/js/src/jsapi.cpp:6316

Program received signal SIGABRT, Aborted.
[Switching to Thread 0x8e8fdb40 (LWP 4690)]
0x00110416 in __kernel_vsyscall ()
(gdb) Exception in thread "AWT-EventQueue-2" java.lang.NullPointerException
        at sun.awt.X11.XEmbeddedFramePeer.getAbsoluteX(XEmbeddedFramePeer.java:265)
        at sun.awt.X11.XBaseWindow.getAbsoluteX(XBaseWindow.java:1159)
        at sun.awt.X11.XBaseWindow.getAbsoluteX(XBaseWindow.java:1159)
        at sun.awt.X11.XBaseWindow.getAbsoluteX(XBaseWindow.java:1159)
        at sun.awt.X11.XBaseWindow.toOtherWindow(XBaseWindow.java:746)
        at sun.awt.X11.XBaseWindow.toGlobal(XBaseWindow.java:784)
        at sun.awt.X11.XWindow.getLocationOnScreen(XWindow.java:1324)
        at java.awt.Component.getLocationOnScreen_NoTreeLock(Component.java:1927)
        at java.awt.Component.getLocationOnScreen(Component.java:1905)
        at sun.awt.X11.XGlobalCursorManager.getLocationOnScreen(XGlobalCursorManager.java:181)
        at sun.awt.GlobalCursorManager._updateCursor(GlobalCursorManager.java:188)
        at sun.awt.GlobalCursorManager.updateCursorImmediately(GlobalCursorManager.java:95)
        at sun.awt.X11.XComponentPeer.updateCursorImmediately(XComponentPeer.java:850)
        at java.awt.Component.updateCursorImmediately(Component.java:2908)
        at java.awt.Container.addImpl(Container.java:1088)
        at java.awt.Container.add(Container.java:373)
        at com.aurigma.imageuploader.windows.uploadprogressdialog.c.b(Unknown Source)
        at com.aurigma.imageuploader.windows.uploadprogressdialog.c.<init>(Unknown Source)
        at com.aurigma.imageuploader.cu.u(Unknown Source)
        at com.aurigma.imageuploader.ay.actionPerformed(Unknown Source)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
        at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
        at java.awt.Component.processMouseEvent(Component.java:6268)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
        at java.awt.Component.processEvent(Component.java:6033)
        at java.awt.Container.processEvent(Container.java:2045)
        at java.awt.Component.dispatchEventImpl(Component.java:4629)
        at java.awt.Container.dispatchEventImpl(Container.java:2103)
        at java.awt.Component.dispatchEvent(Component.java:4455)
        at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4633)
        at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4297)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4227)
        at java.awt.Container.dispatchEventImpl(Container.java:2089)
        at java.awt.Component.dispatchEvent(Component.java:4455)
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
        at java.awt.EventQueue.access$000(EventQueue.java:96)
        at java.awt.EventQueue$1.run(EventQueue.java:608)
        at java.awt.EventQueue$1.run(EventQueue.java:606)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
        at java.awt.EventQueue$2.run(EventQueue.java:622)
        at java.awt.EventQueue$2.run(EventQueue.java:620)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Comment 8 Erik P. Olsen 2012-02-24 20:41:52 UTC
Problem SOLVED.

In a general Danish linux forum I found the following solution to the problem:

In firefox launch about:config and in there change dom.ipc.plugins.java.enabled from false to true and once restarted firefox does not crash any more.

I have no idea what this means but the crash is gone.

Comment 9 Martin Stransky 2012-02-27 07:30:05 UTC
Okay, thanks. BTW. It enables java to run in separated process (plugin-container) so the plugin crash does not affects firefox itself.

Comment 10 nicofo 2012-02-27 21:16:26 UTC
Thanks Erik.
But is this bug closed ?
The property "dom.ipc.plugins.java.enable" should be enabled by default OR the crash of the plugin prevented.

Comment 11 Martin Stransky 2012-02-28 08:25:13 UTC
Okay, noving to OpenJDK.

Comment 12 Martin Stransky 2012-03-02 08:15:30 UTC
A possible dupe of https://bugzilla.redhat.com/show_bug.cgi?id=789959
Mozilla bug https://bugzilla.mozilla.org/show_bug.cgi?id=704249

Comment 13 Kim Bisgaard 2012-03-05 19:01:22 UTC
Looks like https://bugzilla.redhat.com/show_bug.cgi?id=794908

In http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=820
there seems to be a working patch - can we have that applied please?

Comment 14 Deepak Bhole 2012-03-05 19:03:25 UTC
*** Bug 794908 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2012-03-05 23:01:16 UTC
icedtea-web-1.0.6-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/icedtea-web-1.0.6-4.fc15

Comment 16 Fedora Update System 2012-03-05 23:02:37 UTC
icedtea-web-1.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/icedtea-web-1.2-1.fc16

Comment 17 Fedora Update System 2012-03-05 23:03:50 UTC
icedtea-web-1.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/icedtea-web-1.2-1.fc17

Comment 18 Deepak Bhole 2012-03-05 23:05:14 UTC
I have submitted updates for all supported Fedora versions. Please try them out on the above links and add karma is all is OK -- thanks!

Comment 19 Kim Bisgaard 2012-03-06 15:41:37 UTC
Works for me on f16.x86_64 - thx!!

Comment 20 Fedora Update System 2012-03-08 05:06:17 UTC
Package icedtea-web-1.2-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing icedtea-web-1.2-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3311/icedtea-web-1.2-1.fc16
then log in and leave karma (feedback).

Comment 21 Fedora Update System 2012-03-08 21:26:57 UTC
icedtea-web-1.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2012-03-11 16:58:35 UTC
icedtea-web-1.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2012-03-17 23:32:12 UTC
icedtea-web-1.0.6-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.