This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 791317 - TypeError: float() argument must be a string or a number
TypeError: float() argument must be a string or a number
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 795030 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-02-16 13:01 EST by John Reiser
Modified: 2012-04-18 20:23 EDT (History)
21 users (show)

See Also:
Fixed In Version: anaconda-17.12-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 20:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda traceback and debug info (795.67 KB, text/plain)
2012-02-16 13:01 EST, John Reiser
no flags Details
anaconda traceback and debug info (24.00 KB, text/plain)
2012-02-21 17:23 EST, John Reiser
no flags Details
anaconda traceback and debug info (797.78 KB, text/plain)
2012-02-21 17:27 EST, John Reiser
no flags Details
updates image to fix traceback (1.92 KB, application/octet-stream)
2012-02-23 13:41 EST, Brian Lane
no flags Details

  None (edit)
Description John Reiser 2012-02-16 13:01:04 EST
Created attachment 562557 [details]
anaconda traceback and debug info

Description of problem: Install from DVD of Fedora 17 Alpha x86_64 RC2 fails when examining Basic Storage.


Version-Release number of selected component (if applicable):
anaconda-17.8

How reproducible: every time (twice so far)


Steps to Reproduce:
1. boot DVD Fedora 17 Alpha x86_64 RC2; accept defaults through Basic Storage Devices
2.
3.
  
Actual results:
anaconda 17.8 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclasses/fedora.py", line 117, in versionMatches
    oldVer = float(oldver)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclass.py", line 218, in productUpgradable
    "version"  : self.versionMatches(oldver),
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1619, in findExistingRootDevices
    (upgradable, tests) = anaconda.instClass.productUpgradable(arch, product, version)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/upgrade.py", line 81, in findRootParts
    upgradeany=flags.cmdline.has_key("upgradeany"))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 383, in dispatch
    self.dir = self.steps[self.step].target(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 247, in go_forward
    self.dispatch()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1200, in nextClicked
    self.anaconda.dispatch.go_forward()
TypeError: float() argument must be a string or a number


Expected results: no error


Additional info:
Comment 1 Brian Lane 2012-02-20 19:59:22 EST
*** Bug 795030 has been marked as a duplicate of this bug. ***
Comment 2 Timothy Davis 2012-02-20 21:18:50 EST
Same issue here, can't install F17 Alpha RC2
Currently have Windows 7, Ubuntu x64, Slackware 13.37, Vector Linux 6 (KDE classic), and Fedora 16 x64
Comment 3 John Reiser 2012-02-21 17:23:40 EST
Created attachment 564792 [details]
anaconda traceback and debug info

Very similar error in Fedora-17-Alpha.RC4 x86_64 DVD.
Comment 4 John Reiser 2012-02-21 17:27:09 EST
Created attachment 564793 [details]
anaconda traceback and debug info

Very similar error from anaconda-17.11 on Fedora-17-Alpha.RC4 x86_64 DVD.
Comment 5 Jurgen Kramer 2012-02-22 12:00:16 EST
I did not encounter this when installing from the RC4 netinstaller. Fixed already?
Comment 6 Timothy Davis 2012-02-22 13:19:32 EST
Still a problem in F17 Alpha RC4
had to wrangle the live cd to get anaconda to work, but it finally did setup a partition.
Comment 7 Adam Williamson 2012-02-22 13:31:59 EST
Just hit this trying to install on top of OpenSUSE 12.1, on a disk with GPT label, a BIOS boot partition previously created by Fedora, and a swap partition and / partition created by openSUSE (both ext4).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2012-02-22 13:46:27 EST
bcl says any install to a disk which has an OS on it that has a /etc/fstab but no /etc/system-release(?) will hit this.

I'm not sure on the /etc/system-release, I think it may actually be /etc/redhat-release .

bcl will provide an updates.img for this soon. We should document it for common bugs.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2012-02-22 13:59:03 EST
confirming that it's /etc/redhat-release which you need, not /etc/system-release.

so a workaround for this bug is to create a bogus /etc/redhat-release file for the offending OS, looking something like "Fedora release 17 (Beefy Miracle)" - the key is to have some word(s) followed by the key word 'release' followed by a number (possibly followed by some more words in brackets, but I think that's not strictly required). I've tested, and creating such a bogus file for openSUSE does indeed avoid the bug in my case.
Comment 10 John Reiser 2012-02-22 14:30:06 EST
Such "unfriendly to other Linux [Debian, Ubuntu, SuSE, ...]" has happened in the past.  One instance is https://bugzilla.redhat.com/show_bug.cgi?id=466785#c1 from about 3 years ago (late 2008.)

I'll wait for bcl's update.img.  I have a few dozen different installed versions from several vendors, and it's more than a minor annoyance to add a file to all the systems which aren't Fedora, RHEL, or Centos.
Comment 11 Brian Lane 2012-02-23 13:41:43 EST
Created attachment 565351 [details]
updates image to fix traceback

This updates.img should fix things.
Comment 12 John Reiser 2012-02-23 16:16:51 EST
The updates.img from Comment 11 works for me.  I successfully installed Fedora 17 Alpha.RC4 i686 DVD on a system which previously got the error "TypeError: float() argument ...".
Comment 13 Adam Williamson 2012-02-28 01:22:14 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Fedora Update System 2012-03-06 10:00:40 EST
anaconda-17.12-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.12-1.fc17
Comment 15 Fedora Update System 2012-03-07 02:21:07 EST
Package anaconda-17.12-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.12-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3157/anaconda-17.12-1.fc17
then log in and leave karma (feedback).
Comment 16 Adam Williamson 2012-04-18 20:23:09 EDT
This is definitely fixed, we never got around to closing it.

Note You need to log in before you can comment on or make changes to this bug.