Bug 791332 - Need to create subpackage for core python library here so that anaconda is not pulled into oVIrt Node
Need to create subpackage for core python library here so that anaconda is no...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On: 771389
Blocks: 742041 791202
  Show dependency treegraph
 
Reported: 2012-02-16 14:16 EST by Mike Burns
Modified: 2016-04-26 23:40 EDT (History)
10 users (show)

See Also:
Fixed In Version: system-config-keyboard-1.3.1-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 771389
Environment:
Last Closed: 2012-03-06 15:38:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch (2.07 KB, patch)
2012-02-22 09:23 EST, Thomas Woerner
no flags Details | Diff

  None (edit)
Description Mike Burns 2012-02-16 14:16:58 EST
+++ This bug was initially created as a clone of Bug #771389 +++

Description of problem:
bug # 791202 requires ovirt-node to include a keyboard selection capability for non-US keyboards.  To do this we'll need to include files from the system-config-keyboard package.

The problem is that s-c-keyboard pulls in too many dependencies and the manual blacklisting that we would have to do would be quite invasive/difficult.  So what we need is a subpackage of s-c-keyboard that contains the core python libraries so that RHEVH can install just the subpackage w/o pulling in all of the dependencies.
Comment 1 Mike Burns 2012-02-16 14:19:53 EST
The RHEL version of the bug is owned by twoerner@redhat.com

Todd,  Can this get fixed in Fedora as well?

Thanks

Mike
Comment 2 Mike Burns 2012-02-16 14:20:31 EST
Sorry, Thomas, not Todd...
Comment 3 Thomas Woerner 2012-02-16 14:27:07 EST
Should be possible, but have to check code first.
Comment 4 Thomas Woerner 2012-02-22 09:23:51 EST
Created attachment 564987 [details]
Proposed patch

Simple fix, only spec file changes needed.
Comment 5 Perry Myers 2012-02-28 13:27:03 EST
@twoerner: Can you commit that spec file change and build a new package in koji for rawhide (or possibly F17 if it's not too late)?
Comment 6 Joey Boggs 2012-02-29 16:32:17 EST
upstream fixed in ovirt-node just need s-c-keyboard-base:
http://gerrit.ovirt.org/2444
Comment 7 Richard W.M. Jones 2012-03-01 08:29:43 EST
Rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3843278
Comment 8 Fedora Update System 2012-03-01 08:33:53 EST
system-config-keyboard-1.3.1-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-8.fc17
Comment 9 Fedora Update System 2012-03-01 08:36:31 EST
system-config-keyboard-1.3.1-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-6.fc16
Comment 10 Fedora Update System 2012-03-01 19:58:37 EST
Package system-config-keyboard-1.3.1-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-keyboard-1.3.1-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2801/system-config-keyboard-1.3.1-8.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-03-06 15:38:57 EST
system-config-keyboard-1.3.1-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-03-07 23:52:21 EST
system-config-keyboard-1.3.1-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.