Bug 79227 - FLOPPY: Unabled to load ramdisk in a boot/root set with kernel 2.4.9 (2.2.19 works)
FLOPPY: Unabled to load ramdisk in a boot/root set with kernel 2.4.9 (2.2.19...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-08 03:26 EST by Daniel F. Dickinson
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-08 15:44:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scripts, kernel, kernel config, and stripped libc to create boot/root set (2.63 MB, application/octet-stream)
2002-12-08 03:48 EST, Daniel F. Dickinson
no flags Details

  None (edit)
Description Daniel F. Dickinson 2002-12-08 03:26:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have written a boot/root creation script for both kernel 2.4.9 and 2.2.19.  I
created the 2.2.19 set because there is a bug in 2.4.9 which prevents the root
ramdisk from being loaded on one particular machine I have.  At the "VFS: 
Insert root floppy disk to be loaded into RAM disk and press ENTER" pressing
enter gives "VFS:  Insert root floppy and press ENTER".  Since I don't have an
uncompressed root I subsequently get an error message that kernel can't load the
root partition.

Because this happens only on one machine and only with kernel 2.4.9 I suspect
that it is a chipset dependant problem in the 2.4 kernels.

2.2.19 succeeds with the boot and reports that FDC0 is a National Semiconductor
PC87306.

If there is a way I can get more messages from the kernel to help you out I'd be
happy to do it (floppy=debug made no difference).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
NOTE:  This bug only occurs on one of the four systems I have tried it on so
there must be a combination of kernel (since 2.2.19 works) and hardware that
produces the bug
2.Create custom kernel without modules but with floppy
3.Create boot disk
4.Create root disk
5.Reboot system with boot floppy in drive
	

Actual Results:  At the "VFS:  Insert root floppy disk to be loaded into RAM
disk and press ENTER" pressing enter gives "VFS:  Insert root floppy and press
ENTER".  Since I don't have an uncompressed root I subsequently get an error
message that kernel can't load the root partition.

Expected Results:  Root disk should have been loaded into ramdisk and system
should boot using root disk.



Additional info:
Comment 1 Daniel F. Dickinson 2002-12-08 03:48:07 EST
Created attachment 87864 [details]
Scripts, kernel, kernel config, and stripped libc to create boot/root set
Comment 2 Arjan van de Ven 2002-12-08 04:13:18 EST
7.2 is using 2.4.18 nowadays....
Comment 3 Daniel F. Dickinson 2002-12-08 15:44:18 EST
2.4.18 works.  This bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.