This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 793431 - (JBEPP-515) Docs: Installation Guide
Docs: Installation Guide
Status: CLOSED NEXTRELEASE
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: unspecified (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 5.1.0.Docs.GA
Assigned To: Scott Mumford
http://jira.jboss.org/jira/browse/JBE...
:
Depends On: JBEPP-627 JBEPP-569 JBEPP-651 JBEPP-652 793595
Blocks: JBEPP-455
  Show dependency treegraph
 
Reported: 2010-09-29 23:26 EDT by Scott Mumford
Modified: 2012-02-28 11:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-12 23:25:31 EST
Type: Task
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEPP-515 None None None Never

  None (edit)
Description Scott Mumford 2010-09-29 23:26:25 EDT
Affects: Documentation (Ref Guide, User Guide, etc.)
project_key: JBEPP

A tracker for issues relating to the EPP Installation Guide.

Please open separate JIRAs for new issues and link them to this tracker.
Comment 1 Scott Mumford 2010-09-29 23:27:44 EDT
Link: Added: This issue is a dependency of JBEPP-455
Comment 2 Scott Mumford 2010-11-01 00:16:29 EDT
No Release Note Required: JIRA pertains to documentation not product
Comment 3 Scott Mumford 2010-11-01 00:16:29 EDT
Release Notes Docs Status: Added: Not Required
Comment 4 Scott Mumford 2010-11-11 07:46:25 EST
Link: Added: This issue depends JBEPP-569
Comment 5 Scott Mumford 2010-11-25 22:16:52 EST
Link: Added: This issue depends JBEPP-673
Comment 6 mposolda 2010-11-26 10:19:12 EST
Chapter 2.2 - Location should be $JBOSS_HOME/server/[configuration]/deploy/ gatein.ear/02portal.war/WEB-INF/web.xml instead of $JBOSS_HOME/server/[configuration]/gatein.ear/02portal.war/WEB-INF/web.xml 

Chapter 5.4.4 Setup Tomcat configuration - I think that this section should be removed in EPP installation guide, no sense to talk about Tomcat here. Only JBoss paragraph 5.3.4 should remain.
Comment 7 Andrew Ross 2010-11-30 21:17:36 EST
4.4. Disabling Authentication
 - examples refer to HTTP GET and POST methods in web.xml
Comment 8 Scott Mumford 2010-12-01 01:06:44 EST
Fixed. Thanks Andrew.
Comment 9 Prabhat Jha 2010-12-02 11:17:56 EST
In Section 2.1, it currently has: "Unfortunately existing JBoss Enterprise Portal Platform 5.0 or 5.0.1 installations cannot be upgraded in order to deploy JBoss Enterprise Portal Platform 5.1.0"  Both EPP 5 and 5.0.1 can be upgraded to 5.1.0.

For SP installation guide, we need to mention that SP can not be installed with EPP 5.0 or EPP 5.0.1
Comment 10 Prabhat Jha 2010-12-02 14:26:12 EST
The section "5.4.4. Setup Tomcat configuration to use your key" needs to be removed.
Comment 11 Prabhat Jha 2010-12-02 14:37:51 EST
For mysql example, since there is example of DB create script for gateinjcr, there should be same for gateinidm.  This way gatein-ds.xml will be more consistent and complete.
Comment 12 Scott Mumford 2010-12-08 00:39:13 EST
Prabhat,
The section 2.1 about not upgrading has been removed and the Tomcat section had already been removed.

Sorry, but I'm not sure what you mean in your last comment. Can you explain a little more?

Should the command <mysql> CREATE DATABASE gateinjcr;> in step two of the "Creating a MySQL Database" procedure be repeated as <mysql> CREATE DATABASE gateinidm;>

That way the line "Do the same with gateinidm." would be replaced with an example of the step.

Is there more to it that should be documented? Should the whole procedure be repeated, and if so, what needs to be different?
Comment 13 Prabhat Jha 2010-12-08 00:52:43 EST
Nope..that should be enough. Usually I like it when an example is complete so instead of "do the same with blah", it's better to say "do this". It's about same amount of work for you anyway. ;-)
Comment 14 Scott Mumford 2010-12-08 22:37:46 EST
Done. Thanks Prabhat.
Comment 15 mposolda 2010-12-09 08:24:12 EST
- Just noticed that warning about disable POST method in login servlet before going to production is duplicated. Same thing is mentioned in section "2.3. Recommended Practices" and in section "4.4. Disabling Authentication" in the final paragraph "Disabling Pre-configured Accounts".

- Site publisher add-on is mentioned in both section "2.1. Upgrading and Add-ons" and in "Chapter 6. Installing Add-ons". I think it may be good to add all these informations into one section? Or at least add some link from section 2.1 into chapter 6 .

- There is still note "MORE INFO NEEDED HERE ON HOW TO DO THIS." in section "2.1. Upgrading and Add-ons". I believe that this is known issue so I am only reminding it :-)
Comment 16 Scott Mumford 2010-12-12 23:25:10 EST
Marek;

The duplicated sections (Disabling the POST method the and mentions of Site Publisher) are ok to stay as they are. They're in context in those places.
Thanks for the shout about it though.

And the "MORE INFO NEEDED" para in sect 2.1 has been replace by some info.

Thanks.
Comment 17 Scott Mumford 2010-12-12 23:25:31 EST
Closing this JIRA as EPP core docs development is stopping for the 5.1.0 release.
For minor issues, please open a JIRA against EPP 5.1.1.
Only re-open this JIRA for blocker or critical issues. 

Note You need to log in before you can comment on or make changes to this bug.