This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 794680 - virt-v2v prints waring:WARNING:/boot/grub/device.map references unknown device /dev/fd0
virt-v2v prints waring:WARNING:/boot/grub/device.map references unknown devic...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
: Regression
: 869562 (view as bug list)
Depends On:
Blocks: 840699 852627
  Show dependency treegraph
 
Reported: 2012-02-17 05:10 EST by tingting zheng
Modified: 2014-09-26 14:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-v2v-0.8.9-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: virt-v2v renames block devices in various guest config files, including /etc/fstab, during conversion. It emits a warning if it encounters a reference to a block device it doesn't know about. Consequence: virt-v2v would emit a redundant warning if a guest's /etc/fstab referenced /etc/fd0. Fix: Warnings about floppy devices are now explicitly suppressed. Result: virt-v2v no longer emits a warning.
Story Points: ---
Clone Of:
: 852627 (view as bug list)
Environment:
Last Closed: 2013-02-21 05:59:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description tingting zheng 2012-02-17 05:10:21 EST
Description of problem:
When convert guests contained a reference to the floppy disk (/dev/fd0),virt-v2v prints waring:WARNING:/boot/grub/device.map references unknown device /dev/fd0

Version-Release number of selected component (if applicable):
virt-v2v-0.8.6-1.el6.x86_64
libvirt-0.9.10-1.el6.x86_64
libguestfs-1.16.5-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.Use virt-v2v to convert a rhel4u8 guest.
Before conversion, the rhel4u8 guest has fd0 in /boot/grub.device.map
(fd0) /dev/fd0
(hd0) /dev/hda

# virt-v2v  -ic xen+ssh://10.66.72.123 -os default xen-hvm-rhel4.8-i386
root@10.66.72.123's password: 
root@10.66.72.123's password: 
rhel4u8-32b-hv-raw-intel.img: 100% [==============================================================================]D 0h07m05s
virt-v2v: WARNING: /boot/grub/device.map references unknown device /dev/fd0. This entry must be manually fixed after conversion.
virt-v2v: WARNING: The connected hypervisor does not support feature pae.
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: xen-hvm-rhel4.8-i386 configured with virtio drivers.

2.After conversion,check /boot/grub/device.map
(fd0) /dev/fd0
(hd0) /dev/vda

Actual results:
There is warning:virt-v2v: WARNING: /boot/grub/device.map references unknown device /dev/fd0. This entry must be manually fixed after conversion.

Expected results:
There should be no warning as actual results.

Additional info:
When tested with virt-v2v-0.8.3-5.el6.x86_64,there is no such warning.
# virt-v2v  -ic xen+ssh://10.66.72.123 -os default xen-hvm-rhel4.8-i386
root@10.66.72.123's password: 
root@10.66.72.123's password: 
rhel4u8-32b-hv-raw-intel.img: 100% [==============================================================================]D 0h07m07s
virt-v2v: WARNING: No mapping found for bridge interface xenbr0 in config file. The converted guest may not start until its network interface is updated.
virt-v2v: xen-hvm-rhel4.8-i386 configured with virtio drivers.
Comment 3 tingting zheng 2012-02-29 21:41:39 EST
Also tested converting a vm with a cdrom device specified in fstab,virt-v2v will print waring:/etc/fstab references unknown device /dev/hdc.

Steps:
1.Before conversion,prepare a vm with a cdrom device specified in fstab
in guest,fstab entry:
/dev/hdc   /media/cdrom    auto    pamconsole,exec,noauto,managed 0 0

2.Use virt-v2v to convert the guest.
# virt-v2v -ic xen+ssh://10.66.72.123 -os default -b breth0 rhel4-32-hvm-min
root@10.66.72.123's password: 
root@10.66.72.123's password: 
rhel4-32-hvm-min.img: 100% [======================================================================================]D 0h00m36s
virt-v2v: WARNING: /etc/fstab references unknown device /dev/hdc. This entry must be manually fixed after conversion.
virt-v2v: WARNING: /boot/grub/device.map references unknown device /dev/fd0. This entry must be manually fixed after conversion.
virt-v2v: rhel4-32-hvm-min configured with virtio drivers.
Comment 6 Matthew Booth 2012-10-16 06:50:33 EDT
This is fixed upstream in commit 6924a592223b52f707868a84b98865391c03d7c3
Comment 8 Cui Lei 2012-10-24 01:36:09 EDT
Verified partial failed, so move the status to "Assigned".
Summary:
Convert guest with floppy verified passed, but Converted a guest with CDrom(In comment 3), the warning message still popup.

Failed Detail please refer to below:

1. Before conversion,prepare a vm with a cdrom device specified in fstab
in guest,fstab entry:
/dev/hdc   /media/cdrom    auto    pamconsole,exec,noauto,managed 0 0

2. Convert from Xen to KVM:
[root@andytest ~]# virt-v2v -ic xen+ssh://10.66.72.23 -os default -b br0 rhel4-32-hvm-min
root@10.66.72.23's password:
root@10.66.72.23's password:
rhel4-32-hvm-min.img: 100% [==============================================================================================================================]D 0h00m42s
virt-v2v: WARNING: /etc/fstab references unknown device /dev/hdc. This entry must be manually fixed after conversion.
virt-v2v: rhel4-32-hvm-min configured with virtio drivers.

The warning message mentioned in Comment 3 still existed

3. After conversion,check guest file /etc/fstab
/dev/hda   /media/cdrom    auto    pamconsole,exec,noauto,managed 0 0

So change the status to "ASSIGNED"
Comment 9 Matthew Booth 2012-10-24 04:38:45 EDT
The bug specifically references fd0, but the test was of hdc. The hdc warning is different, and needs a different bug.
Comment 12 errata-xmlrpc 2013-02-21 05:59:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0477.html
Comment 13 Richard W.M. Jones 2014-09-26 14:33:42 EDT
*** Bug 869562 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.