Bug 869562 - virt-v2v prints waring:WARNING: /etc/fstab references unknown device /dev/hdc.
virt-v2v prints waring:WARNING: /etc/fstab references unknown device /dev/hdc.
Status: CLOSED DUPLICATE of bug 794680
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v (Show other bugs)
6.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Matthew Booth
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-24 05:18 EDT by Cui Lei
Modified: 2014-09-26 14:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-26 14:33:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-10-24 05:18:38 EDT
Description of problem:
When convert guests contained a CDrom (/dev/hdc),virt-v2v prints waring:WARNING: /etc/fstab references unknown device /dev/hdc. This entry must be manually fixed after conversion.

Version-Release number of selected component (if applicable):
virt-v2v-0.8.9-2.el6.x86_64
libguestfs-1.16.32-2.el6.x86_64
libvirt-0.10.2-5.el6.x86_64
augeas-libs-0.9.0-4.el6.x86_64
febootstrap-supermin-helper.x86_64
hivex-1.3.3-4.2.el6.x86_64
libguestfs-winsupport-1.0-7.el6.x86_64
virtio-win-1.5.4-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Before conversion,prepare a vm with a cdrom device specified in fstab
in guest,fstab entry:
/dev/hdc   /media/cdrom    auto    pamconsole,exec,noauto,managed 0 0

2. Convert from Xen to KVM:
[root@andytest ~]# virt-v2v -ic xen+ssh://10.66.72.23 -os default -b br0 rhel4-32-hvm-min
root@10.66.72.23's password:
root@10.66.72.23's password:
rhel4-32-hvm-min.img: 100% [==============================================================================================================================]D 0h00m42s
virt-v2v: WARNING: /etc/fstab references unknown device /dev/hdc. This entry must be manually fixed after conversion.
virt-v2v: rhel4-32-hvm-min configured with virtio drivers.

3. After conversion,check guest file /etc/fstab
/dev/hda   /media/cdrom    auto    pamconsole,exec,noauto,managed 0 0
  
Actual results:
There is warning:virt-v2v: WARNING: /etc/fstab references unknown device /dev/hdc. This entry must be manually fixed after conversion.

Expected results:
There should be no warning as actual results.
Comment 2 RHEL Product and Program Management 2012-12-14 01:49:43 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Richard W.M. Jones 2014-09-26 14:33:42 EDT

*** This bug has been marked as a duplicate of bug 794680 ***

Note You need to log in before you can comment on or make changes to this bug.