Bug 794835 - kde desktop unresponsive in F17 virt-manager, compositing+llvmpipe too slow, not ready
kde desktop unresponsive in F17 virt-manager, compositing+llvmpipe too slow, ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Alpha/F17AlphaBlocker 790142
  Show dependency treegraph
 
Reported: 2012-02-17 13:33 EST by Oliver Henshaw
Modified: 2012-02-28 05:53 EST (History)
12 users (show)

See Also:
Fixed In Version: kde-workspace-4.8.0-8.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-28 05:53:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from Fc17 Alpha RC2 KDE spin in spice-enabled guest (59.15 KB, text/x-log)
2012-02-17 13:33 EST, Oliver Henshaw
no flags Details

  None (edit)
Description Oliver Henshaw 2012-02-17 13:33:37 EST
Created attachment 563957 [details]
Xorg.0.log from Fc17 Alpha RC2 KDE spin in spice-enabled guest

Description of problem:

F17 alpha RC2 boots to desktop but then is unresponsive - e.g. click on the Fedoa menu (the mouse cursor does work) and nothing happens; right click on the desktop and the menu flashes and a shrunken part-animated desktop menu shows up. But this trick only seems to work once, after which I can only get screen updates by interacting with the desktop and typing or clicking blind and then switching to another vt (inside the VM) and back. In this way I can launch e.g. konsole and see output from the command-line. It's an interesting concept for a workflow but I don't think it will catch on.

This was observed with qxl in the guest, but using video:vesa or display: vnc (or both) doesn't make any difference.


Guest packages:

kernel-3.3.0-0.rc3.git5.1.fc17.x86_64
xorg-x11-drv-qxl-0.0.21-16.fc16.x86_64
xorg-x11-drv-vesa-2.3.0-15.fc17.x86_64
kde-workspace-4.8.0-7.fc17.x86_64
qt-4.8.0-8.fc17.x86_64


Host packages:

spice-server-0.10.1-1.fc16.x86_64
spice-gtk-0.9-1.fc16.x86_64
virt-manager-0.9.1-1.fc16.noarch
libvirt-0.9.6-4.fc16.x86_64
Comment 1 nucleo 2012-02-17 16:19:54 EST
Fedora-17-Nightly-20120213.15-i686-Live-kde.iso - last nightly CD that started fine. 20120214 and later are hangs when KDE almost started.
Comment 2 Rex Dieter 2012-02-17 18:59:08 EST
At hackfest today, christoph witnessed the spice/qxl did indeed hang shortly after (auto)login.  a bit of screen corruption, I mostly assumed some sort of qxl video driver issue.

I'll try to reproduce myself tomorrow, see if we can short this (and the ConsoleKit) thing out, or at least get some more useful debugging.
Comment 3 nucleo 2012-02-17 19:06:55 EST
I tested with xdriver=vesa in vmware (because vmware xorg driver crashes - bug 782995).
Comment 4 Oliver Henshaw 2012-02-21 06:53:31 EST
(In reply to comment #1)
> Fedora-17-Nightly-20120213.15-i686-Live-kde.iso - last nightly CD that started
> fine. 20120214 and later are hangs when KDE almost started.

Could it be llvmpipe? http://koji.fedoraproject.org/koji/buildinfo?buildID=299348

Indeed kde-workspace-4.8.0-7.fc17 is in Alpha-RC2 and http://koji.fedoraproject.org/koji/buildinfo?buildID=299348 but not in http://koji.fedoraproject.org/koji/taskinfo?taskID=3787932
Comment 5 Oliver Henshaw 2012-02-21 06:57:14 EST
Whoops. Make that:

Indeed kde-workspace-4.8.0-7.fc17 is in Alpha-RC2 and http://koji.fedoraproject.org/koji/taskinfo?taskID=3790203  but not in
http://koji.fedoraproject.org/koji/taskinfo?taskID=3787932
Comment 6 Radek Novacek 2012-02-21 07:34:53 EST
Confirmed, it works fine with kde-workspace-4.8.0-6. With -7 whole desktop freezes with qxl and vga drivers.
Comment 7 Rex Dieter 2012-02-21 08:27:21 EST
OK, compositing by default + llvmpipe then is fail so far.  May be worth filing bugs against affected drivers.
Comment 8 Rex Dieter 2012-02-21 08:55:31 EST
Alright, looks like llvmpipe simply isn't ready for testing yet, so we'll need to disable compositing by default.  details in the #fedora-kde irc chat below.


[02/21/12 07:47] <rdieter> .bug 794835 
[02/21/12 07:47] <zodbot> rdieter: Bug 794835 kde desktop unresponsive in F17 alpha RC2 with virt-manager - https://bugzilla.redhat.com/show_bug.cgi?id=794835
[02/21/12 07:48] <rdieter> d1saster: ^^ so, seems like compositing+llvmpipe doesn't work too well for qxl and vga drivers at least.
[02/21/12 07:48] <d1saster> rdieter: wasn't that clear after ajax said that the tfp enhancements are not in place yet?
[02/21/12 07:49] <jreznik> revert it?
[02/21/12 07:49] <d1saster> if they are not in place I also hardly doubt that the gnome people will activate compositing
[02/21/12 07:49] <rdieter> hmm... ok, no that wasn't clear to me.
[02/21/12 07:49] <d1saster> it's just damn slow to copy the window pixmap every time
[02/21/12 07:49] <rdieter> if that indeed is a hard requirement, jreznik's suggestion is the best
[02/21/12 07:50] <rdieter> d1saster: thanks
[02/21/12 07:50] <d1saster> yw :)
[02/21/12 07:50] <d1saster> the fedora feature page for this is imho a bit misleading
[02/21/12 07:50] <rdieter> d1saster: do you recall if ajax gave any indication when/if it *would* be ready?
[02/21/12 07:50] <d1saster> it suggests that things are almost done, but from the conversation with ajax I would say they are not
[02/21/12 07:50] <jreznik> :)
[02/21/12 07:51] <rdieter> else, I can ask myself later.
[02/21/12 07:51] <rdieter> (and we can open a bug to track it)
[02/21/12 07:51] <d1saster> he couldn't even say what the opengl render string would be, so I doubt that mesa 8.0 contains the appropriate code
[02/21/12 07:51] <rdieter> probably should have a tracking bug regardless I guess
Comment 9 Rex Dieter 2012-02-21 09:26:58 EST
marking as alpha blocker, the DE is essentially non-functional (matches criteria 19, being able to run a browser/terminal app at least).

It's an EasyFix, we'll mark 
[Compositing]
Enabled=false
in kwinrc again.  This will at least allow testing for those folks who choose to try enabling it manually.
Comment 10 Kevin Kofler 2012-02-21 09:42:25 EST
That's the wrong fix. It will also disable compositing by default for all the hardware drivers, which are perfectly fine and for which we want testing for the compositing.

We should rebuild kde-workspace without the llvmpipe compositing fix instead.
Comment 11 Kevin Kofler 2012-02-21 09:43:04 EST
Without the llvmpipe compositing patch, I mean.
Comment 12 Adam Williamson 2012-02-21 11:18:05 EST
Please submit the build as an update when it's done.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Fedora Update System 2012-02-21 12:05:25 EST
kde-workspace-4.8.0-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-workspace-4.8.0-8.fc17
Comment 14 Fedora Update System 2012-02-21 12:44:39 EST
Package kde-workspace-4.8.0-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-workspace-4.8.0-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2121/kde-workspace-4.8.0-8.fc17
then log in and leave karma (feedback).
Comment 15 Adam Williamson 2012-02-21 13:47:55 EST
+1 blocker on this, it's going to break KDE on VMs and also probably some 'generic' cards.

We had a bad experience in F16 with a similar-impact bug which we didn't take as a blocker until Final, so I'd rather just get this in now.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Robyn Bergeron 2012-02-21 13:50:43 EST
+1 blocker
Comment 17 Jóhann B. Guðmundsson 2012-02-21 13:54:05 EST
+1 blocker
Comment 18 Adam Williamson 2012-02-21 13:58:04 EST
okay, that's three votes, accepting as blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 nucleo 2012-02-21 17:56:24 EST
RC4 Fedora-17-Alpha-i686-Live-KDE.iso don't hangs with xdriver=vesa (desktop effects enabled).
Comment 20 Adam Williamson 2012-02-21 18:36:35 EST
This should be fixed in RC4, the update was pulled in.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Adam Williamson 2012-02-22 14:47:03 EST
Confirm that Alpha RC4 looks good, KDE runs okay in a KVM (bar the CK warning).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Fedora Update System 2012-02-28 05:53:32 EST
kde-workspace-4.8.0-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.