Bug 794899 - "plymouth" not installed in F-17 Alpha RC2 and causes boot to freeze
"plymouth" not installed in F-17 Alpha RC2 and causes boot to freeze
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH
: Triaged
Depends On:
Blocks: F17Alpha/F17AlphaBlocker F17Alpha-accepted/F17AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-02-17 16:23 EST by Michael Schwendt
Modified: 2012-02-21 13:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 13:57:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2012-02-17 16:23:28 EST
Description:
http://lists.fedoraproject.org/pipermail/test/2012-February/105629.html

In short: boot freezes early. No LUKS passphrase prompt.

# systemctl status plymouth-start.service
plymouth-start.service - Show Plymouth Boot Screen
	  Loaded: loaded (/usr/lib/systemd/system/plymouth-start.service; static)
	  Active: failed (Result: exit-code) since Fri, 17 Feb 2012 21:33:56 +0100; 20min ago
	  CGroup: name=systemd:/system/plymouth-start.service

Turnt out that package "plymouth" is not installed. Installing it fixed this.
Comment 1 Michael Schwendt 2012-02-17 16:25:01 EST
Might be related to "plymouth-scripts" not depending on "plymouth" anymore: bug 794894
Comment 2 Adam Williamson 2012-02-17 16:37:18 EST
Oh, that's a good catch.

So yeah, I see two potentially bad dep chains, now. The one Michael identifies is:

plymouth-system-theme requires plymouth(system-theme)
plymouth-theme-charge provides plymouth(system-theme) and requires plymouth-scripts
plymouth-scripts doesn't require plymouth

Note that, in F16, plymouth-scripts doesn't require plymouth either. I suspect it may never have done. So this one hasn't actually changed - though it may be incorrect, and plymouth-scripts maybe ought to require plymouth.

The other one I identified is simply that dracut in F16 requires plymouth, but dracut in F17 does not. I think this might be the one that actually caused plymouth to get installed in the past.

So we can add plymouth to comps itself, or we can add back dracut's dependency on plymouth, or we can make plymouth-scripts depend on plymouth, or we can make something _else_ entirely depend on plymouth. But we have to do something.

+1 blocker, per criterion "The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption or LVM enabled" combined with criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied"



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 John Dulaney 2012-02-18 12:01:04 EST
Hmm, I don't know how I missed the lack of Plymouth.  I can say that my test VM IS booting, and has been the entire time.  I reckon I shouldn't switch to something else while it is booting so I can catch things like this in the future.

Dunno why others are freezing and I'm not, but I'll say +1 blocker.
Comment 4 Adam Williamson 2012-02-19 02:29:21 EST
john: it'll only actually prevent boot working correctly if you have an encrypted partition (because nothing will display the partition unlock prompt). if you don't have any encrypted partition, boot will work, but you'll see no bootsplash or text boot messages.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Robyn Bergeron 2012-02-19 08:22:39 EST
+1 blocker, per criteria cited by Adam.
Comment 6 Adam Williamson 2012-02-20 18:46:02 EST
Discussed at mini-blocker-review meeting of 2012-02-20. No-one's really against this being a blocker, but there was discussion as to whether it may be workaroundable by blindly typing the passphrase. It's also to be noted that you do get a prompt on non-KMS boots (e.g. in a VM).

Since the fix is available, we decided to just accept it as NTH to avoid the discussion going on too long. Blocker status is left as an open question. We expect we'll pull the fix into RC3 anyway, at which point it'll be a moot point.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2012-02-20 18:47:08 EST
Since Ray hasn't given an opinion on how he'd like this to be fixed, I'm just going to go ahead and shove plymouth into comps for now. It's a simple change and easy to revert if desired. Adding a dependency is a bit more complex and slightly harder to revert.
Comment 8 Adam Williamson 2012-02-20 18:55:01 EST
I've gone ahead and added plymouth as default in Base in comps for F17 and F18, for now:

http://git.fedorahosted.org/git/?p=comps.git;a=commit;h=ed64ea886543e82b74ed7a26ac9ad5ab31591ef6

if we decide to fix this with a dependency in the long term, we can revert that.
Comment 9 Adam Williamson 2012-02-21 13:57:37 EST
Okay, RC3 has plymouth included, so we can close this, as the change was in comps so it's already 'live'.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.