This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 795082 - ibus shortcut key doesn't work
ibus shortcut key doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
: 799949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-19 02:46 EST by Jaekyun Lee
Modified: 2012-03-18 21:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.4.99.20120317-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-18 21:24:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jaekyun Lee 2012-02-19 02:46:23 EST
Description of problem:

Enable of Disable keyboard shortcut key in ibus-setup can not change input method.
and i can not set next input method too,
configuration option window doen't work

only ctrl+space key can change it

Version-Release number of selected component (if applicable):

ibus-1.4.99.20120203-3.fc18.x86_64

How reproducible:

Steps to Reproduce:
1. set Enable of Disable keyboard shotcut key to shift+space
2. press shift + space
  
Actual results:

no effect
Comment 1 fujiwara 2012-02-19 20:59:54 EST
Please use dconf-editor for the workaround.
# yum install dcont-editor
% dconf-editor
/desktop/ibus/general/hotkey/trigger-accel
"<Shift>space"

Since we changed the shortcut key from gdk to gtk, the string format was changed.
Comment 2 Jaekyun Lee 2012-03-09 04:06:12 EST
Dear fujiwara, 

It seems this workaround doens't work 
I edited trigger-accel key to <Shift>Space and <Shift_L>Space, but input methods doesn't changed. only <Control>Space works 

Version-Release number of selected component (if applicable):

ibus-1.4.99.20120304-2.fc18.x86_64 (rawhide)
Comment 3 fujiwara 2012-03-09 04:27:05 EST
Did you restart ibus after the dconf value was changed?
Comment 4 Jaekyun Lee 2012-03-09 04:46:54 EST
yes, I restarted X session, and i checked process id is changed after session is restarted. but it still doesn't work
Comment 5 fujiwara 2012-03-13 22:51:56 EDT
I confirmed '<Shift>space' works fine.
I don't think Shift_L can work.
Comment 6 fujiwara 2012-03-13 22:58:45 EDT
*** Bug 799949 has been marked as a duplicate of this bug. ***
Comment 7 fujiwara 2012-03-18 21:24:32 EDT
I changed the ibus-setup GUI.
BTW, if you use gnome-shell, Shift+Space won't be supported since Shift is used as the reverse conversion.

Note You need to log in before you can comment on or make changes to this bug.