This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 799949 - [abrt] ibus-1.4.99.20120203-3.fc17: keyboardshortcut.py:195:__set_selected_shortcut:TypeError: 'TreePath' object does not support indexing
[abrt] ibus-1.4.99.20120203-3.fc17: keyboardshortcut.py:195:__set_selected_sh...
Status: CLOSED DUPLICATE of bug 795082
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:7dd515635542a688383780a83fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 08:15 EST by Robin Lee
Modified: 2012-03-13 22:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 22:58:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin Lee 2012-03-05 08:15:26 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/share/ibus/setup/main.py ibus-setup
comment:        I was adding a new keyboard shortcut for 'Enable or disable'.
executable:     /usr/share/ibus/setup/main.py
kernel:         3.3.0-0.rc4.git1.4.fc17.x86_64
reason:         keyboardshortcut.py:195:__set_selected_shortcut:TypeError: 'TreePath' object does not support indexing
time:           Mon 05 Mar 2012 09:09:02 PM CST
uid:            1000
username:       cheese

backtrace:
:keyboardshortcut.py:195:__set_selected_shortcut:TypeError: 'TreePath' object does not support indexing
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/setup/keyboardshortcut.py", line 288, in __apply_button_clicked_cb
:    self.__set_selected_shortcut(shortcut)
:  File "/usr/share/ibus/setup/keyboardshortcut.py", line 195, in __set_selected_shortcut
:    model[path[0]][0] = shortcut
:TypeError: 'TreePath' object does not support indexing
:
:Local variables in innermost frame:
:column: <TreeViewColumn object at 0x2eac6e0 (GtkTreeViewColumn at 0x2ff1340)>
:path: <GtkTreePath at 0x30b2060>
:model: <ListStore object at 0x2eac640 (GtkListStore at 0x31a80a0)>
:self: <KeyboardShortcutSelection object at 0x2ea2be0 (keyboardshortcut+KeyboardShortcutSelection at 0x2e6b480)>
:shortcut: 'Control+Super_L'
Comment 1 fujiwara 2012-03-13 22:58:45 EDT
Currently the GUI does not work since event handling switched from gdk to gtk.

Workaround: Please modify the dconf key direclty
1. Invoke dconf-editor
2. Change /desktop/ibus/general/hotkey/trigger-accel from '<Control>space' to '<Control>Super_L'.
3. Restart ibus-daemon

*** This bug has been marked as a duplicate of bug 795082 ***

Note You need to log in before you can comment on or make changes to this bug.