Bug 795327 - [ta_IN] Request to add Lohit Tamil Classical with old Tamil ligatures of -aa and -ai
Summary: [ta_IN] Request to add Lohit Tamil Classical with old Tamil ligatures of -aa ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-tamil-fonts
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-20 09:25 UTC by Shriramana Sharma
Modified: 2012-07-20 11:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-20 11:51:14 UTC
Type: ---


Attachments (Terms of Use)
Lohit Tamil font v2.5.0 with name changed to Lohit Tamil Classical, and additional glyphs added to PUA temporarily (28.39 KB, application/zip)
2012-02-20 09:25 UTC, Shriramana Sharma
no flags Details
Additional glyphs for classical Tamil orthography (13.53 KB, application/zip)
2012-03-25 12:00 UTC, Shriramana Sharma
no flags Details
Font with corrections for glyph shape and LSB/RSB applied (67.13 KB, application/octet-stream)
2012-05-01 04:22 UTC, Shriramana Sharma
no flags Details

Description Shriramana Sharma 2012-02-20 09:25:10 UTC
Created attachment 564352 [details]
Lohit Tamil font v2.5.0 with name changed to Lohit Tamil Classical, and additional glyphs added to PUA temporarily

Description of problem:

The Tamil script has a classical orthography in which the vowel sign -aa ligates with the consonants ண NNA ன NNNA ற RRA and the vowel sign -ai ligates with the consonants ண NNA ன NNNA ல LA ள LLA. 

Thus ணா னா றா (also seen in the right part of ணொ னொ றொ ணோ னோ றோ) and ணை னை லை ளை would be presented differently. 

This classical style has been documented in the Unicode chapter on Tamil: http://www.unicode.org/versions/Unicode6.0.0/ch09.pdf p 300 and 301 (in the book, not of the PDF) under the name of "Ligatures with -aa in Traditional Tamil Orthography" and "Ligatures with -ai in Traditional Tamil Orthography".

So far we are aware of only one Unicode Tamil font which supports it, e-Tamil OTC by Elmar Kniprath from http://www.aai.uni-hamburg.de/indtib/INDOLIPI/Indolipi.htm (http://www.aai.uni-hamburg.de/indtib/INDOLIPI/Tamil.zip). You can check how that font renders the text: ணா னா றா / ணொ னொ றொ / ணோ னோ றோ / ணை னை லை ளை. However we especially like the visual style of Lohit Tamil so we wanted to do a classical style Tamil font based on Lohit Tamil. 

So we have added the glyphs to the Lohit Tamil TTF font version 2.5.0 and request to convert it into a Lohit Tamil Classical font to be separately parallelly released apart from the Lohit Tamil font.

Version-Release number of selected component (if applicable):

2.5.0

How reproducible:

Install Lohit Tamil font. Type ணா னா றா / ணொ னொ றொ / ணோ னோ றோ / ணை னை லை ளை.
  
Actual results:

There are no ligatures of vowel signs -aa and -ai. This is CORRECT behaviour in modern orthography but NOT in classical orthography.

Expected results:

The vowel signs -ai and -ai should ligate with the consonants as described above.

Additional info:

The ligating presentation of the vowel sign -ai is colloquially called "elephant's trunk ai" due to resemblance. After reordering the consonant and -ai ை, the ை glyph can be replaced by the elephant's trunk glyph in contextual substitution before NNA NNNA LA and LLA.

The metrics of the {elephant-ai} glyph should however be such that when it simply replaces the regular {ai} glyph ை, it will correctly go and touch into the nna ண nnna ன etc glyphs. Specifically, it will definitely have a negative RSB. Currently we have determined that with an RSB of -118 it will look correct and join with the following ண ன ல ள consonants correctly.

Comment 1 Shriramana Sharma 2012-03-25 12:00:47 UTC
Created attachment 572521 [details]
Additional glyphs for classical Tamil orthography

Please find attached the finalized extra glyphs required for Classical Tamil Orthography. Sorry for the delay in finalizing.

I have designed them based on existing glyphs so as to following the existing design as far as possible. Hope you find them acceptable. I have also included a PDF demonstrating the classical orthography using the new glyphs.

A few points:

The bearings of the additional glyphs for NNAA NNNAA and RRAA are the same as those of RU because I felt that is the closest similar glyph but feel free to change them. I notice that not all the glyphs have the same bearings, so you probably know better than me what exact values to give.

But for the elephant's trunk (alternate form of ை to be used when combining with ண ன ல ள) I find that allotting an RSB of -124 (minus 124) makes it properly overlap the glyphs of the relevant consonants to give it the connected appearance, because the consonants have LSB-s around 52-57. I have tested this by zooming to 1000% to be sure that no minor gaps are present. 

I don't know why the LSB-s of the consonants are all different but again I leave it to you to ensure that the elephant's trunk correctly overlaps with the consonants. 

After importing the glyphs into the font and adding the requisite OT programming, please post the font for testing. Thank you very much.

Comment 2 Pravin Satpute 2012-03-27 03:46:02 UTC
yes, sure i will put it for testing. apology from my side as well for taking more time for this. lets try to by next week.

Comment 3 Pravin Satpute 2012-04-20 09:49:34 UTC
Hi,


I have added rules for this and also resolved some problems of shapes. 
http://pravins.fedorapeople.org/Lohit-TamilClassical.ttf  let me know if this works for you.

Comment 4 Shriramana Sharma 2012-05-01 04:22:41 UTC
Created attachment 581304 [details]
Font with corrections for glyph shape and LSB/RSB applied

Hello Pravin and thanks for the work.

The rendering logic is now working correctly, and all the following relevant sequences (for classical orthography) are appropriately displayed:

ணா னா றா
ணொ னொ றொ 
ணோ னோ றோ
ணை னை லை ளை

However apparently you had used the old glyphs (which I first provided) for the elephant's trunk form of ை. I had corrected those glyphs (in my second attachment) as they were not looking good. Now I have replaced the appropriate glyphs in the finalized TTF with the new shapes.

Also, there was a problem with the LSB/RSB of the relevant glyphs for classical orthography by which there was too much inter-glyph space in flowing text. I have corrected that also.

Please find both above corrections in the attached TTF.

I still find some aesthetic issues with the LSB/RSB of many other glyphs. For example, துணி has too much inter-glyph space. Compare with தணி or பணி. But I guess we'll work on that at a later date and under a different bug as the present issue is hereby resolved.

Just one last question: I had thought it would be possible (by looking at the e-Tamil OTC font from http://www.aai.uni-hamburg.de/indtib/INDOLIPI/Tamil.zip) that it would be possible to simply substitute the ை glyph by the elephant's trunk glyph when it combines with ண ன ல ள. Here however you have apparently written rules to simply replace ணை னை லை ளை by the appropriate ligated glyphs. Would it be too much trouble for you to effect it in the ideal way? That way, if any corrections to ண ன ல ள are applied they would be automatically affected in the case of ணை னை லை ளை also.

Comment 5 Pravin Satpute 2012-05-11 07:44:28 UTC
Update font is available at http://pravins.fedorapeople.org/Lohit-TamilClassical.ttf

Yes, we can simply change  ை shape as well but in tI gone with ligature approach, since you provided samehat case we will require positioning or kerning as well to get shape at exact position.
substitution + positioning both rules will be required.

Our followed approach is also fine, since number of ligature are not very high in number.

In future version i will remove ligature and use substitution approach.

Let me know your comments on testing, so i can release lohit tamil in upstream.

Comment 6 Shriramana Sharma 2012-05-15 05:47:48 UTC
As far as the required classical Tamil orthography is concerned, in terms of correct display of ligatures etc, this font is OK, but there are some problems with two Tamil numeral glyphs in this font. I'll clarify that in bug #807068.

One more point. The descender for this font is -380 as against -419 for the regular Lohit Tamil font. I think it would be good to have a uniform descender so the two fonts are mutually metrically compatible. Lohit Tamil 2.5.0 had -380 only. Is there a reason that the updated version of Lohit Tamil (not Classical) has as larger descender? Do you want me to file a separate bug for that?

Comment 7 Pravin Satpute 2012-05-29 08:44:07 UTC
i think that problem happened due to we moved 1000 and 100 shaped down than other shapes. Now check and update me.

Can you check it with .sfd files in svn repo? or let me know if you want ttf.

Also it will be nice if you can provide patch next time.

Comment 8 Shriramana Sharma 2012-05-29 12:01:31 UTC
(In reply to comment #7)
> i think that problem happened due to we moved 1000 and 100 shaped down than
> other shapes. Now check and update me.

Now the descender for both Lohit Tamil and Tamil Classical are -380. Thank you.

> Can you check it with .sfd files in svn repo? or let me know if you want ttf.

No probs, I generated the TTF myself.

> Also it will be nice if you can provide patch next time.

You mean as in a text patch file? So it will be possible to execute the actual set of changes requested? OK, and I have used the diff command, but please tell me how to use diff command to output patch in required format so I can do that. (sfddiff output seems too verbose.)

Basically you should know that for font editing purposes I'm not using FontForge but a licensed copy of High-Logic Font Creator (http://www.high-logic.com/font-editor/fontcreator.html), so all my changes are done directly in the TTF. 

I'm not clear as to how to convert the TTF back to SFD i.e. text format from which to produce patch for you. Please advise.

[Formerly you had some concerns about GPL-compliance of TTF format. I hope you no longer have those concerns. See https://www.redhat.com/archives/lohit-devel-list/2011-July/msg00014.html, especially the words: """TTF format gives you access to full useful information. It *is* a native/source format."""]

Comment 9 Pravin Satpute 2012-05-30 05:21:08 UTC
As you know Fontforge .sfd file is text file. Since you are not using Fontforge then its fine just sent me ttf i will merge it.

Yeah, I prefer .sfd over ttf.

Good, we can now release Lohit TamilClassical  :)

Comment 10 Pravin Satpute 2012-07-18 12:53:00 UTC
can we close this bug now?

Comment 11 Shriramana Sharma 2012-07-20 10:15:50 UTC
Hi -- I have no issues pending since the font is working correctly. But I thought normally you close bugs only after pushing it to the repositories? Or is it not possible/necessary for Tamil Classical to be included in Fedora? Would you need a separate package or something like that? 

I mean, I don't use Fedora (sorry) but it might be useful for Fedora users to be able to install this font variant too. 

It is your call. I have no objections if the bug is closed now.

Comment 12 Pravin Satpute 2012-07-20 11:51:14 UTC
Yes this font is in Fedora repository now :)
see https://bugzilla.redhat.com/show_bug.cgi?id=830743 

One can install simply by $yum install lohit-tamil-classical-fonts, need to enable testing repository for Fedora 17, will be stable by 1 week.


Note You need to log in before you can comment on or make changes to this bug.