This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 795740 - [6d19136de7af9135dd23662f18c3ee544a2888da]: gluster volume set help command broken.
[6d19136de7af9135dd23662f18c3ee544a2888da]: gluster volume set help command b...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kaushal
:
: 796044 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-02-21 07:30 EST by Rahul C S
Modified: 2013-07-24 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:52:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 1f3a0dd4742a2fcd3215aee4a5e22125d7ea4f4d
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rahul C S 2012-02-21 07:30:42 EST
Description of problem:
gluster volume set help does not show full help.
root@Dagobah:~# gluster volume set help
Option: cluster.self-heal-window-size
Default Value: 1
Description: Maximum number blocks per file for which self-heal process would be applied simultaneously.

Option: cluster.data-self-heal-algorithm
Default Value: 
Description: Select between "full", "diff". The "full" algorithm copies the entire file from source to sink. The "diff" algorithm copies to sink only those blocks whose checksums don't match with those of source.

Option: cluster.stripe-block-size
Default Value: 128KB
Description: Size of the stripe unit that would be read from or written to the striped servers.

Option: diagnostics.brick-log-level
Default Value: INFO
Description: Changes the log-level of the bricks

Option: diagnostics.client-log-level
Default Value: INFO
Description: Changes the log-level of the clients

Option: diagnostics.brick-sys-log-level
Default Value: CRITICAL
Description: Gluster's syslog log-level

Option: diagnostics.client-sys-log-level
Default Value: CRITICAL
Description: Gluster's syslog log-level

Option: perfor
root@Dagobah:~#
Comment 1 Rahul C S 2012-02-22 01:52:43 EST
*** Bug 796044 has been marked as a duplicate of this bug. ***
Comment 2 Kaushal 2012-03-05 22:42:08 EST
This was fixed by commit bd94f6a for bug https://bugzilla.redhat.com/show_bug.cgi?id=796040 (review at http://review.gluster.com/2822).
Hence, changing bug status.
Comment 3 Rahul C S 2012-04-05 04:13:19 EDT
set help shows full output now.

Note You need to log in before you can comment on or make changes to this bug.