Bug 796234 - [abrt] libreoffice-core-3.4.5.2-5.fc16: XkbUseExtension: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.4.5.2-5.fc16: XkbUseExtension: Process /usr/lib64/l...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:daa9c8aff9e50a5db204db58e04...
:
: 815166 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-22 09:40 EST by Lofton Alley
Modified: 2012-04-25 07:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-3.4.5.2-6.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 07:26:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (20.24 KB, text/plain)
2012-02-22 09:40 EST, Lofton Alley
no flags Details
File: maps (94.54 KB, text/plain)
2012-02-22 09:40 EST, Lofton Alley
no flags Details
File: backtrace (65.43 KB, text/plain)
2012-02-22 09:40 EST, Lofton Alley
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 818761 None None None Never
Launchpad 887691 None None None Never

  None (edit)
Description Lofton Alley 2012-02-22 09:40:40 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/jim/Documents/AE/iBT4+/Week4/LessonPlanWeek4.odt --splash-pipe=7
crash_function: XkbUseExtension
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.2.6-3.fc16.x86_64
pid:            2410
pwd:            /home/jim
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           Wed 22 Feb 2012 08:48:13 AM EST
uid:            1000
username:       jim
xsession_errors: 

backtrace:      Text file, 67001 bytes
dso_list:       Text file, 20729 bytes
maps:           Text file, 96811 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=c007961
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=2397
:GPG_AGENT_INFO=/tmp/keyring-DlPJ5Y/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2328-c007961-libreoffice-0_TIME173685378
:HISTSIZE=1000
:XDG_SESSION_COOKIE=c646e71bc8882aea4fc58a070000000c-1329744284.799646-1267009954
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:QTDIR=/usr/lib/qt-3.3
:GNOME_KEYRING_CONTROL=/tmp/keyring-DlPJ5Y
:QTINC=/usr/lib/qt-3.3/include
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=IBus
:USER=jim
:SSH_AUTH_SOCK=/tmp/keyring-DlPJ5Y/ssh
:USERNAME=jim
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1485,unix/unix:/tmp/.ICE-unix/1485
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/jim
:PATH=/usr/lib/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jim/.local/bin:/home/jim/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/jim
:XMODIFIERS=@im=ibus
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/jim
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=jim
:QTLIB=/usr/lib/qt-3.3/lib
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Bdwf0D0aO5,guid=0c97d7f56ede17f9efce43e900000019
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/jim
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-jim-G1pcD3/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

smolt_data:
:
:
:General
:=================================
:UUID: a0cb70fb-2f97-49d4-90bd-1c7c6697a286
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 5985.98
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2992
:System Memory: 3827
:System Swap: 999
:Vendor: Dell Inc.
:System: OptiPlex 780 
:Form factor: Mini Tower
:Kernel: 3.2.6-3.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:11792:4136:1056) pci, None, HOST/PCI, 4 Series Chipset DRAM Controller
:(32902:11793:4136:1056) pci, pcieport, PCI/PCI, 4 Series Chipset PCI Express Root Port
:(32902:14944:4136:1056) pci, i801_smbus, SERIAL, 82801JD/DO (ICH10 Family) SMBus Controller
:(32902:14850:4136:1056) pci, ahci, STORAGE, 82801JD/DO (ICH10 Family) SATA AHCI Controller
:(32902:14868:4136:1056) pci, None, PCI/ISA, 82801JDO (ICH10DO) LPC Interface Controller
:(32902:4318:4136:630) pci, e1000e, ETHERNET, 82567LM-3 Gigabit Network Connection
:(32902:9294:4136:1056) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:14949:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #2
:(32902:14948:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #1
:(32902:14953:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #6
:(32902:14950:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #3
:(32902:14954:4136:1056) pci, ehci_hcd, USB, 82801JD/DO (ICH10 Family) USB2 EHCI Controller #1
:(32902:14956:4136:1056) pci, ehci_hcd, USB, 82801JD/DO (ICH10 Family) USB2 EHCI Controller #2
:(32902:14960:4136:1056) pci, pcieport, PCI/PCI, 82801JD/DO (ICH10 Family) PCI Express Port 1
:(32902:14962:4136:1056) pci, pcieport, PCI/PCI, 82801JD/DO (ICH10 Family) PCI Express Port 2
:(32902:11796:4136:1056) pci, None, SIMPLE, 4 Series Chipset HECI Controller
:(32902:11799:4136:1056) pci, serial, 16550_SERIAL, 4 Series Chipset Serial KT Controller
:(32902:14958:4136:1056) pci, snd_hda_intel, MULTIMEDIA, 82801JD/DO (ICH10 Family) HD Audio Controller
:(32902:14951:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #4
:(32902:14952:4136:1056) pci, uhci_hcd, USB, 82801JD/DO (ICH10 Family) USB UHCI Controller #5
:(4098:38341:4136:834) pci, radeon, VIDEO, RV620 LE [Radeon HD 3450]
:(32902:11798:4136:1056) pci, ata_generic, STORAGE, 4 Series Chipset PT IDER Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda2 / ext4 4096 4096 5103904 3125631 2869631 1281120 1025450 1025450
:/dev/sda5 /home ext4 4096 4096 72554918 63096984 59465074 18161664 18149727 18149727
:/dev/sda1 /boot ext4 1024 1024 508745 411053 385453 128016 127785 127785
:/dev/sdb1 WITHHELD vfat 16384 16384 30509197 2461323 2461323 0 0 0
:

var_log_messages:
:Feb 20 08:29:28 c007961 kernel: [  309.077054] soffice.bin[2836]: segfault at a20 ip 0000003d3f09bd53 sp 00007fffcea99950 error 4 in libX11.so.6.3.0[3d3f000000+139000]
:Feb 20 08:29:29 c007961 abrt[3048]: Saved core dump of pid 2836 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-02-20-08:29:28-2836 (115458048 bytes)
:Feb 20 10:42:48 c007961 abrt[15889]: File '/usr/lib64/libreoffice/program/soffice.bin' seems to be deleted
:Feb 20 10:42:48 c007961 kernel: [ 8309.100423] soffice.bin[5187]: segfault at a20 ip 0000003d3f09bd53 sp 00007ffff3afa080 error 4 in libX11.so.6.3.0[3d3f000000+139000]
:Feb 20 10:42:49 c007961 abrt[15889]: Saved core dump of pid 5187 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-02-20-10:42:48-5187 (126435328 bytes)
:Feb 20 14:44:36 c007961 kernel: [22817.497470] soffice.bin[16903]: segfault at a20 ip 0000003d3f09bd53 sp 00007fff28513860 error 4 in libX11.so.6.3.0[3d3f000000+139000]
:Feb 20 14:44:47 c007961 abrt[5598]: Saved core dump of pid 16903 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-02-20-14:44:36-16903 (234733568 bytes)
:Feb 22 08:48:13 c007961 kernel: [174233.881951] soffice.bin[2410]: segfault at a20 ip 0000003d3f09bd53 sp 00007ffff4cdd5d0 error 4 in libX11.so.6.3.0[3d3f000000+139000]
:Feb 22 08:48:19 c007961 abrt[3081]: Saved core dump of pid 2410 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-02-22-08:48:13-2410 (96292864 bytes)
Comment 1 Lofton Alley 2012-02-22 09:40:44 EST
Created attachment 564989 [details]
File: dso_list
Comment 2 Lofton Alley 2012-02-22 09:40:45 EST
Created attachment 564990 [details]
File: maps
Comment 3 Lofton Alley 2012-02-22 09:40:47 EST
Created attachment 564991 [details]
File: backtrace
Comment 4 Caolan McNamara 2012-02-22 09:53:22 EST
crash during shutdown
Comment 5 Caolan McNamara 2012-02-22 10:06:42 EST
I see that the immediate crash location with a null dpy and calling XkbQueryExtension can't happen any more in master given http://cgit.freedesktop.org/libreoffice/core/commit/?id=04b9c2f633f0be1b676933943bdd0b1dc58b5471

Probably triggered by some additional event loops after display is closed
Comment 6 Caolan McNamara 2012-02-22 10:10:34 EST
might as well back-port the removal
Comment 7 Caolan McNamara 2012-04-25 07:25:15 EDT
*** Bug 815166 has been marked as a duplicate of this bug. ***
Comment 8 Caolan McNamara 2012-04-25 07:26:08 EDT
ended up being tricky to backport

Note You need to log in before you can comment on or make changes to this bug.