Bug 796344 - Not compatible with JDK7
Summary: Not compatible with JDK7
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mapserver   
(Show other bugs)
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Lisý
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.osgeo.org/pipermail/maps...
Whiteboard:
Keywords:
: 839627 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-02-22 17:34 UTC by jiri vanek
Modified: 2013-06-12 03:34 UTC (History)
5 users (show)

Fixed In Version: mapserver-6.2.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 03:03:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git-formated patch (3.84 KB, patch)
2012-02-22 17:42 UTC, jiri vanek
no flags Details | Diff
phpmodule-failed build log (188.30 KB, text/plain)
2012-02-22 17:46 UTC, jiri vanek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 828161 None None None Never

Internal Trackers: 828161

Description jiri vanek 2012-02-22 17:34:36 UTC
After mass rebuild for openjdk7 this package was not build due to java
incompatibility. See
https://fedoraproject.org/wiki/Java7_Package_Rebuild_Status for details.

Comment 1 jiri vanek 2012-02-22 17:42:48 UTC
Created attachment 565053 [details]
git-formated patch

fter updated to jdk7 build failed because of broken php subpackage dependences log, after disabliing of php package works fine with jdk7 patch

Comment 2 jiri vanek 2012-02-22 17:46:34 UTC
Created attachment 565055 [details]
phpmodule-failed build log

log to failed php module. see: 
cd mapscript/php; make; cd ../..
make[1]: Entering directory `/builddir/build/BUILD/mapserver-6.0.1/mapscript/php'
gcc -fPIC -ldl -fPIC -Wall   -DUSE_PHP_REGEX -DCOMPILE_DL=1  -DUSE_FASTCGI -DUSE_CAIRO -DUSE_FRIBIDI -DUSE_FRIBIDI2    -DUSE_WMS_LYR -DUSE_WFS_LYR -DUSE_SOS_SVR -DUSE_LIBXML2 -DUSE_CURL -DUSE_CURLOPT_PROXYAUTH  -DUSE_WCS_SVR -DUSE_WFS_SVR -DUSE_WMS_SVR   -DUSE_POSTGIS -DPOSTGIS_HAS_SERVER_VERSION -DUSE_GDAL -DUSE_OGR -DUSE_GEOS  -DUSE_THREAD -DUSE_PROJ -DUSE_AGG_SVG_SYMBOLS    -DUSE_GD_GIF -DUSE_GD_PNG -DUSE_GD_JPEG -DUSE_GD_WBMP -DUSE_GD_FT -DGD_HAS_FTEX_XSHOW -DGD_HAS_GDIMAGEGIFPTR -DGD_HAS_GETBITMAPFONTS -DGD_HAS_GET_TRUE_COLOR_PIXEL -DUSE_ICONV -DUSE_GIF -DUSE_PNG -DUSE_ZLIB -DUSE_FREETYPE  -I/builddir/build/BUILD/mapserver-6.0.1 -I/usr/include -I/usr/include/fastcgi -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng15   -I/usr/include/fribidi     -I/usr/include/libxml2    -I/usr/include -I/usr/include/gdal -I/usr/include   -Irenderers/agg/include  -Irenderers/agg/include   -I/usr/include   -I/usr/include/freetype2  -I/usr/include/php -I/usr/include/php/dl -I/usr/include/php/main -I/usr/include/php/Zend -I/usr/include/php/include -I/usr/include/php/TSRM  -I/usr/include/php/ext/ereg/ -c -o php_mapscript_util.o php_mapscript_util.c
php_mapscript_util.c: In function 'mapscript_object_new':
php_mapscript_util.c:45:41: error: 'zend_class_entry' has no member named 'default_properties'
php_mapscript_util.c: In function 'mapscript_object_new_ex':
php_mapscript_util.c:62:41: error: 'zend_class_entry' has no member named 'default_properties'
make[1]: Leaving directory `/builddir/build/BUILD/mapserver-6.0.1/mapscript/php'
make[1]: *** [php_mapscript_util.o] Error 1

Comment 3 jiri vanek 2012-02-22 17:51:59 UTC
Warning - the proposed patch will remove php plugin!

Comment 4 Petr Pisar 2012-09-04 14:11:10 UTC
*** Bug 839627 has been marked as a duplicate of this bug. ***

Comment 5 Petr Pisar 2012-09-04 14:14:46 UTC
This is about PHP 5.4. Not about JDK.

Comment 6 Petr Pisar 2012-09-04 15:06:11 UTC
However there is something wrong with Java stuff too, see bug #828161:

+ make
javac edu/umn/gis/mapscript/*.java
edu/umn/gis/mapscript/layerObj.java:445: error: cannot find symbol
        classobj.layer=this;
                ^
  symbol:   variable layer
  location: variable classobj of type classObj
edu/umn/gis/mapscript/layerObj.java:497: error: cannot find symbol
                clazz.layer=this;
                     ^
  symbol:   variable layer
  location: variable clazz of type classObj
edu/umn/gis/mapscript/mapObj.java:289: error: cannot find symbol
        layer.map=this;
             ^
  symbol:   variable map
  location: variable layer of type layerObj
edu/umn/gis/mapscript/mapObj.java:329: error: cannot find symbol
                layer.map=this;
                     ^
  symbol:   variable map
  location: variable layer of type layerObj
edu/umn/gis/mapscript/mapObj.java:341: error: cannot find symbol
                layer.map=this;
                     ^
  symbol:   variable map
  location: variable layer of type layerObj
5 errors
make: *** [mapscript_java] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.oKWMaC (%build)

Comment 7 Petr Pisar 2012-09-04 15:09:20 UTC
I wonder where the file mapscript/java/edu/umn/gis/mapscript/layerObj.java comes from because it's not in the source tar ball.

Comment 8 Pavel Lisý 2012-10-15 17:19:16 UTC
It is downloaded by swig I suppose:

make interface
mkdir -p edu/umn/gis/mapscript 
swig -java -package edu.umn.gis.mapscript -outdir edu/umn/gis/mapscript -o mapscript_wrap.c ../mapscript.i

But I don't know yet how to solve build problem, any suggestions?

Comment 9 Fedora Update System 2013-05-22 16:24:32 UTC
mapserver-6.2.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mapserver-6.2.1-1.fc17

Comment 10 Fedora Update System 2013-06-02 18:41:19 UTC
Package mapserver-6.2.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mapserver-6.2.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9870/mapserver-6.2.1-1.fc19
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2013-06-03 03:03:07 UTC
mapserver-6.2.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-06-11 09:02:45 UTC
mapserver-6.2.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2013-06-12 03:34:57 UTC
mapserver-6.2.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.