Bug 79729 - pstack segfaults
pstack segfaults
Status: CLOSED DUPLICATE of bug 98162
Product: Red Hat Raw Hide
Classification: Retired
Component: pstack (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 79578 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-12-16 05:05 EST by Tim Waugh
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:50:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2002-12-16 05:05:31 EST
[root@cyberelk root]# gdb --args pstack 15590
GNU gdb Red Hat Linux (5.3post-0.20021129.3rh)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
(no debugging symbols found)...
(gdb) r
Starting program: /usr/bin/pstack 15590
(no debugging symbols found)...(no debugging symbols found)...
15590: /usr/libexec/fish-applet-2
--oaf-activate-iid=OAFIID:GNOME_FishApplet_Factory --oaf-ior-fd=22
 
Program received signal SIGSEGV, Segmentation fault.
0x080497cd in resolveSymbols ()
(gdb) bt
#0  0x080497cd in resolveSymbols ()
#1  0x00000000 in ?? ()
(gdb)

pstack-1.1-4
Comment 1 Joe Orton 2003-01-09 05:10:42 EST
Easy to reproduce on 8.0 using mozilla, e.g.

pstack `pidof mozilla-bin | cut -f1 -d' '`

19134: /usr/lib/mozilla-1.0.1/mozilla-bin
pstack signal received: Segmentation fault

same backtrace as above.
Comment 2 Roland McGrath 2003-11-11 17:16:41 EST

*** This bug has been marked as a duplicate of 98162 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:50:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.