Bug 797332 - nfs-utils idmapd exports incompatible conf API calls that conflict with libnfsidmap
nfs-utils idmapd exports incompatible conf API calls that conflict with libnf...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
16
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-24 19:21 EST by friedman
Modified: 2012-05-08 00:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.5-14.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-23 20:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modifications to rpm spec to include new patch (740 bytes, patch)
2012-02-24 19:21 EST, friedman
no flags Details | Diff
Modify conffile.c not to make global symbols visible to plugins (377 bytes, patch)
2012-02-24 19:22 EST, friedman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 705952 None None None Never

  None (edit)
Description friedman 2012-02-24 19:21:02 EST
Created attachment 565697 [details]
Modifications to rpm spec to include new patch

Description of problem:

In conjunction with the patch for bug 705952, rpc.idmapd exports the conf API in nfs-utils:support/nfs/conffile.c, which is incompatible with the similar conf API in libnfsidmap:cfg.c.  For one thing the members of struct conf_trans are not aligned similarly.

This incompatibility predates Fedora 16 but doesn't seem to have been exposed until now.  I'm not sure if it's due to a glibc or binutils change.  But now, the dynamically loadable modules in libnfsidmap are reading a corrupted conf data structure (e.g. it sees the "value" data in the "tag" variable) and consequently rpc.idmapd crashes after the umich_ldap.so module is loaded.   Of course, to see this you have to apply the patch in 705952 or the ldap functionality is completely stubbed out.

Version-Release number of selected component (if applicable):

libnfsidmap-0.24-7.fc16
nfs-utils-1.2.5-3.fc16

How reproducible:

always

Steps to Reproduce:
1. Apply patch 705952 to libnfsidmap library
2. Configure /etc/idmapd.conf to use an ldap server for id mapping
3. run /usr/sbin/rpc.idmapd.

Actual results:

Crashola


Expected results:


A working nfs4 idmapper.


Additional info:

The attach patch limits the visibility of the symbols in the nfs-utils
conffile.c so that they are only visible to programs linked directly to
it.  This forces the objects dynamically loaded via libnfsidmap to use the
functions defined in that shared library instead.
Comment 1 friedman 2012-02-24 19:22:13 EST
Created attachment 565698 [details]
Modify conffile.c not to make global symbols visible to plugins
Comment 2 Steve Dickson 2012-03-15 10:38:02 EDT
(In reply to comment #1)
> Created attachment 565698 [details]
> Modify conffile.c not to make global symbols visible to plugins
Would it be possible to post this patch upstream at Linux NFS Mailing list <linux-nfs@vger.kernel.org> using the appropriate signed-off-by line?
Comment 3 Steve Dickson 2012-03-15 13:00:26 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > Created attachment 565698 [details]
> > Modify conffile.c not to make global symbols visible to plugins
> Would it be possible to post this patch upstream at Linux NFS Mailing list
> <linux-nfs@vger.kernel.org> using the appropriate signed-off-by line?

Never mind I just did.... 
    http://marc.info/?l=linux-nfs&m=133183074005222&w=2
Comment 4 Fedora Update System 2012-03-16 11:21:47 EDT
nfs-utils-1.2.5-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.5-5.fc16
Comment 5 Fedora Update System 2012-03-16 11:24:14 EDT
nfs-utils-1.2.5-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nfs-utils-1.2.5-13.fc17
Comment 6 Fedora Update System 2012-03-22 20:41:04 EDT
Package nfs-utils-1.2.5-13.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nfs-utils-1.2.5-13.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4479/nfs-utils-1.2.5-13.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-03-23 20:26:21 EDT
nfs-utils-1.2.5-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-05-08 00:11:31 EDT
nfs-utils-1.2.5-14.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.