Bug 797507 - Failure install PXE UEFI dracut: FATAL: No or empty root= argument
Failure install PXE UEFI dracut: FATAL: No or empty root= argument
Status: CLOSED DUPLICATE of bug 785815
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-02-26 05:56 EST by Sergiy Bobok
Modified: 2012-03-09 13:06 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 13:06:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dracut: FATAL: No or empty root= argument (131.95 KB, image/jpeg)
2012-02-26 05:56 EST, Sergiy Bobok
no flags Details
screen shot (15.02 KB, image/png)
2012-03-09 01:51 EST, Hongqing Yang
no flags Details

  None (edit)
Description Sergiy Bobok 2012-02-26 05:56:39 EST
Created attachment 565875 [details]
dracut: FATAL: No or empty root= argument

Description of problem: While trying to install Fedora 16 via pxeboot on server with UEFI support I got following error.

[ 2.965035] Initializing XFRH netlink socket
[ 2.965130] NET: Registered protocol family 10
[ 2.965263] Mobile IP06
[ 2.965265] NET: Registered protocol family 17
[ 2.965274] Registering the dns_resoluer key type
[ 2.965755] registered taskstats version 1
[ 2.974176] Inn: No TPN chip found. actiuating TP?—bypass!
[ 2.975691] Magic number: 0:21:88
[ 2.975734] acpi INT3FOD:00: hash matches
[ 2.982725] rtc_cmos 00:07: setting system clock to 2012-02-23 17:05:28 UTC (1330016728)
[ 2.982987] usb 2-1: new high speed USB device number 2 using ehci_hcd
[ 3.134852] Initializing network drop monitor seruice
[ 3.170109] Freeing unused kernel memory: 940k freed
[ 3.186944] Urite protecting the kernel read-only data: 10240k
[ 3.210599] Freeing unused kernel memory: 1260k freed
[ 3.235300] Freeing unused kernel memory: 1584k freed
[ 3.248874] usb 2-1: New USB device found. idUendor=8087. idProduct=0024
[ 3.248877] usb 2-1: New USB device strings: l1fr=0. Product=0. SerialNumber=0
[ 3.249403] hub 2—1:1.0: USB hub found
[ 3.249741] hub 2—1:1.0: 6 ports detected
[ 3.361476] dracut: dracut—013—18.fc16
[ 3.384353] dracut: FATAL: No or empty root= argument
[ 3.400844] dracut: Refusing to continue
[ 3.448365] dracut Warning: Signal caught!
dracut Uarning: Signal caught!
[ 3.479571] dracut Uarning: dracut: FHTHL: No or empty root= argument
dracut Uarning: dracut: FQTHL: No or empty root= argument
[ 3.511697] dracut Uarning: dracut: Refusing to continue
dracut warning: dracut: Refusing to continue
[ 3.545637] usb 2-1.2: new low speed USB device number 3 using ehci_hcd
[ 3.574489] Kernel panic — not syncing: attempted to kill init!
[ 3.590857] Pid: 1, comm: init Not tainted 3.1.0-7.fc16.x86_64 #1
[ 3.606497] Call Trace:
[ 3.622165] [<ffffffff814acb8e>] panic+0x91/0x1a5
[ 3.638093] [<ffffffff8105ae35>] do_exit+0x9e/0x764
[ 3.653957] [<ffffffff810668d4>] ? recalc_sigpending+0x7e/0x82
[ 3.669971] [<ffffffff8105b780>] do_group_exit+0x7a/0xa2
[ 3.685386] [<ffffffff8105b7bf>] sys_exit_group+0x17/0x17
[ 3.701150] [<ffffffff814bc482>] system_call_fastpath+0x16/0x1b

Version-Release number of selected component (if applicable): Fedora 16 

Installation was carried out in accordance with Article Testcase UEFI pxeboot(http://fedoraproject.org/wiki/QA:Testcase_UEFI_pxeboot).

Additional info: Server Dell PowerEdge R210 II.
Comment 1 Harald Hoyer 2012-02-27 04:17:19 EST
seeem like the dhcp server is missing the root path option
Comment 2 Sergiy Bobok 2012-02-27 13:23:27 EST
There were no problems with same install CentOS 6.2 under the same kernel parameters:
        root (nd)
        kernel /vmlinuz
        initrd /initrd.img
Also, no additional options must be specified in accordance with article Testcase UEFI pxeboot(http://fedoraproject.org/wiki/QA:Testcase_UEFI_pxeboot).
Comment 3 Harald Hoyer 2012-02-29 13:39:25 EST
might be related? https://bugzilla.redhat.com/show_bug.cgi?id=798660
Comment 4 Hongqing Yang 2012-03-09 01:28:50 EST
got the same error while preupgrade F16 to F17, after boot into 'Upgrade to Fedora 17', this error occurs.
Comment 5 Hongqing Yang 2012-03-09 01:51:08 EST
Created attachment 568828 [details]
screen shot

since the system die after reboot. please find the error information from the screentshot in attachment
Comment 6 Hongqing Yang 2012-03-09 01:53:23 EST
According to Fedora 17 beta release criteria article 
8. The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation (from any official install medium) of the previous stable Fedora release, either via preupgrade or by booting to the installer manually. The upgraded system must meet all release criteria 

I would like to set this as a beta blocker.
Comment 7 Adam Williamson 2012-03-09 13:06:57 EST
This is a dupe of the famous 785815. We also have 800205 as a 'special case' for preupgrade, because potentially, if anaconda didn't fix this, preupgrade could for its own case.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 785815 ***

Note You need to log in before you can comment on or make changes to this bug.