This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 797772 - Use vga as the default display adapter
Use vga as the default display adapter
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
: 797769 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-27 04:34 EST by Marko Myllynen
Modified: 2014-07-06 15:31 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 795688
Environment:
Last Closed: 2013-10-02 18:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-02-27 04:34:45 EST
+++ This bug was initially created as a clone of Bug #795688 +++

Description of problem:
Libvirt leaves the policy of the default display adapter hardware up to the hypervisor meaning that with QEMU one gets Cirrus instead of vga. However, as can be shown with glxgears vga provides much better FPS rate than Cirrus (these numbers are from RHEL 6.2 host/guest on a Lenovo laptop):

cirrus : 78 FPS
vga    : 260 FPS

Please make vga as the default display adapter in libvirt when using QEMU.

Version-Release number of selected component (if applicable):
RHEL 6.2

Additional info:
With the proposed optimizations in the bugs below the difference is even greater to vga's advantage:

https://bugzilla.redhat.com/show_bug.cgi?id=795685
https://bugzilla.redhat.com/show_bug.cgi?id=795686

--- Additional comment from pm-rhel@redhat.com on 2012-02-21 12:11:42 EET ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from rjones@redhat.com on 2012-02-21 12:30:07 EET ---

libvirt leaves the policy up to qemu, so make this argument
on the upstream qemu mailing lists first.

--- Additional comment from dallan@redhat.com on 2012-02-22 18:57:24 EET ---

Marko, I understand what you're saying, but libvirt explicitly leaves this kind of decision up to either qemu or to management applications using libvirt (e.g., ovirt, virt-manager), so I have to close this as NOTABUG.  I'm sure that there are places where we've failed to follow that rule, but in general we try to honor it.

--- Additional comment from eblake@redhat.com on 2012-02-22 19:38:44 EET ---

(In reply to comment #3)
> Marko, I understand what you're saying, but libvirt explicitly leaves this kind
> of decision up to either qemu or to management applications using libvirt
> (e.g., ovirt, virt-manager), so I have to close this as NOTABUG.  I'm sure that
> there are places where we've failed to follow that rule, but in general we try
> to honor it.

That said, we should probably open bugs against virt-install and virt-manager so that default creation of new guests prefers vga where appropriate, rather than deferring to hypervisor defaults.

--- Additional comment from myllynen@redhat.com on 2012-02-27 11:31:08 EET ---

(In reply to comment #4)
> (In reply to comment #3)
> > Marko, I understand what you're saying, but libvirt explicitly leaves this kind
> > of decision up to either qemu or to management applications using libvirt
> > (e.g., ovirt, virt-manager), so I have to close this as NOTABUG.  I'm sure that
> > there are places where we've failed to follow that rule, but in general we try
> > to honor it.
> 
> That said, we should probably open bugs against virt-install and virt-manager
> so that default creation of new guests prefers vga where appropriate, rather
> than deferring to hypervisor defaults.

I've now proposed this change in the upstream mailing list:

http://lists.nongnu.org/archive/html/qemu-devel/2012-02/msg03274.html

Per Eric's suggestion I'll clone this bug against virt-install and virt-manager.

Thanks.
Comment 2 Dave Allan 2012-02-27 09:04:35 EST
Cole, what do you think?
Comment 3 Cole Robinson 2012-02-27 09:56:13 EST
We already use vga for windows guests by default, but historically linux guests have not worked with vga IIRC, at least not out of the box. If that isn't the case now we could possibly change it, but modern guests should be using qxl anyways, which we default to for recent fedora at least.

So if anything we should be trying to use qxl everywhere rather than vga. But in the absence of people supporting qxl in RHEL asking for the virt-manager default to be changed, I don't think we should be tweaking this now since it's just going to expose a less tested code path.
Comment 4 Cole Robinson 2012-02-28 12:37:03 EST
*** Bug 797769 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2012-03-01 18:36:52 EST
Deferring to 6.4 at least
Comment 6 Eric Blake 2012-03-27 14:00:42 EDT
*** Bug 807415 has been marked as a duplicate of this bug. ***
Comment 8 Cole Robinson 2013-10-02 18:54:15 EDT
As mentioned before, we already use spice everywhere by default, including virt-install these days. And where there's spice, there's qxl. So that should cover this (qxl has a fallback vga mode)

Note You need to log in before you can comment on or make changes to this bug.