Bug 79814 - postgresql-pl should obsolete postgresql-perl
postgresql-pl should obsolete postgresql-perl
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: postgresql (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
David Lawrence
:
Depends On:
Blocks: 79579
  Show dependency treegraph
 
Reported: 2002-12-16 20:53 EST by Enrico Scholz
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-16 14:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-12-16 20:53:39 EST
Description of problem:

The new postgresql-pl package of postgresql-7.3 should obsolete postgresql-perl.
Else, upgrade fails because of conflicting files:

| $ rpm -Uvh postgresql-pl-7.3-2.i386.rpm
| Preparing...                ########################################### [100%]
|         file /usr/lib/pgsql/plperl.so from install of postgresql-pl-7.3-2
conflicts with file from package postgresql-perl-7.2.2-1


Version-Release number of selected component (if applicable):

postgresql-pl-7.3-2
Comment 1 Andrew Overholt 2003-03-04 12:37:46 EST
Assigning to me.
Comment 2 Andrew Overholt 2003-04-16 14:59:52 EDT
This is now fixed in the packages which will be included in rawhide.
Comment 3 David Kaplan 2003-11-17 19:17:31 EST
If you obsolete postgresql-perl, what happens to the functionality
that was contained in the the Pg.pm perl module?

Note You need to log in before you can comment on or make changes to this bug.