Bug 798196 - virt-resize confuses format and output_format variables; using --output-format sets the input format
virt-resize confuses format and output_format variables; using --output-forma...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks: 798197
  Show dependency treegraph
 
Reported: 2012-02-28 04:51 EST by Richard W.M. Jones
Modified: 2012-02-28 05:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 798197 (view as bug list)
Environment:
Last Closed: 2012-02-28 05:35:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-02-28 04:51:36 EST
Description of problem:

virt-resize --output-format raw sets the *input* format to raw.
This is because the code for the --output-format flag is
accidentally setting the format variable (not output_format):

https://github.com/libguestfs/libguestfs/blob/a93d4a9dc1aea6940886c85d4b09f21cbfc80969/resize/resize.ml#L101

(Bug found by Grant Williamson)

Version-Release number of selected component (if applicable):

1.17.8

How reproducible:

100%

Steps to Reproduce:
http://pastebin.com/VpsNjYEa
Comment 1 Richard W.M. Jones 2012-02-28 05:35:53 EST
Fix pushed upstream here:
https://github.com/libguestfs/libguestfs/commit/88ba4da4d6c07762fc95c96ea67019f0ebf4677c

Note You need to log in before you can comment on or make changes to this bug.