Bug 798323 - Unicode characters break CLI when executed from a subshell
Unicode characters break CLI when executed from a subshell
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.1
Unspecified Unspecified
medium Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Katello QA List
: Triaged
: 998028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-28 11:07 EST by Tomas Strachota
Modified: 2014-09-18 11:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: katello-cli-0.2.6-1, katello-cli-tests-0.2.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-25 08:06:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Strachota 2012-02-28 11:07:42 EST
Description of problem:
Unicode characters can cause UnicodeEncodeError anytime they are printed and the cli is executed from a subshell. More precisely every time python can't guess terminal's encoding. This causes troubles with localised strings.


Version-Release number of selected component (if applicable):
katello-cli-0.2.1-1


Steps to Reproduce:
For example:
1. katello environment create --name="žluťoučký_kůň" --prior Library --org ACME_Corporation
2. echo "$(kat environment list --org ACME_Corporation)"
3. see following error and the environment not being listed
error: 'ascii' codec can't encode character u'\u017e' in position 0: ordinal not in range(128) (more in the log file)

Actual results:
Error "'ascii' codec can't encode character"

Expected results:
Command should print localised strings normally.
Comment 4 Tomas Strachota 2012-03-05 05:23:58 EST
Fixed in katello-cli-0.2.4-1

All string inputs are converted to unicode as soon as possible. If there's no encoding settings forced from outside, utf-8 is set as default for stderr and stdout.
Comment 5 Tomas Strachota 2012-03-05 07:03:41 EST
One more update in katello-cli-0.2.5-1
Comment 7 Tomas Strachota 2012-03-05 10:08:56 EST
Forgot to change spec file. It should by all finally fixed in katello-cli-0.2.6-1
Comment 9 Corey Welton 2012-03-08 15:19:48 EST
QA Verified: 0.1.303-1.el6
Comment 10 Hayk Hovsepyan 2012-07-04 11:25:13 EDT
This fix causes another bug which is described here: https://bugzilla.redhat.com/show_bug.cgi?id=836575

Talked to inecas, he is working on this.
Comment 11 Ivan Necas 2012-07-04 13:14:51 EDT
This is a regression after commit 57dfe2924527f1efe66eec9bc53854bc51f27722

Fix is in pull request https://github.com/Katello/katello/pull/286
Comment 15 Ivan Necas 2012-07-04 14:28:15 EDT
Note after more investigation: 

https://bugzilla.redhat.com/show_bug.cgi?id=836575 is not caused by the fix of this bug. See comments there for details.
Comment 16 Mike McCune 2013-08-16 14:03:55 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 17 Og Maciel 2013-08-16 16:34:52 EDT
*** Bug 998028 has been marked as a duplicate of this bug. ***
Comment 18 Bryan Kearney 2014-04-25 08:06:31 EDT
This is a python specific problem which will not be an issue in the new hammer based cli.

Note You need to log in before you can comment on or make changes to this bug.