Bug 998028 - UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-8: ordinal not in range(128)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-8: or...
Status: CLOSED DUPLICATE of bug 798323
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 14:59 EDT by Og Maciel
Modified: 2013-08-16 16:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 16:34:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-08-16 14:59:10 EDT
Description of problem:

Running the headpin cli using a locale other than English shows the following error:

UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-8: ordinal not in range(128)

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.20-1.el6sat.noarch
* signo-katello-0.0.20-1.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch

How reproducible:


Steps to Reproduce:
1. LANG=ru_RU headpin -u $USER -p $PASSWD org list
2.
3.

Actual results:

2013-08-16 14:41:59,578 [ERROR][MainThread] error() @ base.py:204 - 'ascii' codec can't encode characters in position 0-8: ordinal not in range(128)
2013-08-16 14:41:59,578 [ERROR][MainThread] error() @ base.py:205 - Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/katello/client/cli/base.py", line 217, in main
    ret_code = super(KatelloCLI, self).main(args, command_name, parent_usage)
  File "/usr/lib/python2.6/site-packages/katello/client/core/base.py", line 306, in main
    parser = self.create_parser(command_name, parent_usage)
  File "/usr/lib/python2.6/site-packages/katello/client/core/base.py", line 287, in create_parser
    parser = super(Command, self).create_parser(command_name, parent_usage)
  File "/usr/lib/python2.6/site-packages/katello/client/core/base.py", line 140, in create_parser
    parser.set_usage(self.usage(command_name, parent_usage))
  File "/usr/lib/python2.6/site-packages/katello/client/core/base.py", line 266, in usage
    first_line = _("Usage: ") + self._get_usage_line(command_name, parent_usage)
  File "/usr/lib/python2.6/site-packages/katello/client/core/base.py", line 112, in _get_usage_line
    first_line += " <{0}>".format(_("options"))
UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-8: ordinal not in range(128)

Expected results:


Additional info:
Comment 1 Og Maciel 2013-08-16 16:34:52 EDT

*** This bug has been marked as a duplicate of bug 798323 ***

Note You need to log in before you can comment on or make changes to this bug.