Bug 798373 - live image failed to boot in 3 runlevel
live image failed to boot in 3 runlevel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
: 799312 (view as bug list)
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-02-28 13:31 EST by nucleo
Modified: 2013-07-04 09:01 EDT (History)
13 users (show)

See Also:
Fixed In Version: firstboot-17.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 14:52:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nucleo 2012-02-28 13:31:55 EST
Description of problem:
Fedora-17-Alpha live imaged failed to boot in 3 runlevel.

Version-Release number of selected component (if applicable):
Fedora-17-Alpha-i686-Live-Desktop.iso
Fedora-17-Alpha-i686-Live-KDE.iso

Steps to Reproduce:
1. Boot from CD.
2. Add "3" kernel parameter.
3.
  
Actual results:
No login on any of tty's.

Expected results:
Login should be shown for tty1-tty6 

Additional info:
It worked until last F17 nightly images but broken in Alpha.
Comment 1 nucleo 2012-02-28 13:46:13 EST
The same result with "systemd.unit=runlevel3.target".
Comment 2 Michal Schmidt 2012-02-29 07:40:57 EST
Try with "rd.plymouth=0 plymouth.enable=0 3"
Comment 3 nucleo 2012-02-29 07:50:31 EST
Login shown with "rd.plymouth=0 plymouth.enable=0 3" and with "plymouth.enable=0 3" parameters.
Comment 4 Michal Schmidt 2012-02-29 09:19:30 EST
I believe the problem is caused by firstboot-text.service. The service says:

Conflicts=[...] plymouth-quit.service

The result is that there is then nothing that would quit plymouth in multi-user.target.
Comment 5 Martin Gracik 2012-02-29 09:54:10 EST
Where did the firstboot in f17 get from? firstboot in f16 had firstboot-text.service removed, so I have no idea how it got back in f17.
Comment 6 Michal Schmidt 2012-02-29 11:45:32 EST
Looking at the Koji build history ( http://koji.fedoraproject.org/koji/packageinfo?packageID=97 ), I see:

firstboot-16.1-3.fc17  ausil   2012-01-13 20:38:50  complete
firstboot-16.4-1.fc16  mgracik 2011-09-19 20:19:33  complete

Maybe you had removed firstboot-text.service only on the f16 branch and forgot to update the master branch?
Comment 7 Bill Nottingham 2012-03-02 11:59:24 EST
*** Bug 799312 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2012-03-02 12:29:36 EST
Discussed at the 2012-03-02 blocker review meeting, as the 'original' of 799312. Agreed this is an F17 Beta blocker under criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so".

Re-opening because the update is still pending. Martin, you need to create an update via Bodhi for firstboot-17.0-1.fc17 and mark it as fixing this bug instead. Then when the update is pushed stable, this bug will get closed by Bodhi. Just firing a build through Koji isn't enough, it won't make it into the official tree unless you submit it as an update. thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Fedora Update System 2012-03-02 12:56:17 EST
firstboot-17.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/firstboot-17.0-1.fc17
Comment 10 Fedora Update System 2012-03-05 15:58:41 EST
Package firstboot-17.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-17.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2922/firstboot-17.0-1.fc17
then log in and leave karma (feedback).
Comment 11 Adam Williamson 2012-03-19 19:48:51 EDT
TC2 should have the fixed firstboot, so we should be able to test and confirm this is fixed with TC2.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 nucleo 2012-03-19 19:56:29 EDT
TC2 boots in 3 runlevel (KDE i686 cd tested).
Comment 13 Tim Flink 2012-03-20 11:31:47 EDT
F17 Beta TC2 boots into runlevel 3 using KDE x86_64 live usb - setting to verified
Comment 14 Kamil Páral 2012-03-20 11:54:55 EDT
We still have to push firstboot update to stable updates, please provide karma.
Comment 15 Fedora Update System 2012-03-21 14:52:00 EDT
firstboot-17.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.