Bug 799312 - @base and @base-x comp results in a broken system
@base and @base-x comp results in a broken system
Status: CLOSED DUPLICATE of bug 798373
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-02 08:09 EST by Kamil Páral
Modified: 2014-03-16 23:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 11:59:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
booted system screenshot (29.15 KB, image/png)
2012-03-02 08:10 EST, Kamil Páral
no flags Details
used kickstart (352 bytes, text/plain)
2012-03-02 08:11 EST, Kamil Páral
no flags Details
serial console output (32.88 KB, text/plain)
2012-03-02 08:11 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-03-02 08:09:40 EST
Description of problem:
I have used a kickstart to install F17 Alpha x86_64 from DVD. It contained:

%packages
@base
@base-x
%end

The result is that the final system a) doesn't boot to X b) doesn't show any login prompt on any tty c) some weird tool "Text Mode Setup Utility" is started during boot.

Screenshot of the system is in system.png. You can see a Text Mode Setup Utility overwritten by further boot messages. You can't use your keyboard to control that tool.

I have grabbed the tool in full, this is how it looks like:

Text Mode Setup Utility 1.19.11                      (c) 1999-2006 Red Hat, Inc.




                      ┌────────┤ Choose a Tool ├─────────┐
                      │                                  │
                      │   Authentication configuration   │
                      │   Firewall configuration         │
                      │   Keyboard configuration         │
                      │   Network configuration          │
                      │   System services                │
                      │                                  │
                      │      ┌──────────┐  ┌──────┐      │
                      │      │ Run Tool │  │ Quit │      │
                      │      └──────────┘  └──────┘      │
                      │                                  │
                      │                                  │
                      └──────────────────────────────────┘




    <Tab>/<Alt-Tab> between elements  |    Use <Enter> to edit a selection


Full serial console output is also attached.

My guess is that some required packages are missing from base-x comp. Or that this Text Mode Setup Utility broke the boot, but I have no idea what it is and why it runs.


Version-Release number of selected component (if applicable):
Fedora 17 Alpha
anaconda 17.11

How reproducible:
always

Steps to Reproduce:
1. install F17 Alpha x86_64 DVD with the following kickstart
  
Actual results:
no login prompt (neither X nor console)

Expected results:
login prompt (X)

Additional info:
Proposing as F17 Beta blocker due to this release criterion:
"In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied. The firstboot utility must be able to create a working user account"
https://fedoraproject.org/wiki/Fedora_17_Alpha_Release_Criteria
Comment 1 Kamil Páral 2012-03-02 08:10:34 EST
Created attachment 567056 [details]
booted system screenshot
Comment 2 Kamil Páral 2012-03-02 08:11:11 EST
Created attachment 567057 [details]
used kickstart
Comment 3 Kamil Páral 2012-03-02 08:11:32 EST
Created attachment 567058 [details]
serial console output
Comment 4 Bill Nottingham 2012-03-02 11:59:24 EST
That sounds like a non-useful kickstart. (If you try to use arbitrary combinations of groups, it's up to you to get them right.)

base-X doesn't include a desktop, and never has. The text mode tool you're seeing is text mode firstboot.

The fact that it doesn't boot correctly is likely a firstboot bug with the systemd service file.

*** This bug has been marked as a duplicate of bug 798373 ***

Note You need to log in before you can comment on or make changes to this bug.