Bug 79848 - Crashes when attempt tp edit device hardware device
Summary: Crashes when attempt tp edit device hardware device
Status: CLOSED DUPLICATE of bug 76226
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network   
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-12-17 15:15 UTC by Gerald Jensen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:50:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Jensen 2002-12-17 15:15:44 UTC
Description of problem: 
 
Crashes when attempt to edit device. Devices are 3COM 3C69x and Intel 
EtherExpress pro 100B NIC. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always (2 machines .. both get same result) 
 
 
Steps to Reproduce: 
1. Open Network Configuration GUI 
2. Select Hardware tab 
3. Select a listed device 
4. Click Edit 
     
Actual results: 
Unhandled exception message 
 
 
Expected results: 
Configuration dialog 
 
 
Additional info:

Comment 1 Gerald Jensen 2002-12-17 15:16:52 UTC
 
Traceback (innermost last): 
  File "/usr/sbin/neat", line 1402, in ? 
    gtk.mainloop() 
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop 
    _gtk.gtk_main() 
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__ 
    ret = apply(self.func, a) 
  File "/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked 
    self.showHardwareDialog(type, true) 
  File "/usr/sbin/neat", line 1269, in showHardwareDialog 
    dialog = ethernetHardwareDialog(hw) 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py", 
line 75, in __init__ 
    self.setup() 
  File 
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py", 
line 135, in setup 
    list.append(modInfo[i]['description']) 
KeyError: description 
 
Local variables in innermost frame: 
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84d97d0> 
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 
'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA 
wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 
wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan 
NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 
'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com 
EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron 
E2100', 'NE1000, NE2000, and compatible', 'Intel EtherExpress Pro 100B', 
'Allied Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 
21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 EISA', '3Com 
3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 
'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 3200', 
'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments 
SB1000'] 
self: <netconfpkg.gui.ethernethardware.ethernetHardwareDialog instance at 
84c1878> 
i: defxx 

Comment 2 Harald Hoyer 2003-01-09 13:28:45 UTC

*** This bug has been marked as a duplicate of 76226 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:50:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.