Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 76226 - (rcn:135:setup) TB ethernethardware:135:setup
TB ethernethardware:135:setup
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 76376 76435 77038 77190 78007 78183 78298 78320 78464 78512 78665 79030 79159 79269 79349 79724 79848 80772 80837 81105 82813 83299 85465 85624 86340 86363 86501 88258 88559 88762 105961 (view as bug list)
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-10-18 10:00 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-06 10:02:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:257 high SHIPPED_LIVE Updated redhat-config-network package available 2003-05-06 00:00:00 EDT
Red Hat Product Errata RHBA-2002:267 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-02-07 10:19:58 EST

  None (edit)
Description Need Real Name 2002-10-18 10:00:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
An exception occured when I used the redhat network configuration tool to edit
the hardware configuration. When the network configuration tool started a
warning occured:

"eth0 has an alias to module eepro100 in modules.conf, instead of currently
loaded module orinoco_cs." 

This is refering to my Lucent WavLan card. When attempting to edit the hardware
configuration for eth0 the following exception occurs:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1402, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1248, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1269, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware
.py", line 75, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware
.py", line 135, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84cd6a0>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 'S
MC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco PCMCIA wireless
(alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 wireless', '
Intel EtherExpress/1000', 'PCI NE2000 clones', 'MiCom-Interlan NI5010', '3Com 3c
515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 'AT1500, HP J2405A, mo
st NE2100/clone', 'MyriCOM MyriNET SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitac
hi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compa
tible', 'Intel EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBI
L IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 1
6i/32 EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun B
igMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel Communications Model 32
00', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instrume
nts SB1000']
self: <netconfpkg.gui.ethernethardware.ethernetHardwareDialog instance at 84fc7d
0>
i: defxx




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above
	

Additional info:
Comment 1 Harald Hoyer 2002-10-23 05:31:10 EDT
*** Bug 76376 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2002-10-23 05:34:42 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.
Comment 3 Harald Hoyer 2002-11-04 07:47:41 EST
*** Bug 77038 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2002-11-15 09:38:43 EST
*** Bug 76435 has been marked as a duplicate of this bug. ***
Comment 5 Harald Hoyer 2002-11-17 09:22:10 EST
*** Bug 78007 has been marked as a duplicate of this bug. ***
Comment 6 Sergio Monteiro Basto 2002-11-17 21:01:42 EST
1.0.1-1 correct the problem for me ....
Comment 7 Need Real Name 2002-11-18 04:44:09 EST
With 1.0.1-1, new error (368).
When install:
reddhat-config-network-1.0.1-1 conflicts with file from package
redhat-config-network-1.0.0-1

>rpm -ivh --force  redhat-config-network-1.0.1-1.i386.rpm

when I start the redhat network configuration:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1440, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 237, in __init__
    self.load()
  File "/usr/sbin/neat", line 276, in load
    self.loadProfiles()
  File "/usr/sbin/neat", line 285, in loadProfiles
    profilelist = getProfileList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py",
line 404, in getProfileList
    PFList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py",
line 91, in load
    prof.HostsList.append(host)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ProfileList.py",
line 965, in append
    item.setParent(self)
AttributeError: setParent

Local variables in innermost frame:
self: [<netconfpkg.genClass.Host instance at 84c1360>]
item: <netconfpkg.genClass.Host instance at 84c1360>
Comment 8 Harald Hoyer 2002-11-18 06:09:30 EST
> When install: reddhat-config-network-1.0.1-1 conflicts 
> with file from package redhat-config-network-1.0.0-1
> rpm -ivh --force  redhat-config-network-1.0.1-1.i386.rpm

You should not do this!!! Use upgrade!
rpm -Uvh redhat-config-network-1.0.1-1.i386.rpm
Comment 9 Harald Hoyer 2002-11-21 07:08:30 EST
*** Bug 78298 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2002-11-25 05:50:28 EST
*** Bug 78512 has been marked as a duplicate of this bug. ***
Comment 11 Harald Hoyer 2002-11-25 05:53:21 EST
*** Bug 78464 has been marked as a duplicate of this bug. ***
Comment 12 Harald Hoyer 2002-11-27 06:58:10 EST
*** Bug 78665 has been marked as a duplicate of this bug. ***
Comment 13 Harald Hoyer 2002-12-05 05:05:44 EST
*** Bug 79030 has been marked as a duplicate of this bug. ***
Comment 14 Harald Hoyer 2002-12-09 05:10:05 EST
*** Bug 79159 has been marked as a duplicate of this bug. ***
Comment 15 Harald Hoyer 2002-12-09 06:57:16 EST
*** Bug 79269 has been marked as a duplicate of this bug. ***
Comment 16 Harald Hoyer 2002-12-11 06:19:18 EST
*** Bug 79349 has been marked as a duplicate of this bug. ***
Comment 17 Harald Hoyer 2002-12-16 04:36:42 EST
*** Bug 79724 has been marked as a duplicate of this bug. ***
Comment 18 Harald Hoyer 2003-01-09 08:28:35 EST
*** Bug 78320 has been marked as a duplicate of this bug. ***
Comment 19 Harald Hoyer 2003-01-09 08:28:53 EST
*** Bug 79848 has been marked as a duplicate of this bug. ***
Comment 20 Harald Hoyer 2003-01-09 08:31:19 EST
*** Bug 80772 has been marked as a duplicate of this bug. ***
Comment 21 Harald Hoyer 2003-01-09 08:31:26 EST
*** Bug 80837 has been marked as a duplicate of this bug. ***
Comment 22 Harald Hoyer 2003-01-09 08:31:42 EST
*** Bug 81105 has been marked as a duplicate of this bug. ***
Comment 23 Harald Hoyer 2003-01-27 10:27:30 EST
*** Bug 82813 has been marked as a duplicate of this bug. ***
Comment 24 Sergio Monteiro Basto 2003-02-04 16:51:18 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=82435 the bug 82435 is also
reported for me.

I note that when I change th configuration active button stop to works,
sorry I dont have time to explain better.
Comment 25 Harald Hoyer 2003-02-05 04:04:15 EST
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-3
fixes your problem for r-c-n
Comment 26 Harald Hoyer 2003-02-05 04:05:45 EST
oops
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1
of course :)
Comment 27 Sergio Monteiro Basto 2003-02-06 08:15:13 EST
of course I am reporting the bug, on redhat-config-network-1.0.3-1.i386.rpm
when I change the configuration active button stop to works,
sorry I dont have time to explain better.
Comment 28 Harald Hoyer 2003-02-06 08:26:54 EST
this is intended... you have to save first...
Comment 29 Harald Hoyer 2003-02-07 07:47:29 EST
*** Bug 83299 has been marked as a duplicate of this bug. ***
Comment 30 Sergio Monteiro Basto 2003-02-07 19:27:19 EST
yes
Comment 31 John Flanagan 2003-02-14 16:04:19 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html
Comment 32 Harald Hoyer 2003-03-10 09:05:56 EST
*** Bug 85465 has been marked as a duplicate of this bug. ***
Comment 33 Harald Hoyer 2003-03-10 09:15:28 EST
*** Bug 85624 has been marked as a duplicate of this bug. ***
Comment 34 Harald Hoyer 2003-03-20 11:20:23 EST
*** Bug 86340 has been marked as a duplicate of this bug. ***
Comment 35 Harald Hoyer 2003-03-21 07:22:32 EST
*** Bug 86363 has been marked as a duplicate of this bug. ***
Comment 36 Harald Hoyer 2003-03-25 04:08:04 EST
*** Bug 86501 has been marked as a duplicate of this bug. ***
Comment 37 Harald Hoyer 2003-03-25 05:16:53 EST
*** Bug 77190 has been marked as a duplicate of this bug. ***
Comment 38 Harald Hoyer 2003-03-25 05:19:15 EST
*** Bug 78183 has been marked as a duplicate of this bug. ***
Comment 39 Harald Hoyer 2003-04-08 05:40:14 EDT
*** Bug 88258 has been marked as a duplicate of this bug. ***
Comment 40 Harald Hoyer 2003-04-13 17:50:46 EDT
*** Bug 88762 has been marked as a duplicate of this bug. ***
Comment 41 Harald Hoyer 2003-04-14 08:59:45 EDT
erratum still not released...
Comment 42 Harald Hoyer 2003-04-14 09:41:06 EDT
*** Bug 88559 has been marked as a duplicate of this bug. ***
Comment 43 Sergio Monteiro Basto 2003-04-15 14:32:21 EDT
of course I am reporting the bug, on redhat-config-network-1.0.3-1.i386.rpm
when I change the configuration active button stop to works,
"this is intended... you have to save first..."
yes, I save first and cannot active the new configuration.
for example:
I have eth0 actived , and add eth0:1, desactive eth0, save configuration, and
when I try to active and nothing is done.
so I close redhat-config-network
and do service network start.
Comment 44 Harald Hoyer 2003-05-06 10:02:27 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-257.html
Comment 45 Harald Hoyer 2003-10-24 12:03:26 EDT
*** Bug 105961 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.